General discussion

Locked

installing linux on seagate SATA drive

By ransinha2004 ·
my pc consist of AMD 64 bit processor with MSI motherboard and that is compatable to AMD 64 and seagate SATA hard drive, for windows installation it is fine and speed is very fast but while installing linux either mandrake 9/redhat 9.0 it doesn't go well and give the message that an error occured no hard drive found, so for this linux installation what will be my bios setting and one thing more in the begining pc unable to recognise the hard drive but any how this problem is shorted out but linx installation is still a problem for me please suggest.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by david.planchon In reply to installing linux on seag ...

I'm just going on top of my head here since I am not familiar with either distros.

First question that comes to my mind is what is your drive set to in the BIOS and does your BIOS have a setting for : "Plug and Play OS"?

Then on the install, at the beginning on the first splash screen of the install for linux do you have a choice to use "install with APCI enabled", "install in safe mode" and maybe some other options?

which one do you choose?

It seems to me that something in the bios isn't setup properly.

let us know and good luck!

Collapse -

by david.planchon In reply to installing linux on seag ...

i'm not familiar with mandrake or red hat anymore -haven't used them in several years but off the top of my head 2 things to check:
1) in your bios your HDD settings for SATA drive and you might also have an option called "Plug and Play OS" with a yes/no possibility.
Try toggling those.

2) at the very first splash screen of the linux install most distros will ask if you want a ACPI enabled install or a safe mode install.... which one are you choosing.

Collapse -

by Suramya In reply to installing linux on seag ...

You need to install the SATA driver before installing to allow Redhat to detect the SATA Drive.

To do it you first need to download the driver disk image for your SATA controller from the web and create a driver disk. (Try a web search <SATA controller name> + linux + drivers)

Once you create the drisk start the install and enter the following option at the installation prompt: 'linux expert' (Without the quotes) and press enter.

Linux will then ask you if you have any driver-disks, answer yes after inserting the floppy you created in the floppy drive. Once the driver is installed properly continue the installation as usual.

Hope this helps.

- Suramya

Collapse -

by ITPirate In reply to installing linux on seag ...

Rasinha,

I have the same problem. I also have an AMD 64 bit processor and seagate SATA hard drive. Could you tell me how you fixed the issue?

Thanks,
Tim

Collapse -

by ptsd21 In reply to installing linux on seag ...

my pc consist of INTEL P IV 3.0 , INTEL 915 GVWB, 512 DDRAM, Seagate Barracuda ST380817AS 80GB Hard Drive.While installing RH 9.0 it gives no hard drive found error. Searched many sites for disk Drivers..can u suggest me some sites??

Thanks

Dhanunjay

Collapse -

by samik In reply to installing linux on seag ...

According to the ptsd21@... user's question...

I have the same sata controller and the same HDD...
At the first I also started to search a driver for sata controller, but eventually I have been assumed to change the IDE configuration from my BIOS...
I changed it to the Compatible mode, with the parameters P-ATA+S-ATA..
And the Red Hat 9.0 recognized the HDD. So You need to change it...
After that when You will close to finish Your installation, You must put the Red Hat boot from the first boot sector (it will be asked), and make it with GRUB (not with Lilo)...After that mount Your Floppy and copy the linux.bin file to the Floppy. After that copy it to Windows c:/, and edit the boot.ini file writting "c:/boot.ini"
After that it will be work with two OS...

Collapse -

by samik In reply to

Sorry... Edit it not with "boot.ini", but "c:/linux.bin"

Back to Linux Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums