General discussion


Insufficient privileges

By tutor ·
I have 4 of 7 workgroup computers that have decided NO account has sufficient privileges to update Windows, change IP addresses or log into WMI on computer management.

They are NOT part of a domain, only a workgroup. All are WIN XP Pro, SP2.

The problem started when a program was installed that requires ICS on one computer for a VPN to an external server. Technical support from the software company had us make several changes in the attempt to get connected, which finally worked. Now attempts to change settings are met with errors even with the main administrator account in safe mode.

Windows Firewall "Advanced" tab says "The network connection settings have become corrupted." Attempting to reset to defaults results in nothing happening, since any attempt to change IP settings gives the "insufficient privileges" message.

Attempting to change the IP address results in ?insufficient privileges?. Trying to check security settings in WMI under computer management results in "WIN32: Access Denied" and logon failed.

I have tried using the netsh commands to reset the TCP/IP. I've changed the ForceGuest settings in the registry (per research here and Microsoft). I've tried having the Guest account on and off. I tried removing all connections to other computers (mapped drives), as well as the obvious of uninstalling the program that started this.

What is really confusing is that 3 computers work and 4 don't. I have compared every setting in anything I researched between a working computer and the ones that don't work and can't find any differences. Even MORE befuddling is that 2 computers were not working 4 weeks ago and in the last 2 weeks have started updating Windows and will let me see/change IP settings again. All computers have had the same program updates applied. (The 3rd computer was out of use for 2 months so status was unknown.)

Symantec online shows no virus or spyware.

I'm hoping someone can come up with an answer short of wi

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

by BFilmFan In reply to Insufficient privileges

And these systems are not infected with a virus?

I would advise you to break the admin password with one of the methods abounding on the net and then check these systems closely with a virus scanner.

Collapse -

by tutor In reply to

Poster rated this answer.

They have had Symantec Corporate Anti Virus running for over a year with no virus showing. I also checked with the online virus check and found no threats - virus OR sypware. (As stated in my question!) While local antivirus can be compromised, I have never seen the online check compromised.

I don't need to "break" the password to the defualt admin account, as I have it and can sign on. How would breaking that password change online virus scan results?

Collapse -

by CG IT In reply to Insufficient privileges

Well, as you said your self, the problem started when you installed "a program" that requires ICS for VPN. Also, you said the software company that made the program had you make changes, I would call them. I doubt anyone here could give suggestions for a resolution since we do not know what program it is that was installed and what changes that software company had you do.

I would call them

Collapse -

by HAL 9000 Moderator In reply to Insufficient privileges

The simple answer is that the software and changes you have made are causing the problem. This can either directly affect the altered computers or it may allow then to run perfectly and adversely affect the untouched computers.

Something that has been done here is adversely affecting the ability to use Admin Rights on these computers and by the sounds of your description I would be asking the software company who supplied the program and instigated the changes for an answer.

Just a word of caution on the Symantec Corporate AV software I was at a place yesterday who uses it and one of the systems had an infection which Norton's was reporting but couldn't remove so I went there to fix the thing up no big problem there but the infection was released on 19 August 2003 and had somehow infected a computer several years latter. So while it is good it isn't infallible either particularly as some of the "Script Kiddies" write programs to bypass this application and either disable it or become invisible to it so I wouldn't be dismissing out of hand some form of infection.

But my first gut reaction would be the installed software for the VPN and thew changes that where made and since you haven't listed the actual program or the changes it is impossible to actually answer your question so it really belongs in the hands of the supplier of the product that you installed and changed the original setup to sort out.


Collapse -

by HAL 9000 Moderator In reply to

I should have read all of the answers to your question CG IT has it right ring the makers of the product and ask then for a fix.

Collapse -

by timdaniel In reply to Insufficient privileges

I have been researching exactly the same problem on our school network for weeks now. The problem is to do with SP2 and has many additional effects such as no network connections in the network connections dialog box, inability to use windows update, inability to load new software etc.
If you rollback to SP1 by uninstalling SP2 from add/remove programs you will probably find things are OK, unfortunately I still don't know what is causing the problem.


Collapse -

Anyone have a fix?

by c.ashour In reply to

I seem to be experiencing the exact same problem, the thing is I don't know when it started so it's hard to pinpoint what software is causing this.

-Network settings are inaccessible. Permission problem

-When I load the properties up I see the lan status but it's resolution is larger than what my screen is set for, therefore I don't have access to the buttons inside since the resolution is larger that the screen window.

-Firewall has errors as mentions

This machine was installed with sp2 already in place on the cd, therefore I can not remove the sp2.

Any help is appreciated.

Computer has no viruses or spyware.

Collapse -


by c.ashour In reply to Anyone have a fix?

OK guys I'm happy to say I found the problem out! and I fixed it and it works now.

this has something to do with dcom and WMI
you need to repair it.

follow this link and follow the instructions and you should get up and running.

Collapse -

Thank you

by XT John In reply to I FOUND THE SOLUTION!!!

for posting the answer. It's sad to see these issues lay around unresolved:) Glad you took the time to share...

Related Discussions

Related Forums