Question

  • Creator
    Topic
  • #2140764

    Integrated GPU apparently bad; added GPU card; still no signal to monitor

    by ptools ·

    No signal to monitor
    Checked cable; tried various cables
    Been thinking about replacing old monitor, bought a new one (Dell P2219H)
    Still no signal; deduced integrated GPU was bad
    Purchased SAPPHIRE pulse RADEON RX580 & power cable
    Installed card; connected to power supply (REVOLUTION Xt) 12 pin to 8 pin at card
    No signal at monitor, so impossible to install drivers

    Appreciate any help.
    Thanks,
    Pat

You are posting a reply to: Integrated GPU apparently bad; added GPU card; still no signal to monitor

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our Community FAQs for details. All submitted content is subject to our Terms of Use.

All Answers

  • Author
    Replies
    • #2416093

      Specs

      by ptools ·

      In reply to Integrated GPU apparently bad; added GPU card; still no signal to monitor

      Windows 10 64-bit

      Asus Z170-A
      Intel Core i7 processor
      64GB dual-channel DDR4 2133

      Sixth-generation, four core/eight thread Core i7 processor

      500GB SSD M.2 550 system drive, with 3D V-NAND technology
      2TB 6Gbits/s SATA audio drive

    • #2416092

      Member profile doesn’t seem to have details.

      by rproffitt ·

      In reply to Integrated GPU apparently bad; added GPU card; still no signal to monitor

      Some PCs won’t boot with that card (PCs without EUFI BIOS.)

      I can’t check this out because I don’t see what PC or motherboard we have here.

    • #2416089

      A few thoughts.

      by rproffitt ·

      In reply to Integrated GPU apparently bad; added GPU card; still no signal to monitor

      1. What profle? I looked at your member profile and from what I see, no PC details. TR Forums work differently so maybe you see it and we don’t.

      2. How did you determine the integrated graphics was the only failure?
      Once in a while I will get a machine that your story is told and we find it’s a bad motherboard. Or they forgot to plug in the ATX12V connection. Or something else.

      3. The board and CPU looks to be from 2015 so a low CMOS/RTC battery could cause it to power up but do nothing. I’d pop in a fresh battery, do the CMOS/RTC reset noted on page 1-19 of the English (2015) manual at https://www.asus.com/us/Motherboards/Z170-A/HelpDesk_Manual/

      Copy from manual is blocked so you must read that page as it’s not just a jumper and done!

      Again, I worry that it’s not just the failure you noted above.

      • #2416084

        1. 2. 3.

        by ptools ·

        In reply to A few thoughts.

        1. When I set up my profile, there were fields for bio, interests, current technologies, etc. I entered PC specs @ current tech.
        But I don’t see any of that when I look at my profile. Click the EDIT button & the fields are there…

        2. I’m no tech BY ANY MEANS. When monitor was not getting signal from device, I checked cable connections, tried different cables, to no avail. Having been looking at buying a new monitor, I went ahead. Still no signal. My inexperienced assumption was that the integrated GPU had gone bad, so I ordered the card & put it in. Ran power cable from GPU 12pin to 8 pin at card. I purchased the computer new in 2015 & have never messed with ATX12V connection.

        Q: when she boots up, should the fans in the card start up? They don’t. Assumed they may come on when monitor IS getting signal…

        3. I just replaced the CMOS battery & will follow the link you’ve provided.

        Thanks!

      • #2416080

        CMOS RTC reset

        by ptools ·

        In reply to A few thoughts.

        Well, I followed the instructions on pg 1-19.

        First method: unplug power; short circuit (bridge with metal object) pins 1-2, 5-10 seconds; plug in power, turn on, press delete to enter BIOS & re-enter data. Still, no signal to monitor, so no access to BIOS.

        ‘If that method doesn’t work’: unplug power, remove CMOS battery, “move” pins again (assumed = short circuit again), replace battery, plug in power, turn on. Still, no signal to monitor.

        Again, fans in GPU card do not come on. Should they?

        Other fans do. While booting, seems to sound normal; at least one light on the board comes on for a couple-few seconds. Seems to be booting up. Still, no signal from device to monitor. (But what do I know?)

        Looking forward to further guidance.

        Thank you.

        • #2416061

          As it sounds.

          by rproffitt ·

          In reply to CMOS RTC reset

          It sounds like the PC itself has deeper problems.

          As to the GPU fans, if this card needs a power supply connection be sure to check that out.

          But as it sounds so far it does not sound as if it was just the onboard graphics had failed but something bigger than that.

        • #2416060

          Deeper problems

          by ptools ·

          In reply to As it sounds.

          Okay. Thanks a lot. I did run power from the power supply to the card.

          Looks like I’ll be dropping her at a repair shop this afternoon.

          I really appreciate your help.

          Thanks very much. Stay safe & well.

          Pat

Viewing 2 reply threads