Question

Locked

Intermittent internet connection RRAS

By powster2k7 ·
Hi Guys,

How we doin?

Ok got a small problem with my RRAS server.

Issue: Clients intermittenly loose internet connection and no inbound traffic is allowed:

Temp. solution: To restart RRAS services

Details; Once the RRAS has been restarted then clients are able to access internet and able to allow inbound remote desktop connection.

We are using multiple public IP addressing. We have tried a number of solutions; replace the router, reconfigured RRAS ; trailed through pages of logs but with no success.

When the connection drops, I loose RDP and unable to ping the server. However, when the service is restarted all is well for a few hours.

I appreciate that this is a breif overview but if you guys requrie more information then please let me know.

I would also appreciate if someone who has encountered this problem also please get in touch.

It would also be apprecited if someone who has successfully set up a RRAS with no issue using 5 multiple ip addressing that has been provided by BT.

For your reference: Secondary Lan has been setup in the router and appears to be working.

This conversation is currently closed to new comments.

13 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Subnets?

by sidekick In reply to Intermittent internet con ...

If the client's ip address and the IP address it get's from RRAS are in overlapping subnets, that can cause a problem, though a never seen it cause this specific problem. Also, try turning the "use gateway on remote network" on or off to see if that helps.

Collapse -

RRAS issue

by powster2k7 In reply to Subnets?

Hey,

Thanks for the reply.
OK am going to recondifuge the RRAS on saturday.

Am nit sure I am following when you say they are on overlapping subnets. It would be great if you could elloborate a bit more.

I will try the other soluton you have suggested and feedback the outcome.

Cheers Jai

Collapse -

overlap

by sidekick In reply to RRAS issue

By overlapping subnets, I mean, for example, if the client computer's local network is using 192.168.1.x subnet, and the network that it is connecting is also using 192.168.1.x, or something like 192.168.x.x.

Collapse -

overlap

by powster2k7 In reply to overlap

Ah right I see what you mean!

I have 2 NICS installed and one is using one of the public multiples.

One of the NICS has 2 RJ45 ports which one is not utilised.

I am going to utilise this port and use that for my VPN clients.

So the setup I will have will be three interfaces; one for the lan, one for wan and one dedicated to the public ip address.

What would be your thoughts on that?

Cheers

Jai

Collapse -

hard to say

by sidekick In reply to overlap

As long as it doesn't make the problem worse, it can't hurt to try it.

I was rereading the original post. Is the LAN going through the RRAS server to get out to the internet? If so, would setting up the LAN to go directly to the firewall or router (whatever the RRAS is using as the next hop to the internet) be an option. You would just need to forward the incoming VPN traffic to the RRAS server. I'm not sure how everything is set up, so I can't say whether or not this would be possible or create a security issue.

This may or may not fix the problem you are having, but at least if the problem continues the LAN wouldn't be brought down with it.

Collapse -

I've got the same problem

by danieljokinen In reply to Intermittent internet con ...

Hi,

I've got the same problem as you do, only my network doesn't work for that long after restarting RRAS (goes down after all from 20 min to 2 hours).

I've had this network running for quite a while though, well over a month anyway. This last monday it started though. At first clients couldn't reach internet. Then when I restarted the RRAS service everything went back to normal, for a while. I've tried disabling the RRAS completely and configured it all over again but it makes no difference.

This network is 'overlapping'. There are 2 VLAN's that use 192.168.1.x and 192.168.5.x that connect to the server. Then RRAS NAT's it to the "uplink" network which is 192.168.0.x, then to the WAN router that goes out on the internet.

The setup is kind of non-standard because there's a telephony SIP system (installed much later than the server) involved which needs to be on DMZ to be able to work properly, therefore we needed to add a router with DMZ host properties to be able to accomodate it. Though it's not really common practice, it's still been working perfectly for well over a month.

I realise it still could be part of the problem, but as it's been working I'm reluctant to think so. I'd much rather resort to network cards, corrupt files or anything else software-related.

One thing I think is rather odd is that the internal interface in RRAS being non-operational. There's nothing in the event viewer about any sort of error, so I'm not sure that's an issue.

Anyone got any suggestions?

Collapse -

Update

by danieljokinen In reply to I've got the same problem

Okay, now I've had time to try a few things. Firstly, I replaced the network card and set everything up exactly as before, but to no avail. After that I put the server on a direct internet IP, leaving the 'uplink' network 192.168.0.x. At this point the server is acting router towards the internet, and it only seems to make the problem even worse.

I'm thinking virus or malware at the moment, so I've started a major virusscan of the entire network. I've also called our ISP in hope that they could tell me anything that'd help me trace what's going wrong.

Looking at this from the simplest possible angle it seems that the RRAS binds a connection to some strange node which makes the internet traffic go down the drain. Then when using ipconfig /release it releases this binding and internet goes back up. Sounds very much like a virus... but then again I said the same thing about the network card :)

Guess it's only to continue excluding possibilities until you stumble upon the problem.

Collapse -

Outage

by powster2k7 In reply to Intermittent internet con ...

Hey Guys,

Thanks for your help on this.

I have reconfigured it all and still having the same problems.

i have rec-configured RRAS only to do the NAT to try and eliminate the source of the problem.

Collapse -

Any progress at all?

by danieljokinen In reply to Outage

Hi, have you had any progress at all with this? Any difference in anything you try?

My problem got worse since I configured the server to be connected straight to the internet, instead of behind a router as before. Other than that I'm all out of ideas. I've involved the ISP in this, hopefully they could give me some sort of indication of some sort.

Collapse -

No Progress

by powster2k7 In reply to Any progress at all?

Even with RRAS configured as a NAT it still drops the connection.

I might have to get a 3rd party engineer to look at this. There is something that we are missing. Have you configured DHCP and DNS on your server?

Cheers

Jai

Back to Networks Forum
13 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums