Question

Locked

internet explorer is slow to open

By bernadetten ·
When I turn my computer on, it takes 4-5 minutes for it to open. When I click on internet explorer, it takes about 3 minutes to open. I do daily maintenance to clear cache etc., so have no idea why this is so slow. My high speed internet is not "high" speed. Anyone know how to remedy this problem?
Bernadette N

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

1st thing to do

by animatech In reply to internet explorer is slow ...

Is to get 1 of the freeware anti virus applications (AVG, Avast just to name a couple ) and run a virus scan on your PC.
Alternatively you can log into Mcafee web site and run an online scan (I think you can do that with Norton as well).
2nd thing is to grab a spyware application such as SpyBoot Search & destroy, Ad Aware (Or any other that you heard of), Run a scan and delete all the nasties.
After you have done that then check your PC if still slow open "Task Manager" via ctrl - alt - delete go to "Process" tab and check which process is taking the most CPU, Memory.
If you don't recognize the name just google it.
If should not be there then take it off - -Google will direct you to sites that will give you a good advise.

If it is not any of the above then you might have a hardware problem and you best off starting to check your event viewer (just go to Start - Run and type in - eventvwr).
Check you system & application tabs for any errors.

remember to always back up you important data before you do any of the above.

Let me know if this helped

Collapse -

Don't listen to these fools

by davisro In reply to internet explorer is slow ...

THE PROBLEM IS WITH ADD-ON'S. Go to START>ALL PROGRAMS>ACCESSORIES>SYSTEM TOOLS>INTERNET EXPLORER(No Add Ons) and you're problem will go away...fools

Collapse -

Google Toolbar

by yakster In reply to Don't listen to these foo ...

I was having this problem (IE6 frozen for 90 seconds after start) on Win2K machine.

Uninstalling Google Toolbar was the only thing that resolved this.

-Chris

Collapse -

It worked!!

by kevannberg In reply to Google Toolbar

After hours of searching the internet and trying so many different fixes... removing and uninstalling the google toolbar was the only thing that worked!! Who would have thought it was that easy!!

Thank you again....

Collapse -

hallelujah!!

by markd28 In reply to It worked!!

finally - thanks kevannberg

Collapse -

Google Toolbar solved for me as well!

by jadams In reply to Don't listen to these foo ...

I have been running google tool bar for a couple years - no ideas what changed but the removal fixed my 120 second IE loading problem!

Collapse -

Thanks for this fix

by mikegipps In reply to internet explorer is slow ...

Thanks for this fix. My computer was taking almost 2 minutes to open Internet Explorer. Removing google from the tool bar solved the problem. The solution is simple once you know the cause. Access the IE toolbar and select: View/toolbar/then uncheck the google toolbar.

Collapse -

Ditto on unchecking the "Google" tool bar option

by ajbarlows In reply to Thanks for this fix

Right-click on Google tool bar and uncheck the selection.

Collapse -

simple fix, worked for me

by jblvmoll In reply to internet explorer is slow ...

I suddenly lost ability to access Google, and access to certain sites was agonizingly slow. Various answers were tried with no luck. Contacted cable provider, they said modem "needs to be reset". Tech noted it had been over 140 days since last reset. I unplugged power to both modem and router (Linksys). After about 15 seconds, plugged in modem power, then plugged in router power. Like magic fast fast fast connections, again, whew. The tech told me that the "reset" should be done about every month. Unplug power to both router and modem, wait maybe 15 seconds, then FIRST plug in modem, then router. This certainly was a great lesson for me, and I now have it as a monthly reminder in my calendar.

Collapse -

Internet Explorer is slow to open

by mike-holden In reply to internet explorer is slow ...

This problem has been around for a long time and is still with us, even in IE9 on Windows 7. This simple procedure fixed it for me. It reduced the time taken to open IE from 20 seconds to 2 seconds.
In Internet Explorer click on the Tools menu, then Internet options - Connections - LAN settings. Uncheck the Automatically Detect Settings box. Close and reopen IE.
There seem to be no detrimental side effects.

Back to Browser Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums