Question

Locked

Internet printing problem

By rob.hill ·
Hi,

I am trying to configure internet printing using IIS7. I have installed the print server role on server 2008 and shared a printer.

From the users machine I have typed in the address of the printer in explorer and have been given the option to connect to the printer.

The first problem was that users aren't given permission to install web based printers and for some reason administrator isn't given the option to connect. I have got round this for the minute by giving the user more privileges. But when I try to connect to the printer, the status bar appears to get right to the end before I get the following error message:

Installation of printer failed - Parameter is incorrect.

Anyone else come across this - any help would be much appreciated!

Thanks

Rob

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Collapse -

Permissions

by Wizard-09 In reply to Internet printing problem

What persmissions have you given the users on the print server, when you installed the printer on the print server goto the permissions tab then add the users in which require the access.

Collapse -

Thanks

by rob.hill In reply to Permissions

Thanks for that - got a hol tomorrow so will test it Fri

Cheers

Rob

Collapse -

Argument Invalid

by rob.hill In reply to Thanks

It appears that part of the problem was I tried to connect a windows 2000 machine to server 2008 to perform the internet printing. I have since tried using an XP machine and for the time being have allowed all users permission to connect to the internet printer.

This produced the following error message: 'Argument Invalid' - but interestingly still added the printer to the local machine. However when printing to the printer, the document sits in the spooler and nothing is physically printed.

Any idea's?

Cheers

Rob

Collapse -

Internet Printing Problem

by ashily24dee In reply to Internet printing problem

Hi,

The printing process fails itself sometimes. In this case, you will not get any error messages and no output from the printer. This is because of missing of one specific folder which is referred by temp environment variable. You can resolve this error message with the help of settings available in Control Panel. You can see ???user variables for name??? option in ???Environment??? tab. You need to verify the path given there.

Get more information to fix internet printing problem :

http://printers.iyogi.com/problems/internet-printing-problems.html

Back to Networks Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums