Question

Locked

InterVlan Routing

By pradeep2jr ·
Hi everyone,

Plz have a look to the below configuration first:

switch1#sh mac-address-table
!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname switch1
ip name-server 0.0.0.0
!
!
!
ip subnet-zero
!
!
!
!
!
!
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport mode trunk
backup interface

Mac Address Table
------------------------------------------
Vlan Mac Address Type Ports
---- ----------- ---- -----
3 000C.5705.2214 DYNAMIC Fa0/4
3 000C.5401.8140 DYNAMIC Fa0/5
2 000C.4326.7045 DYNAMIC Fa0/3
2 000C.6516.6802 DYNAMIC Fa0/2
1 000C.3782.8690 DYNAMIC Fa0/1
1 000C.3782.8691 DYNAMIC Fa0/1

Total Mac Addresses for this criterion: 6
no fair-queue
!
interface FastEthernet0/2
switchport access vlan 2
backup interface
no fair-queue
!
interface FastEthernet0/3
switchport access vlan 2
backup interface
no fair-queue
!
interface FastEthernet0/4
switchport access vlan 3
backup interface
no fair-queue
!
interface FastEthernet0/5
switchport access vlan 3
backup interface
no fair-queue
!
interface FastEthernet0/6
backup interface
no fair-queue
!
interface FastEthernet0/7
backup interface
no fair-queue
!
interface FastEthernet0/8
backup interface
no fair-queue
!
interface FastEthernet0/9
backup interface
no fair-queue
!
interface FastEthernet0/10
backup interface
no fair-queue
!
interface FastEthernet0/11
backup interface
no fair-queue
!
interface FastEthernet0/12
backup interface
no fair-queue
!
vtp domain bigdomain
interface Vlan 1
no ip address
no ip route-cache
shutdown

vlan 2 name 2

vlan 3 name 3
!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 15
!
no scheduler allocate
end


I have configured intervlan routing by connecting switch 2950 to router by enabling subinterfaces on the router.I configured two vlans (2&3)as you can see in the above config.My question why iam getting two mac-addresses for vlan1. Fa0/1 is trunk port on the switch and it is connected to router fa0/1 by enabling subinterfaces for inter-vlan routing.Thanks in advance for your reply.Awaiting for your swift response.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

RE: InterVlan Routing

by NetMan1958 In reply to InterVlan Routing

One of the mac addresses belongs to the router interface.

Collapse -

interVlan routing

by pradeep2jr In reply to RE: InterVlan Routing

hi,
Thanks for your reply and what about other mac address since one is for router interface.Awaiting your reply

Collapse -

RE: InterVlan Routing

by NetMan1958 In reply to InterVlan Routing

Log in to the router and run the "sh interfaces" command. Then examine the hardware address for each interface.

Collapse -

Does it assign a "virtual" mac to the sub interface?

by Dumphrey In reply to RE: InterVlan Routing

in order to let it work at layer 2? Seems to me it would have too.

Collapse -

RE: Virtual MAC

by NetMan1958 In reply to Does it assign a "virtual ...

It's been a while since I configured "router on a stick" however best I remember, subinterfaces inherit the MAC of the main interface. This is from a Cisco router I have here:

FastEthernet0 is up, line protocol is up
Hardware is PQUICC_FEC, address is 0040.9647.066b (bia 0040.9647.066b)

FastEthernet0.1 is up, line protocol is up
Hardware is PQUICC_FEC, address is 0040.9647.066b (bia 0040.9647.066b)

I'm hoping he will post the output of "sh interfaces" from his router as I'm kinda curious now.

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums