General discussion

Locked

IOS installation

By muddin ·
I have cisco account and downloded the IOS image file size 3.6mb, name(c2950-i6k2l2q4-mz.121-22.EA13) with bin extension and kept onto my PC which has a console connection to the switch.

SWitch' available space 7741440 bytes total (4777984 bytes free). Please send the step by step process of

1. How to configure my switch as a A TFTP server?
2. how to copy this IOS file to the switch.

when I run "copy tftp flash" command it ask for name or IP address etc( It's looking for a remote server)

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

IOS installation

by muddin In reply to IOS installation

My current file
LonMAP2950#dir
Directory of flash

2 -rwx 1674921 Apr 30 2001 16:09:51 c2950-c3h2s-mz.120-5.3.WC.1.bin
3 -rwx 269 Jan 01 1970 00:00:57 env_vars
4 drwx 10240 Apr 30 2001 16:09:52 html
166 -rwx 720 Mar 01 1993 00:24:25 vlan.dat
167 -rwx 1025 Mar 01 1993 00:08:05 config.text

7741440 bytes total (4777984 bytes free)

Collapse -

TFTP Server

by NetMan1958 In reply to IOS installation

You don't use your switch as a tftp server. Download one of the freely available TFTP server programs and install it on your computer. (Do a Google search for Solar Winds TFTP Server, or TFTPD32, and there are others).

Once you have that installed on your computer, make sure the computer has a network connection to the switch in addition to the console cable connection. Your computer must have an ip address that is on the same subnet as your switch's ip address.

Next, create a new directory or pick an existing directory on your computer to be the tftp-root and then configure the TFTP server program to use that directory. Next copy your new IOS image file into that directory.

The first thing you want to do is copy your current IOS image to the TFTP server just in case the new one doesn't work and you need to reinstall your old IOS. To do that:
"copy flash tftp"
it will then prompt you for the ip address of the tftp server which will be the ip address of your computer that is running the tftp server program. It may prompt you for the name of your current image or may default to it automatically. You can determine the image name by running "show version" and look for the filename with a ".bin" extension.

Once you have a backup copy of your current image, it's time to load the new one. You do this with:
"copy tftp flash"
It may or may not prompt again for the tftp server ip. If it does, enter the same ip as you did before. It will prompt you for the image name you want to install. Enter the name of your new image file (c2950-i6k2l2q4-mz.121-22.EA13.bin). If there isn't enough flash memory to hold the new image and your old one, it tell you it needs to erase the current one before installing the new one (This is why we backed up your current one earlier). Tell it to proceed with the operation and if all goes well it will transfer the image to flash. Then to reboot with the new image type "reload" at the cli.

See this article for more info:
http://www.cisco.com/en/US/products/sw/iosswrel/ps1828/prod_release_note09186a00800810f3.html

Collapse -

With your kind help

by muddin In reply to TFTP Server

With your kind help I have downloaded and configured my workstation as TFTP server. After making backup of my old IOS file loaded the new IOS file to the switch.
But when I run "reload" command it always load my old IOS file. I am not sure what I am doing wrong. When I was loading the new file it did not promt to erase the old file. I am in impression that there are enough spaces in my flash memory. Please see the both files are there, unless any file permission issue.

******************************************
LonMAP2950#dir flash:
Directory of flash

2 -rwx 1674921 Apr 30 2001 16:09:51 c2950-c3h2s-mz.120-5.3.WC.1.bin
3 -rwx 269 Jan 01 1970 00:00:57 env_vars
4 drwx 10240 Apr 30 2001 16:09:52 html
165 -rwx 3721946 Mar 01 1993 00:08:13 c2950-i6k2l2q4-mz.121-22.EA13.bin
166 -rwx 720 Mar 01 1993 00:24:25 vlan.dat
168 -rwx 1025 Mar 01 1993 00:58:06 config.text

7741440 bytes total (1055744 bytes free)

*************************************

I am thinking to delete the old image file manully and try to "reload"

LonMAP2950#del c2950-c3h2s-mz.120-5.3.WC.1.bin
Delete filename [c2950-c3h2s-mz.120-5.3.WC.1.bin]? y
Delete flash:y? [confirm]n
Delete of flash:y aborted!
*********************************
Please advice.

Collapse -

Run these commands

by NetMan1958 In reply to With your kind help

2950(config)#boot system flash:c2950-i6k2l2q4-mz.121-22.EA13.bin

2950#wr mem

2950#reload

Collapse -

After running boot system flash

by muddin In reply to Run these commands

LonMAP2950#conf t
Enter configuration commands, one per line. End with CNTL/Z.
LonMAP2950(config)#boot system flash:c2950-i6k2l2q4-mz.121-22.EA13.bin
LonMAP2950(config)#boot system flash:c2950-i6k2l2q4-mz.121-22.EA13.bin
LonMAP2950(config)#wr
% Incomplete command.

LonMAP2950(config)#end
LonMAP2950#w
00:05:56: %SYS-5-CONFIG_I: Configured from console by consoler
Building configuration...
[OK]
LonMAP2950#wr
Building configuration...
[OK]
LonMAP2950#reload
Proceed with reload? [confirm]

00:06:24: %SYS-5-RELOA Reload requested

C2950 Boot Loader (CALHOUN-HBOOT-M) Version 12.0(5.3)WC(1), MAINTENANCE INTERIM
SOFTWARE
Compiled Mon 30-Apr-01 07:56 by devgoyal
WS-C2950-24 starting...
Base ethernet MAC Address: 00:08:21:9f:68:80
Xmodem file system is available.
Initializing Flash...
flashfs[0]: 164 files, 3 directories
flashfs[0]: 0 orphaned files, 0 orphaned directories
flashfs[0]: Total bytes: 7741440
flashfs[0]: Bytes used: 6685696
flashfs[0]: Bytes available: 1055744
flashfs[0]: flashfs fsck took 10 seconds.
...done initializing flash.
Boot Sector Filesystem (bs:) installed, fsid: 3
Parameter Block Filesystem (pb:) installed, fsid: 4
Loading "flash:c2950-i6k2l2q4-mz.121-22.EA13.bin"...flash:c2950-i6k2l2q4-mz.121-
22.EA13.bin: magic number mismatch: bad mzip file

Error loading "flash:c2950-i6k2l2q4-mz.121-22.EA13.bin"

Interrupt within 5 seconds to abort boot process.
Boot process failed...

The system is unable to boot automatically. The BOOT
environment variable needs to be set to a bootable
image.

switch:
switch:
************************************

I have lost all of the old seetings and can't run any commands.

here are some example.

switch: dir

List of filesystems currently registered:

flash[0]: (read-write)
xmodem[1]: (read-only)
null[2]: (read-write)
bs[3]: (read-only)

switch: conf t
Unknown cmd: conf
switch: sh run
Unknown cmd: sh
switch: copy tftp flash
tftp: permission denied
switch: copy flash tftp
flash: permission denied
switch:

Collapse -

Corrupt image file

by NetMan1958 In reply to After running boot system ...

It looks like that new image you got is corrupt or didn't transfer from tftp to the switch correctly. The switch is booting into ROMmon mode. You need to run this command:
"boot flash:c2950-c3h2s-mz.120-5.3.WC.1.bin" to boot your old image and start all over.

Collapse -

Loaded the image back.

by muddin In reply to Corrupt image file

I thought I will not be able to go back, because I have writen in the memory and rebooted the switch.

After booting up with the command "boot flash:c2950-c3h2s-mz.120-5.3.WC.1.bin" and writing in the memory when I run "reload" command this still try to load the corrupted image "c2950-i6k2l2q4-mz.121-22.EA13.bin" and fail. Finally I ran "boot system flash:c2950-c3h2s-mz.120-5.3.WC.1.bin" and "reload" worked fine.

Could you please explain the difference between "boot flash:c2950-c3h2s-mz.120-5.3.WC.1.bin" and "boot system flash:c2950-c3h2s-mz.120-5.3.WC.1.bin".

Best Regards.

Collapse -

I left out a step earlier

by NetMan1958 In reply to Loaded the image back.

I wrote the previous reply in a hurry and left out a step. To explain:
When your switch failed to boot the new image, it booted into ROMmon mode. Think of ROMmon like this - if you boot a computer and it can't locate a drive with a boot sector on it it will give you an error message saying so and then offer you the chance to go into BIOS setup by pressing a key (say for instance F1). If you press that key you can go into setup and reconfigure the BIOS to try to boot from different devices on the computer.

The code that tried to find a boot drive and rendered the error message and gave you the setup interface is contained in the BIOS. Configuring things in the BIOS of a computer involves using a different interface than configuring something from within the operating system once the computer has successfully booted.

ROMmon on a Cisco device is essentially the same thing and likewise ROMmon uses a different and very limited set of commands that are different than the commands you use once you have successfully booted an IOS image.

So when you were in ROMmon mode the correct command was "boot flash:c2950-c3h2s-mz.120-5.3.WC.1.bin". however, I should have told you that once it booted and you were running within the IOS you needed to run the commands "boot system flash:c2950-c3h2s-mz.120-5.3.WC.1.bin" and "wr mem" to make it survive a reboot.

Collapse -

IOS installation

by muddin In reply to Corrupt image file

What I understand is in ROMmon mode (likewise BIOS) we only can run limited commands like "boot flash:c2950-c3h2s-mz.120-5.3.WC.1.bin" and this command force the switch to boot with this image( unlike "reload" command only) because "reload" command boot with the default image.

The other thing, I thought after booting up with "boot flash:c2950-c3h2s-mz.120-5.3.WC.1.bin" image and run "wr" command and this image should be permanent, but it did not. After booting up when I ran "reload" commnad or manually power down/up it always run with the corrupted "flash:c2950-i6k2l2q4-mz.121-22.EA13.bin" image, even though I had deleted the corrupted image by "del" command. Finally "boot system flash:c2950-c3h2s-mz.120-5.3.WC.1.bin" command took care of it.

Question.

1. Since I had deleted the "flash:c2950-i6k2l2q4-mz.121-22.EA13.bin" image, where it was running from?

2. Did "boot system flash:c2950-c3h2s-mz.120-5.3.WC.1.bin" command made it the system operating system? or any other?

3. I know Switch or Router don't have hard disk space, can you please explain storage facilities for these like memory etc. how many types of storage in Switch or Router?

Collapse -

Answers

by NetMan1958 In reply to IOS installation

Rather than me trying to explain it, read these 2 articles and then post back if you still have questions.

http://cisco.com/en/US/products/hw/switches/ps628/products_tech_note09186a0080169696.shtml

http://www.cisco.com/en/US/docs/ios/12_2/configfun/configuration/guide/fcf009_ps1835_TSD_Products_Configuration_Guide_Chapter.html

Back to Networks Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums