ipconfig is not a recognisable internal or external command

By ttrza1986 ·
I was recently completing some documentation for my boss when i ran into an unusual error on one of the machines in the computer lab. When i type ipconfig into the command prompt i get an error stating that it is not recognized as an internal or external command. I went on to try a number of other commands such as help, ping etc with the same result. I am able to run these commands if i were to navigate to c:\windows\system32. I have checked the path in environment variables and it points to the same path mentioned above. What do you guys think may be the cause and a possible solution for this problem?

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

re: Check the path again.......

by ThumbsUp2 In reply to ipconfig is not a recogni ...

... this time, highlight Path statement and click edit. Inside, it should say, at the very minimum:


On my system, %SystemRoot% translates to C:\Windows, but yours may be different.

Also make sure this is the first entry in the Path statement and nothing precedes it. Sometimes programs install themselves and put their path before the system path, which leads to exactly what you're seeing, not recognized as an internal or external command.

Collapse -

checked it

by ttrza1986 In reply to re: Check the path again. ...

%SystemRoot%\system32 is the first entry.

Collapse -

Check what else is in there....

by ThumbsUp2 In reply to checked it

Often, older programs will install a path statement in the environment variable which confuses the system.

Try copying the contents of the path statement into Notepad and save the file. Then, remove all BUT the %SystemRoot%\system32 statement in the environment variable, reboot and test. If your command line works fine, one by one, add each additional path statement back into the environment variable (from your Notepad file), reboot and test again. You should eventually bump into the errant statement which is preventing your command line from working correctly (it will probably be the last one). At this point, you'll have to decide if that particular path statement is indeed needed (or maybe correct it).

Note: Each path statement in the environment variable is separated by a semi-colon ( and no spaces between them. Make sure you add things back to the environment variable exactly the way they were copied out of it, into your Notepad file, until you find the bad one.

Collapse -

locked out

by 45GEEK In reply to ipconfig is not a recogni ...

You say that you are a student and the object of your problem is in the computer lab.

My first thought would be that your tech support administrator for your school has locked you out of the command line (CLI). Which is a common practice for computer labs. An easy way to find out is type /? at the command prompt. If you get the same resopnse you are locked out, and attempting to change anything will be fruitless.

Although you can get by this on a couple of levels if you know how to script. Another test is to go to Start>Run> and type wbemtest and then click on OK. You should then get a window that allows you to see all of the available "Classes" installed on the machine if you know what you are doing. This is one piece of testing/development that is very difficult to lock out.
But again if you are typing ipconfig as all one word if you are not locked out you should get some output. Remember that typing just ipconfig with no switches will take you to the interactive mode. A more common command is with the /all switch. ( >ipconfig /all)

Have fun!

Back to Desktop Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums