General discussion


ipconfig /release does not release IP Address

By jviso ·
Dear friends of Tech Republic, I have run into this situation several times and I still don't know what is going on. I am working on this peer-to-peer network (5 PCs), all connected through a Paradyne DSL modem. All the PCs are running a mixture of WinXP Pro and Home edition. I am able to get 4 desktops on-line in no time, they get their IP addresses from the Paradyne modem/router via DHCP. Now, with this Compaq Laptop with Windows XP Home edition, I get a connection since I can see the little icon lid-up by the system tray. The laptop is not getting an IP address from the modem/router and when I try to do "ipconfig /release" it won't release (why?)the ip address. I even forced the IP address by assigning it by hand...Still no connection to the internet. I plugged in another laptop in the same connection and it works perfectly. The laptop autoconfigures the IP address everytime if I let it obtain an IP address from the DHCP server 169.254.x.x. I did not try re-setting the TCP/IP stack...
I would really love to hear your suggestions!

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

Release or obtain?

by gralfus In reply to ipconfig /release does no ...

You said it won't grab an IP from the router, but then you say it won't release the IP. I'm not sure how it got it in the first place. If you use the /renew switch, what happens?

Is the NIC working? Are there any yellow or red alerts in Device Manager?

The 169.254 IP range is what Windows defaults to if it can't pick up an IP from a DHCP server.

Collapse -

by mrafrohead In reply to ipconfig /release does no ...

Log in as Administrator of the box and go into the network connection area.

Find the connection that you are having problems with. right click on it and click "repair".

That will release/renew automagikally for you.

If that isn't working, you have something wrong going on, like a NIC with drivers that are wrong or not installed or the wrong CAT5 plugged into the wrong NIC...

Collapse -

How to release IP address in vista

by RBaker456 In reply to

1. Right-click on desktop
2. select 'create shortcut'
3. type 'cmd' into the titlebar

A new icon appears on the desktop

4. Right-click on that icon
5. Select 'Run as administrator'
6. Use 'ipconfig /release' command
7. Use 'ipconfig /renew' command

It sounds to me like you may have a problem that could be resolved quickly by removing and reinstalling the pc NIC. It sounds as though you may have some settings issues (if you're a tinkerer) and when the NIC re-installs it should reset your IP address fine. If not, you can try setting your IP manually, but you need to have the DNS servers of your router (on the WAN side) in order to make that function. You would have to find out how to log in to your router (google 'linksys router config' for instance, if your router is a linksys) and go to the status page and look for something that says 'DNS servers' right below your live (NOT 192.168.x.x) IP address.
Use those for our DNS servers when you set your IP address manually and you should be able to get on the net.

Collapse -

Yes...I have tried all that is suggested

by jviso In reply to ipconfig /release does no ...

Dear friends, first, thanks for getting back to me. Yes, all that you have suggested I have tried. I checked the Device Manager and no signs of bad drivers. I tried the "repair" option and that did not work either. At this point I have to think that there is a problem with the NIC or Spyware have corrupted something. The weird thing is that, that same laptop worked earlier in a different node. Now, I connect another laptop at this same node (where I am having problems) and it works fine, so I know that the cat V patch cord and its connection to the router is good.
If you happen to come up with another idea please let me know.
Thanks so much in advance!

Collapse -

I suspect the NIC/driver

by TracyF In reply to ipconfig /release does no ...

You could try a remove NIC from device manager- restart.

If that's not it- get a new driver for it from the 'net.

I had this happen to me once before- & have been racking my brain on this- just cannot recall exactly what the solution was...but I'd have to guess driver,


Collapse -


by jdclyde In reply to ipconfig /release does no ...

try running the winsoc download.

I had to do this about a week ago.

Collapse -

ipconfig /release done not release IP address

by trunning In reply to ipconfig /release does no ...

look at the nic card in the back. See if the lights are working. If not, remove and reseat the NIC card. I did that and the activity lights on the NIC card worked again.

Collapse -

PLEASE similar problem ..tried another nic and router/network

by lshone In reply to ipconfig /release done no ...

What gives when you can only obtain an autoconfiguration address in windows xp.. this pc is a hp compaq with an on board broadcom nic..we tried everything we could think of short of a system restore going back 2 weeks.. we installed another nic in the pci slot..same thing .we get link lights and all but no ip from the router ..even staticly configured ip will not connect to the internet .. tried firefox and IE ... PLEASE HELP!

Collapse -


by brandon.aiken In reply to ipconfig /release does no ... is MS's APIPA behavior. If a PC set to DHCP cannot find a DHCP server, it gets one of those addresses because Windows must assign it something. You can't "ipconfig /release" because you don't have a DHCP lease. There's nothing to release.

The system is still sending out DHCPDISCOVER messages, and is giving you a address to satisfy Windows. As soon as it finds a DHCP server (such as when you plug it in) you will get a valid IP address.

Possible reasons:
1. MAC filtering is enabled on the router/hub.
2. NIC is damaged or otherwise bad.
3. NIC drivers are incorrect.

Try giving the suspect laptop a static IP.

Collapse -

Static IP didn't work

by ewok69 In reply to APIPA

I have two laptops on my desk. One connects to the internet through a cable modem and one does not. The one that does not keeps getting the ip every time I do the release and renew sequence. I tried finding the ip and dns on the pc that is working and inserted it into the one that is not. I still could not connect. Any other suggestions?

Related Discussions

Related Forums