Question

Locked

iPhones and Blackberry's not connecting to Exchange Server

By Magnitude_V1 ·
On Wednesday our BT BusinessHub failed and BT sent us a new one the next day. I plugged it in and set the IP, Subnet etc on the router to what the failed router was. All Emails are being sent and received from the computers but the iPhones and Blackberry's won't connect to the Exchange Server.

I get the following on the iPhones:
'Cannot Get Mail
The connection to the server failed'

As nothing on the phones have changed and as the computers are all sending and receiving mail without any issues I'm guessing I need to change something on the Hub to allow the phones to connect to the server.

BT BusinessHub Model: BT2700HGV
Microsoft Windows Small Business Server 2003
ActiveSync is set in Exchange System Manager -> Global -> Mobile

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Some port forwarding is probably missing

by TobiF In reply to iPhones and Blackberry's ...

There are probably a couple of applications running on your server, listening for incoming connections from the outer world.

But these connections from the internet only reach the router, and the new router has no clue what computer inside your network might be interested in "unexpected incoming traffic".

Say you run Outlook Web Access on the server. You'd then want to tell the router (under "port forwarding" or "Virtual servers") that external traffic to TCP port 443 should be forwarded to the same port on the internal ip address of your server.

Same would apply for pop (TCP 110) and (hopefully secured and authenticated) SMTP (traditionally on TCP 25, but in parallel ports like 587 or 465 may be used, since port 25 is stopped by many network operators.)

In addition, you need to know on what ports BES (the BlackBerry server) listens. I have no clue.

As a proof of concept, provided that your server has up to date internal firewall and AV security, you could try to TEMPORARILY enter the internal IP address of your server in the router setting for DMZ, so that all incoming traffic that isn't an obvious reply to previous outgoing traffic, will be thrown towards your internal server. But this should only be used temporarily, since the router would forward lots of bad things, as well.

One more thing, of your internet connection has dynamic ip address, then it's possible that the previous router was automatically updating a dyndns entry.

Finally, when you get everything to work:
1. Save a backup of the router configuration.
2. Note down the router settings you've done. (in case the replacement router won't construe the backup file you just saved.)

Collapse -

Solved

by Magnitude_V1 In reply to Some port forwarding is p ...

You were correct about the Port Forwarding, I checked the Firewall Logs and it said that devices using Port 443 were trying to get access so I added HTTPS (Port 443) to the Small Business Server through the Bt Business Hub.

Unfortunately it didn't completely solve the problem as 2 of the iPhones would not connect to the Hub and kept saying the WEP Key was wrong, to solve that I had to reset the Network Settings on the iPhone in the Settings option and the turn off the iPhone and try the WEP Key again. If it didn't work I just turned the iPhone off and then on again and repeated that until it accepted the WEP Key.

Back to Networks Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums