Question

Locked

IRQ conflict?

By darah.shawn ·
As I try and work through this moronic USB modem issue, I've come across some similar situations, most of which have ended up being IRQ conflicts between the USB Host Controllers and audio or video cards.

In particular, I'm looking at IRQ 18 on my machine:

18 NEC PCI to USB Open Host Controller
18 NVIDIA GeForce 7800GT
18 VIA USB Enhanced Host Controller

All IRQ's are being used up to 23 at the moment. Unfortunately, my BIOS only allows me access (PCI or Reserved) up to 15. Vista is not allowing me to rearrange IRQ assignments.

1) Is this IRQ possibly the source of my issues with a USB modem that constantly freezes?
2) How can I get the IRQ assignments changed through Vista?

I can post the other IRQ's as well, if necessary.

PC specs are as follows:

Asus A8N-E, non-SLI, BIOS Rev. 1013
AMD Athlon 64 X2 4800+
Onboard audio
BFGTech GeForce 7800GT
two separate generic USB2.0 cards
Vista Ultimate 32-bit (although issue is similar on 64-bit Vista and 64-bit Windows XP Pro)

Thanks in advance.

This conversation is currently closed to new comments.

25 total posts (Page 1 of 3)   01 | 02 | 03   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

OK I don't know if this works in Vista

by OH Smeg In reply to IRQ conflict?

Or more importantly if you can change the IRQ & DMA Settings for these devices at least.

Open the device Manager then open up the USB Devices find the VIA USB Enhanced Controller and right click on it in the drop down menu select proprieties and left click on this in the next window to open left Click on the Resources Tab and see what you can change in there. If you can change things make the changes and reboot the computer if it's still working correctly try connecting the USB Modem again and see if it works now. If it doesn't change the IRQ on the Nvidia Geforce 7800GT the same way and reboot after saving the changes.

Personally I don't think that you'll find this is a IRQ Conflict though but a conflict between the Modem and computer you may be required to open the Modems Setup and make changes in there. But to be perfectly honest I stopped using USB Modems because of issues like this with th original version of XP. I found the USB Modems to just be unreliable.

Col

Collapse -

That's what I was trying.

by darah.shawn In reply to OK I don't know if this w ...

That's how I was trying to change the IRQ settings, and unfortunately Vista has it greyed out ("Use Automatic Settings" is checked with no option to uncheck it).

The only common factors I have seen between my issue and similar ones are 1) IRQ conflicts with audio or video cards, whether or not a conflict is shown; and 2) issues with USB modems emulating COM ports, but I don't have any options to change those either.

Unfortunately, I do not have any other options for internet here besides a USB modem through the wireless carrier (EVDO). I'm already locked into a contract anyhow, so I'd rather get this working instead of having to use it with my laptop at all times.

How can I get Vista to allow me to change IRQ settings within the OS? So far I'm not finding any way to make that happen.

Collapse -

You might want to try and flash the BIOS to a lower one...

by Peconet Tietokoneet In reply to IRQ conflict?

Flash the BIOS first to this one:
A8N-E Bios version 1011
http://support.asus.com/download/download.aspx?SLanguage=en-us

And then flash to version:
A8N-E Bios version 1013

You will have to type in your type of motherboard and processor so that you can get the info that you need.

It just might correct your issue that you have.

Collapse -

Would it be an issue...

by darah.shawn In reply to You might want to try and ...

....that I went straight from 1010 to 1013?

I only flashed up when the problem started, so I'm not sure if skipping 1011 would have been a problem or not?

Collapse -

When you flash to the lower version.....

by Peconet Tietokoneet In reply to Would it be an issue...

Select the "Load default settings" option and then re-start your computer. When started do a shutdown. Boot up and access the BIOS and sort out your settings to the way you want it and then re-boot (make sure you save and exit). See if the problems are still there.
Next load on the new version of your BIOS and do the same as above. Hopefully this should correct your issue.

Collapse -

I'll give that a shot...

by darah.shawn In reply to When you flash to the low ...

Hopefully that will do it. I'll try and re-flash, then post back.

Thanks.

Collapse -

Have you tried updating your

by Jacky Howe In reply to IRQ conflict?

USB modem with the latest firmware.

Collapse -

No new firmware seems to be avail.

by darah.shawn In reply to Have you tried updating y ...

That was the first thing I looked for, incidentally.
I've asked my ISP who provides the modems, but their techs are (go figure) useless. UTStarcom and Pantech (the manufacturers) say they don't have any info on newer firmware and refer me back to my ISP. It's a vicious cycle.

I also tried downgrading the BIOS to revision 1011, but the update utilities don't allow for downflashing so I'm stuck on the newest.

Collapse -

Pantech

by Jacky Howe In reply to No new firmware seems to ...

firmware is dated 2005. Have you asked them if these modems are compatible with Vista. What Operating System is on the Notebook.

Collapse -

I'm convinced Alltel is insane.

by darah.shawn In reply to Pantech

My laptop is running Vista Home Premium (32-bit). The modem runs flawlessly.

So far, the main PC has run XP Pro x64, Vista Ultimate 32- and 64-bit, all to the same tune.

Back to Windows Forum
25 total posts (Page 1 of 3)   01 | 02 | 03   Next

Related Discussions

Related Forums