General discussion

  • Creator
    Topic
  • #2179121

    Issac Mchannon’s Blog

    Locked

    by issacmchannon ·

    blog root

All Comments

  • Author
    Replies
    • #3137399

      Issac Mchannon’s Blog

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      Imported Technology Blog from Blogger.

    • #3135672

      Learn to Spell

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog





      No I’m not that bad at spelling. I had pasted a large amount of VBA code into a word document at work when I recieved this one. (Click the Image If you cannot read it)

    • #3135673

      My Thoughts on VWD Beta

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      So I’ve recently been playing with Microsoft’s Visual Web Developer Beta. I have to say that I am very impressed with the way it works thus far. It’s geared for web application development, but I think mainly what I’ll be using it for is as an html editor.

      I think I can sum it up good like this:”It’s web design for a VB programmer”

      You know how in VB the menu’s will pop up with the methods and properties you can use? Yeah, this program does that, but with html tags. You know how you drag and drop user controlling visual elements right on to your forms? It does that to. You know how you can set a variety of properties from the property pane for whatever control you have selected. Think about doing that for a web pages and tables. To assign a stylesheet to a page you just select the stylesheet properties the properties pane for that document.

      A really cool thing it does: Create CSS style sheets with a formating options dialog box.

      These are just a few of the basic things the program does. It’s geared to be much more than an html editor.

      Try it out by downloading the beta from Microsoft’s web site, just make sure you have 1.3 gb of free space on your hard drive and a few hours to kill for the gruesomely long install.

      I believe that it also requires XP SP2 if your installing it on an XP box.

    • #3135670

      Testing the Post to Blog by E-Mail Feature

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

    • #3135671

      Interesting

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      “The paranoid, adrenaline-fueled culture of so-called speeders, and the drug’s effects make users
      likely candidates as ID thieves, medical experts say. Meth addicts can stay up for days performing
      menial tasks, such as testing the validity of credit card numbers on websites and buying goods online.”
      http://www.usatoday.com/tech/news/computersecurity/2005-09-29-meth-id-theft_x.htm

    • #3135667

      Yum

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

    • #3135668

      A couple of odds

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      “Array of Vegetables” – My Java Script and Perl instructors slip of the tongue when trying to say Array of variables

      “You mean that box on the wall?” -My Boss in reference to the Cisco Switch on the Wall

      “Mouse Button Monitoring Service”
      Description:”Enables a cocice. Stopping or disabling this service will result in system instability.”
      File: Mousebm.exeDropped by Escobot.A
      A weird service dropped by the virus that exploits the plug and play service on 2000 boxes.

      “We are the root of the spanning tree” – The terminology used by the root of a spanning tree when viewing the information on a Cisco IOS based switch

    • #3135669

      A Peeve for an IT Guy

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      Here’s one that I’m sure many networking professionals can relate to: We have recently purchased a piece of hardware that hasn’t been behaving as it is supposed too. The problem is so perplexing that the manufacturer has sent up an expert from the states to assess it further. Now I appreciate the guys help but one thing he did caught me off guard. It would seem that proper IT manners would dictate that before you try to plug your corporate laptop into someone else’s network you might want to ask first. You know usually there’s certain policies in place about what is and isn’t allowed. Not this guy though, Lucky for me I barely caught him before he had.

    • #3135664

      My Current IT Projects

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog


      Web Stuff

      I’m going to rebuild my servers and begin web hosting and design here in town. I’ve already got a couple of clients lined up. I’m using Win 2003 Server with IIS and SQL. Two sites will require web forms and posting capability from users and the other one will be my resume/portfolio site as soon as I get the time to build it.

      I also just finished the JavaScript coding for the dating web site my group designed for a class project. My part of the development so far was the compatibility test which matches up the user with Dates based on their personality test results.


      Programming

      My big programming project at work has been going pretty well. The project is a very dynamic and customizable database application. Access Frontend, VBA enhanced to work with excel for importing data back and forth and an Access backend for now. The program also features context sensitive help. Hopefully most of the testing will be complete by mid November to early December.


      School

      I’ll only be able to take one class this next quarter so I think I’m going to advantage of the spare time and join AITP.

    • #3135665

      VWD Issues

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog




      First Problem with VWD: Doesn’t do frames – not really that big of an issue because you can paste the code in. You just can’t edit the whole thing together in designer view.

      Second Problem: I got an error today (see the image) all of a sudden for no reason at all. This error has basically rendered the designer aspect of the program useless as it will not load. (The graphical editing part) Uninstalling and reinstalling the product hasn’t solved the problem yet. Something to do with failed packages loading: The trident designer package which refers to tridsn.dll. A regsvr32 repair didn’t fix the issue either. I’m looking for a solution to this right now and I’ll post the fix when I find it.

    • #3135661

      XP Quirk

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog





      Saw a Cool XP Quirk today on one of my users machines. XP for some reason mapped all of the drive letters to the same network share and then marked them as disconnected. The problem was fixed upon reboot of the machine.

    • #3135662

      JavaScripting Stuff

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      The other tech that I work with found me a really cool article today on creating a client side search engine for a web site using JavaScript. This is perfect for the application I have been developing because unfortunately I cannot post the html help files onto a web server.
      http://www.oreilly.com/catalog/jscook/chapter/ch01.html

      Today at work I learned a lesson: Never use JavaScript to secure your application licensing. I was troubleshooting an application today that was not working correctly and viewed the java script code for the search page. The application searches some html documents for the locations of PDF files based on the users query. When installing the application you specify a license code to use whichever version you selected to install. The function I found today that handles the licensing was about 8 lines long. Basically if the key specified during install did not match for the version specified then the function would return a false to the calling function. Well change that false to a true and walla, you now have a full featured application without the license key.

      Of course we had a license, I just thought it was interesting when I saw the function.

    • #3135663

      What an Interesting Waste of Time

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

    • #3135659

      VWD Problem Update

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      So I’ve looked around for a fix to the VWD problem I posted about earlier. None of the solutions I’ve found have remedied the problem. The most comprehensive potential solution I found was here: http://blogs.msdn.com/astebner/archive/2005/04/19/409905.aspx .

      I guess I’ll have to wait until someone finds a fix.

    • #3135660

      Kudos to the XP pop-up blocker

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      Today I had a user come to me and tell me that the pop-up blocker built into XP was interfering with the site they like to check their horoscope on. I’ll I have to say about this is Kudos to the product for working properly.

    • #3135655

      Handy Tip from TechRepublic

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      “To use Openfiles, all you have to do is open a Command Prompt window and type:
      Openfiles [/parameter]
      where /parameter is one of three settings that you can use to configure Openfiles:
      /Disconnect: Disconnects one or more open files. /Query: Displays files opened locally or from shared folders. /Local: Enables/disables the display of local open files. You can find detailed information about additional sub-parameters in the Windows Help and Support Center.”

      http://techrepublic.com.com/5100-10877_11-5901798.html?tag=nl.e101

    • #3135656

      Nice Goin Guys

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      Latest Windows Patch Causes Problems

      http://techrepublic.com.com/2100-1009_11-5897997.html?tag=nl.e101

      That really bites since the viruses are coming out as fast as the vulnerabilities are announced.

    • #3135657
    • #3135658

      My Routers Config

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      Here’s the Config For my router at home.
      It’s a 1605R and I’ve upgraded the memory to 24 mb. It has an 8 mb flash and it’s running IOS 12.3
      This Config allows my router to connect through the DSL modem provided by my ISP

      Current configuration : 1451 bytes!
      version 12.3
      service configservice timestamps debug datetime msec
      service timestamps log datetime msec
      no service password-encryption!
      hostname Fenrir
      !boot-start-markerboot-end-marker
      !enable secret 5 excluded
      !no aaa new-modelip subnet-zero
      ip name-server excluded
      ip name-server excluded
      ip dhcp excluded-address exlcuded
      !ip dhcp pool home network excluded
      !vpdn enable
      vpdn ip udp ignore checksum
      !vpdn-group 1
      request-dialin protocol pppoe
      interface Ethernet0
      no ip address
      pppoe enable
      pppoe-client dial-pool-number 1
      no cdp enable
      !interface Ethernet1
      ip address 192.168.0.1 255.255.255.0
      ip nat inside
      !interface Serial0
      no ip address
      shutdown
      no fair-queue
      interface Dialer1
      ip address negotiated
      ip mtu 1492
      ip nat outside
      encapsulation ppp
      no ip mroute-cache
      dialer pool 1
      dialer-group 1
      ppp chap hostname excluded
      ppp chap password 7 excluded
      ppp pap sent-username excluded password 7 excluded
      !ip nat inside source list 101 interface Dialer1 overload
      ip classless
      ip route 0.0.0.0 0.0.0.0 Dialer1
      no ip http server
      no ip http secure-server
      !access-list 101 permit ip 192.168.0.0 0.0.255.255 any
      !banner motd ^CC UNAUTHORIZED ACCESS WILL RESULT IN SWIFT & PAINFUL PROSECUTION ^C!
      line con 0
      line vty 0 4
      password 7 excluded
      login
      !end

    • #3135653

      Happenings

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      I get to go tour the Cisco Office here in Anchorage for one of my classes tonight. I’ll post about it later if I see anything really cool.


      Oracle has made a free version of their 10g database available to the public. This is excellent for those of us who want to learn a bit about Oracle systems but haven’t had access to it. I believe the database size has been limited though.

      Sony’s Gone too Far with this one: http://www.washingtonpost.com/wp-dyn/content/article/2005/11/02/AR2005110202362.html


      11.5% Market Share For FireFox: http://news.zdnet.co.uk/software/applications/0,39020384,39235378,00.htm

      I’ll also be posting a list of my favorite utilities to use soon.

    • #3135654

      Another Day

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      So I checked out the Cisco building here in town yesterday. They had a pretty nice cabling and rack setup in their server room. The tour guy also told us alot about the VOIP products Cisco was putting out. All in all I guess it was pretty good. I was kind of expecting something more extravagent, but then again it’s alaska and it was only a regional office.

      So I think that I’m going to use Dreamweaver to develop my portfolio website. After the issues with VWD, even though it was just a beta version, I don’t want to deal with the hassel.

      I got the chance to look at a Cisco aironet for the first time at work today. I was surprised to find that you can configure it from the console just like you were configuring a router or a switch. I was pretty impressed with the hardware.

      Over the next couple of weeks I’m finally going to build the webserver I’ve been meaning to for awhile now. I’ll post the specs when I do. I’m also going to build that portfolio website soon and soon I’ll be setting up a VPN on my home router. I’ll post my router config’s when I do.

    • #3131052

      Bad Cap’s

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      A problem with motherboard capacitors that’s rearing it’s ugly head again:

      http://techrepublic.com.com/2100-10877_11-5942647.html?tag=fdnews

      Good Information

    • #3131053

      Good Analogy

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      My teacher from my contract management class compared drafting a contract to software development last night by saying that one of the main considerations is to include everything that may come up, alot like software development when the programmer tries to make the program do as much as possible for the user so that they don’t have to think.

      I thought it was a pretty good analogy.

    • #3131051

      Stuck On a VBA Coding Issue

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      I ran into a little trouble with some coding today. I have need to open up a web-based application that we use, from the Access Application I’m developing and then input a value into the web applications search box and submit it. This is so that my users can quickly view the search results about the item selected fast. I’ve searched the web for awhile but may have my own solution, although it’s rather crude in my opinion.

      The user will select what they want to look up and click a button on my form to search.
      The Program will then generate a small html file dynamically and open it in Explorer.
      The html file that was generated will have a little bit of JavaScript code so that it opens up the search page of our web application, places the string into the search box and then submits it.

      Like I said rather crude, but I’m pretty sure it will work.
      I’ll post the code if I get it to.

    • #3117460

      Perl DBI

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      My last perl class went over connecting to databases with perl. I asked how you could specify options for the recordsets such as read-only or paged but the instructor had not run across how to before and the book had no references to it either. So here’s how with the sources referenced underneath:

      $dbh = DBI->connect(‘dbi:mysql:Clients’,’serf’,’readonly’);
      http://www.databasejournal.com/features/mysql/article.php/10897_1430061_7
      DBI HANDLE ATTRIBUTES ^

      Example:
      … = $h->{}; # get/read
      $h->{
      } = ; # set/write
      Attributes common to all handles

      The driver supports all of the general DBI handle attributes provided by DBI. Differences from standard behaviour are listed below.
      ChopBlanks (boolean, inherited)
      Supported by the driver as proposed by DBI, but due to the fact that MaxDB cannot handle trailing blanks the driver will always chop blanks for CHAR/VARCHAR columns.

      Database Handle Attributes

      The driver supports all of the DBI database handle attributes provided by DBI. Additionally the driver provides some MaxDB specific database handle attributes.
      maxdb_isolationlevel (integer)
      Gets/Sets the isolation level of the current connection.
      maxdb_kernelversion (string, read-only)
      Gets the version of the database instance used at the current connection.
      maxdb_sdkversion (string, read-only)
      Gets the version of the MaxDB SQLDBC software development kit used by the driver.
      maxdb_sqlmode (string)
      Gets/Sets the SQL mode of the current connection. Possible values are ORACLE INTERNAL.
      maxdb_unicode (boolean, read-only)
      Indicates whether the current connection supports unicode (true) or not (false)

      Statement Handle Attributes

      The driver supports all of the DBI statement handle attributes provided by DBI. Additionally the driver provides some MaxDB specific statement handle attributes.
      maxdb_fetchSize (integer)
      Gets/Sets the maximum number of rows that can be fetched at once. Use this to manipulate the number of rows fetched in one chunk via the order interface. Use a value > 0 to set the maximum number of rows. Use a value <= 0 to reset this limit to the default value. The default value is 'unlimited' (32767). Setting this value does not affect an already executed SQL statement. maxdb_maxrows (integer) Gets/Sets the number of rows of a ResultSet. The number of rows of the result set is truncated if the result of a query statement is larger than this limit.
      The default setting is ‘unlimited’ (0). Setting this limit does not affect an already executed SQL statement. maxdb_resultsetconcurrency (string) Gets/Sets the type of the result set concurrency.
      There are two kinds of concurrency: CONCUR_UPDATABLE The result set can be updated. CONCUR_READ_ONLY The result set is read-only. The default setting for the concurrency is CONCUR_READ_ONLY maxdb_resultsettype (string) Sets the type of a result set. A result set is only created by a query command. There are three kinds of result sets: FORWARD_ONLY The result set can only be scrolled forward. SCROLL_SENSITIVE The result set is scrollable but may change. SCROLL_INSENSITIVE The result set is scrollable and not change. The default for the result set type is SCROLL_INSENSITIVE maxdb_rowsaffected (integer, read-only) Returns the number of rows affected by the executed SQL statement. This method returns a non-zero value if more than one row was addressed by the SQL statement. If the return value is lower than zero, more than one rows was addressed but the exact number of addressed rows cannot be determined. maxdb_tablename (integer, read-only) Retrieves the table name (for SELECT FOR UPDATE commands only). http://search.cpan.org/~maxdb/DBD-MaxDB-7.6.00.16/MaxDB.pm

    • #3122500

      Decided What to Use for my Portfolio Site

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      I’ve decided to use dreamweaver and photoshop 7 for the development of my portfolio website. VWD seems to have too many issues with it otherwise I would have loved to use that. I have noticed one weird thing with Dreamweaver though. When draging and dropping an image into Dreamweaver from an explorer folder the img source path gets a “/” in front of it. This seems to cause both I.E. and Firefox to be unable to render the images correctly. Other than that I like what I’ve seen from Dreamweaver so far. It will take me awhile to finish my site, but when I do I’ll post the link.

    • #3121679

      Excellent Website to review Good Web Design’s

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      I was searching for lists of good website designs and think this is one of the best one’s I’ve found:
      http://www.coolhomepages.com/

    • #3122835

      Reply to question about my Routers Config

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      Comment:

      Cool. I grabbed the pppoe config, I’ll try it on my router.You don’t have an access-list blocking bad ports?

      Reply:

      Right now I use other forms of security for various reasons.
      When I setup the network for a VPN and Remote Acces I’ll employ an access list.

      Thanks for checking out my blog!!!!

    • #3122513

      Rounding with Excel

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      I had to lookup a few rounding functions today:

      http://www.ozgrid.com/Excel/excel-rounding.htm
      Round Numbers
      The ROUND Function will round numbers to a specified number of digits. If the number of digits is negative, it will round to the left of the decimal point. If zero it will round to the nearest Integer (whole number).
      =ROUND(1.5,0) will result in a value of 2
      =ROUND(1.4,0) will result in a value of 1
      Round Numbers Up
      The ROUNDUP function will round numbers up, away from zero.
      =ROUNDUP(1.4,0) will result in a value of 2
      Round Numbers Down
      The ROUNDDOWN function will round numbers down, toward zero.
      =ROUNDDOWN(1.6,0) will result in a value of 1
      INT (although less flexible) can also be used. =INT(1.6) will also result in 1

      This function allows you to some a group of cells where an error might be present:

      —-Ignore Div0
      =ROUNDUP(SUMIF(H5:H8,”<>#DIV/0!”),0)

      http://groups.google.com/group/microsoft.public.excel.worksheet.functions
      /browse_thread/thread/b250879d5d43a30e/4781864b78f8715#4781864b78f8715?sa=X&oi=groupsr&start=1&num=3

    • #3126639

      G-mail’s So Called Virus Scanning “Issues”

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      There’s been alot of complaining about Google’s new virus scanning feature with G-mail lately.
      I think the criticism of this feature is lame. One of the complaints is that you still can’t send certain attatchments. There is an easy way around this, rename the extension. While some users may not be savy enough to figure this out, you can’t argue with the fact the MSN’s servers are being delayed right now because of the latest sober variant. In other words it’s a good tradeoff. Besides, many e-mail services don’t allow certain attatchments either.

      Another “problem” is that you can’t turn off the virus scanning protection. I’ll just point to the MSN issue again on this issue. If you work in IT and need to send an infected file, I’m sure you can figure out a way that you can transfer the file via another medium.

      I’ve only been using G-mail now for a few weeks and so far I’m very impressed with the service. I’ve pretty much ditched outlook ’03 for it. I’m glad that Google is taking the approach they are with this virus scanning protection. One of the most prevalent issues that we have to deal with in the industry is security. Many software and IT services companies have a poor track record with this aspect of IT. It’s nice to see a push from any company that is trying to minimize the problem.

    • #3130097

      XP Quirk Revisited

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      I posted a few pictures awhile back of XP mapping every available network drive to the same place and then marking them all as “disconnected”. We’ll that has been recurring frequently on the same machine lately and now on a few others as well. After searching Google Groups I think I’ve pinpointed the problem. Since upgrading to Symantec 10 we’ve experienced a long string of problems with the software, this appears to be one of those many problems. The post that I found claimed that upgrading from 10.0.0.x to 10.0.1.x would fix the problem. So now I’ll have to look into what problems are caused by 10.0.1.x and I guess we’ll decide from there whether it’s worth the trouble at this point. Rebooting the machines does fix the problem temporarily.

    • #3124525

      Printing Through Terminal Services

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      We use terminal services along with Citrix at work for a few applications on site and there is also another terminal services server that we use in another domain that we don’t have administrative access to.

      There’s been a few problems with getting the printers on the local machine to show up for the
      remote session on the server.

      The first problem is dealing with local vs network printers already on the client machine. With Terminal services the printers need to be local printers, not network printers, to transfer over to the session on the server.

      This can be worked around fairly easily enough though.
      At the command prompt simply type:
      net use lpt1 file://Server/Printer /persistent:yes

      This command maps the lpt1 port to the server share and is then seen as a local printer by windows. There is a problem if the user that needs this mapping does not have administrative rights on the local machine. This can be worked around by an administrator going into Device Manager and disabling the lpt1 port under the ports category.

      Once this is done the port is not tied to hardware and it is then possible for a user account without admin rights to map a network printer to it. If something has been mapped to lpt1 already or you need to change it just delete the mapping:
      net use lpt1 /delete

      After this was setup we still had problems getting the printer to show up during the client session for the other domain. This was found to be a driver issue. The server in the other domain did not have the printer driver for our printer loaded. So we worked around this by loading a generic driver that we knew 2000 Server should have out of the box as a temporary fix until the IT staff for that domain gets around to loading the correct driver version.
      Fun stuff but kind of a pain.

    • #3124524

      Access Error

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      The Error:
      “msaccess.exe has generated errors and will now be closed. You will need to restart the program. An error log is being created.”

      I have a login screen where the user types there initials in at when the program loads. The user clicks login and then another form is opened and the user name is populated into a text box along with the date. During this process I get the above error message for some reason.
      I searched the net and could not find a suitable solution before the problem somehow magically went away. One weird aspect was that if I closed the form without logging in and then opened the login form manually and used it, everything went fine. So after that I saved and tried opening again, no luck, I still got the error.

      The next thing I tried was placing message boxes between every line of code the form ran to see if I could pinpoint the line thatwas causing the error. This time all of the message boxes popped up successfully and the form loaded fine. So I took all of the message boxes out and walla, the application was working again for some strange reason.
      I’ll have to do some more digging on the error to see if I can find out exactly what caused it, but for now it’s gone.

    • #3124523

      Window’s Live Local Beta

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      Microsoft went live today with their Live Local Service so I took a look at it. It seemed to work fairly well and I didn’t encounter any errors. While the service is in Beta it looks like they have left some room in to add some more features. I found it to be lacking in that area, but I did like the pushpin feature and the fact that you can get driving directions by selecting your departure and destination spots. Right now I’m still going to use Google Earth and I think that if Microsoft is going to compete with the other types of this software out there they’ll have to add more features. For now though it’s a good start.

      Check it out at http://live.local.com

    • #3124388

      Awesome Administrator Tip

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      At work we just created a new IS share on our server. The problem I ran into though was accessing files on the share from other user accounts without permissions to the share. We were playing around with the runas command for awhile with no luck. After searching Google Groups I found the answer:

      At the run dialog:

      runas /user:administrator “explorer /separate”

      This allows you to browse to the share from explorer without having to make the user log off and then back on again to retrieve software, utilities, documentation, ect.

    • #3124387

      Update That Makes the Administrator Tip Better!

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      After posting the last tip I realized that it would be nice if explorer would just open up to the share after running the command instead of to the root drive where you would have to navigate further to get to it:

      runas /user:administrator “explorer /separate, \\Server\Share”

    • #3125907

      Unable to Create MDE

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      I’m getting close to finishing my application at work. This is the first Access application I have developed so I was a little confused at first about the horribly vague “unable to create mde” error.

      I found a blog here:
      http://alexdyb.blogspot.com/2005/10/Microsoft-access-was-unable-to-create.html

      that referenced this website : http://www.access.qbuilt.com/html/conversion.html

      as a good one for troubleshooting this error. The website was good. They had 15 suggestions for solving this problem. Their first suggestion turned out to be my problem. Compile the Code and fix whatever the compilation is hanging up on.

      In my case is was within my error handling procedure. I pass a number of values to an error module that writes them into a new record in my errors table for later review. One of the values I pass is the name of the form. I was referencing this within the call as “ME.NAME”. Access however doesn’t seem to like this very much so I found another article that gave a better way to refer to this:

      http://forums.devarticles.com/Microsoft-access-development-49/creating-audit-trail-of-all-edits-to-database-22382.html

      Screen.ActiveForm.Name

      This fixed the compilation errors and I was able to create the MDE file.

      I was pretty surprised to see that my program went from a 40 mb MDB file to 8.5 mb MDE file.

    • #3196811

      Digerati

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      digerati: persons knowledgeable about computers.

      -From Google’s Word of The Day

    • #3098301

      Oracle calendar Connector for Outlook

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      I ran across this plug-in the other day that allows you to connect MS Outlook’s calendar program to Oracle Calendar’s Backend. After testing it out I’m happy with it so far and the setup program is fairly straight forward to use.

      You can download the connector here:

      http://ist.uwaterloo.ca/ew/Bookit/download.html

    • #3109513

      IDS Setup

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      I’ve started setting up an IDS on a linux box since I plan to host my portfolio website from my house soon. The box is running Suse 9.2 and I’m going to be using snort. Ran into one problem though. After making alot of config changes I rebooted to see the following error:

      initrd error 15: file not found

      Turns out that there was a problem with the boot loader. Reinstalling it got everything backup and running again.

    • #3107653

      A little weird

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      I decided to download Oracle 10g today so I could see what it was like. I’ve never used Oracle’s database before so I was thinking about using the free version they released for the backend for my portfolio website. When I went to download the database I found the terms of acceptance a little odd:

      Oracle Technology Network Developer License Terms

      To accept this license, you must agree to all of the following terms by checking the boxes next to each statement below:

      ELIGIBILITY EXPORT RESTRICTIONS

      I am not a citizen, national or resident of, and am not under the control of, the government of: Cuba, Iran, Sudan, Libya, North Korea, Syria, nor any other country to which the United States has prohibited export.
      I will not download or otherwise export or re-export the Programs, directly or indirectly, to the above mentioned countries nor to citizens, nationals or residents of those countries.
      I am not listed on the United States Department of Treasury lists of Specially Designated Nationals, Specially Designated Terrorists, and Specially Designated Narcotic Traffickers, nor am I listed on the United States Department of Commerce Table of Denial Orders.
      I will not download or otherwise export or re-export the Programs, directly or indirectly, to persons on the above mentioned lists.
      I will not use the Programs for, and will not allow the Programs to be used for, any purposes prohibited by United States law, including, without limitation, for the development, design, manufacture or production of nuclear, chemical or biological weapons of mass destruction.

    • #3107654

      IE 7 Beta 2

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      I installed IE 7 Beta 2 today. The anti phishing filter looks like it has some potential. I do like the tabbed browsing feature and also how you can click to view a thumbnail page of all of your open tabs on one page. I think that they should turn the pop up blocker on by default instead of off though.

      I guess I was expecting to see alot more new features with this version. The RSS feeds were nice too, but I really don’t see a reason to ditch Firefox for the new IE yet and I doubt many loyal Firefox users will either. I did originally try to create this post with the new IE as well, but you couldn’t see any of the text as you typed in the create post box for blogger! My gmail account worked alright with it though.

    • #3272857

      Got A New Job!

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      Alaska is definantly a small town. A while back I was working closely with someone from the company my current employer purchases their network scanners and printers from on a troubleshooting issue. About 6 months latter, a week ago, I got a call from him saying that there was an opening at the company he had recently gotten a job with. So I went in for a few interviews and they hired me! I start in 2 weeks.

    • #3272858

      Stuff

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      Gmail

      I’m more impressed with Gmail every time they come out with a new feature. I think it’s by far the best e-mail client I’ve ever used. I really like the way they layout your e-mail conversations and I can’t wait until they do more with their chat features.

      More Google

      I was excited to hear that google came out with an online web page editor. Unfortunatly by the time I had heard about it the demand for it was so great they had to stop accepting new users. Hopefully they start accepting again soon, I can’t wait to try it out.

      Google’s going to make films from the National Archives available from Google Video.

      Dell Peeve

      In general I’ve always been pretty happy with the quality of Dell machines. Lately though I’ve seen more and more problems with the hardware. For instance, on a number of machines I’ve had hard drives, cd-roms and motherboards fail within having the machine for a few months. Most of the issues have been with the Optiplex GX270’s.

      802.3af Power Over Ethernet

      Learned some cool stuff about IEEE 802.3af from a paper I had to write for class. A little bit about it: You can use it over 10/100/1000 ethernet networks. There are two implementations Mid-Span and End-Span. End Span involves getting an 802.3af compliant switch that powers devices connected to it over your cable. Mid Span involves placing a device between your switch and 802.3af devices. Mid Span is used for legacy hardware that do not have PoE capability. The standard was published in 2003 so it’s fairly recent and bound to change frequently within the next few years. A couple of benefits: you don’t have to run a power cord for your wifi ap’s, if your switch’s are connected to a UPS your devices can stay powered on in the event of a power outage, think VOIP phones. There’s alot more to it, this was just a brief summary, but expect to see it more and more.

    • #3272856

      Another Reason why Symantec is Lame

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

    • #3090298

      Microsoft Boasts, Again

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      Microsoft recently stated that their search engine was going to be better then Google’s and that it will return “twice as many results”. Is it just me or haven’t they been making similar statements every few years now? If they can do it kudos, but as of yet they haven’t lived up to their boastings.

    • #3086477

      Runtime Error 458

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      Today I got hit with runtime error 458 while testing an access application.
      The error message was: “variable uses an automation type not supported in visual basic”.
      Well that’s a helpful message. I couldn’t find a straight answer googling around but most refrences to this error mentioned incorrect variable assignemnts. Turns out I hadn’t declared the variable to begin with. While I usually don’t ever forget to do this it does strike me as odd that this would be the root of the error. The variable was used in a loop, never assigned anything but an integer and I have Option Explicit turned off. A little odd, but it’s working fine now!

    • #3086389

      First Dive into Windows Live

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      Microsoft has come out with Windows Live Beta, to be found at http://www.live.com.

      My main curiosity with the product was the “Live Search”, of course because of all Microsoft’s “we’re going to be better than Google Search” talk.

      The Search interface is interesting. Instead of having multiple pages with a set number of results per page you get only one page. On this one page you can scroll and view all of results. There is also a little bar on the side that lets you customize how much information you want displayed for each result. This is a feature I think that I could really come to like. I found it a little slow and clunky, but this is a beta and it probably doesn’t help that I’m using FireFox either for Windows Live 🙂 lol.

      So I tried three queries: “structured query language”, “Web 2.0” and “bible”. For all three queries the results between MS and the Google Engine were pretty close at least for the first few pages (or scrolls). Google of course returned more, about 600,000,000 more, but there didn’t seem to be a significant difference in relevancy, at least for the first few pages. Of course Google’s also has the personalized results from News and Groups that show up as well. I also ran an image search. Which went really slow with the “Live” search.

      The next thing I wanted to play with was the gadgets. These things actually annoyed me quite a bit. First, you have to click like four buttons to finally get the one you want on your homepage. Second, they’re slow, third, each one takes up a quarter of the page and there didn’t seem to be a place where you could adjust settings for most of them. I did like the “Add Stuff Directory” though that lets you browse for stuff a little easier and drop items straight onto your page.

      That’s about all I checked out for my first encounter with “Live”. I’ll be dinking around with it some more, but I can’t see myself leaving the Google Personalized home for this one anytime in the near future.

    • #3147862

      Exchange 4.4.7 NDR

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      I ran into an Exchange problem the other day. Users were intermittently getting a delayed delivery report and then eventually an NDR when trying to send e-mail to one domain.

      “Could not deliver the message in the time limit specified. Please retry or contact administrator.

      After some troubleshooting it turns out that the isp was having a routing issue. Of course they denied it, but the tracert verified this, along with the fact that after having talked to them about it, the issue was quickly fixed.

    • #3147863

      Verclsid.exe

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      Had a problem today with a users MS Office 2003. The user was unable to browse to attach a file to an e-mail in outlook. The application kept hanging up. Opened up word and tried to open a document from within by browsing and the same thing happened. I loaded sysinternals process explorer and noticed that the process verclsid.exe was interfering with WINWORD.EXE. I killed the process but it just kept relaunching the process every time a browse open file dialog box was opened. It turns out that this process was installed with the last batch of MS patches to be released on 4-11-06. Here’s the link to the bulletin:

      http://www.microsoft.com/technet/security/Bulletin/ms06-015.mspx

      The only fix I could figure out was to uninstall the updates.

    • #3147864

      It’s a Catch 22

      by issacmchannon ·

      In reply to Issac Mchannon’s Blog

      Would you rather risk getting hit by the latest exploit to crop up or would you rather chance installing Microsoft Updates?

      It looks like I’m not the only one having a problem:

      http://groups.google.com/groups/search?q=verclsid.exe&qt_s=Search

Viewing 50 reply threads