General discussion

Locked

Issues with Upgrading from Exchange 2003 Standard to 2003 Enterprise

By bluem10000 ·
Yesterday I performed an upgrade on our Exchange Server 2003 Standard to Exchange 2003 Enterprise (OS is Win 2003 Standard). I Ordered the Exchange 2003 Enterprise Media from Microsoft and used the CD labeled "Microsoft Exchange 2003 Server Enterprise, August 2003".

When I did the upgrade from Standard to Enterprise I used the "Reinstall" option and ran the ran setup.exe in the \SETUP\I386 folder and selected Reinstall. Once the Install was completed I reinstaled Exchange Server SP2. After SP2 was installed I restart the server.

After Server was restarted I looked in the Event Viewer>Application log and did not find Event I 1217. However, I found two Event I 1216 shown as follow:

(First Entry)
Event I 1216
Time: 2:10:39 PM
The Exchange store 'First Storage Group\Mailbox Store (DC-SERVER)' is limited to 75 GB. The current physical size of this database (the .edb file and the .stm file) is 67 GB. If the physical size of this database minus its logical free space exceeds the limit of 75 GB, the database will be dismounted on a regular basis.

(Second Entry)
Event I 1216
Time: 2:10:39 PM
The Exchange store 'First Storage Group\Public Folder Store (DC-SERVER)' is limited to 18 GB. The current physical size of this database (the .edb file and the .stm file) is <1 GB. If the physical size of this database minus its logical free space exceeds the limit of 18 GB, the database will be dismounted on a regular basis.

Since we had Exchange 2003 Standard there is an entry in the registry for database size. I had to increase database size few times. Under HKLM\SYSTEM\CURRENTCONTROLSET\SERVICES\MSEXCHANGEIS\SeverName\PrivateSTORE{guid} there is an entry "Database Size Limit in Gb". Before the upgrade the database size was set to 70GB. so I went and changed to 80 and performed net stop msexchangeis and net start msexchangeis, but for some reason the no events were logged to Application indicating database size was increased. Not sure if this is needed or not or if it will make any difference.

At this point I was not sure if the upgrade to Exchange 2003 Enterprise was done or completed correctly. So, I opened ESM and under Administrative Group>First Administrative Group>Servers>DC-Server it showed the Edition as Standard and the Version as "Version 6.5 (Build 7638.2 Service Pack 2" and modified data is 11/1/09. Not sure why it still shows as Standard and not Enterprise?

I checked the following article http://support.microsoft.com/kb/240152/en-us for the key that points to either Exchange 2003 Standard or Enterprise and under HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall I am able to find the key:
F95DE19F-CF69-4b03-81B6-9EC050D20D3B: Enterprise Full Packaged Product (FPP) . So the registry shows that I have Exchange Enterprise but ESM shows Standard.

I did few more searched on the web and someone suggested I create a new Storage Group and a Mailbox Store. So, I went to ESM and under Administrative Group>First Administrative Group>Servers>ServerName I created a New Stroage Group called "Test Storage Group". I already have a storage group called "First Storage Group". Next I right clicked on Test Storage Group>New>Mailbox Store and I got the following error message "This storage group already contains the maximum number of stores allowed. ID no: c1034a7a Exchange System Manager". When I created the Test Stroage Group I created a new folder under C:\Program Files\Exchsrvr\2ndStorageGroup for Transaction Log location and System Path location.

Hopefully Someone will help me in resolving this mess.

Thanks,
B

This conversation is currently closed to new comments.

1 total post (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Solved...

by bluem10000 In reply to Issues with Upgrading fro ...

Ok?the problem seemed to be with Microsoft Exchange Messaging and Collaboration Services since during the reinstall it was showing a red x. Also, from Event ID 1002 as shown below the EXIFS was the main problem. I mentioned this issue again to the last MS Engineer I spoke with and it happens that today he also had a customer with similar problem on SBS 2003 but he said it is most likely the same issue I am having. So he asked to go to C:\Windows\System32\Drivers and rename the following files exifs.sys and exifssmsg.dll. After renaming both files I ran the Reinstall of MS Exchange 2003 Enterprise and everything was ok?.the ESM now shows Enterprise and I see Event ID 1217.

During my past 3 reinstalls the event log showed error below but I did not notice and MS Support I spoke with first did not notice as well?.the strange thing is that during reinstall no error message or anything appeared to indicate it just showed a red x not Messaging and Collaboration Services.

Event I 1002
Source: MSExchange Setup
Category: Microsoft Exchange Setup
Exchange Server component Microsoft Exchange Messaging and Collaboration Services failed. Error: 0xc107041d - 0xc007041d - The service did not respond to the start or control request in a timely fashion. (EXIFS)

Back to Networks Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums