General discussion

Locked

JavaScript cannot open a new window

By ajmarc ·
How can this problem be resolved? Are there any browsers that have JavaScript built in and can open a new window from within the browser itself?

SYMPTOMS
When JavaScript runs outside Microsoft Internet Explorer, JavaScript is no longer permitted to open a new Internet Explorer pop-up window by using the window.open() method to display the contents or to run the contents of the specified URL. Specifically, JavaScript is prevented from opening a new pop-up window from the Microsoft Windows XP Service Pack 2 Run dialog box and from a Microsoft Office application.
Changing Zone Settings to Internet on the Security tab does not resolve this problem. You can find the Security tab in Outlook Tools under Options.

CAUSE
Enhanced security has been added to prevent JavaScript from opening a new pop-up window when JavaScript runs out of context in Windows XP Service Pack 2. This problem occurs when JavaScript is embedded as a hyperlink in a Microsoft Outlook message.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by ajmarc In reply to JavaScript cannot open a ...

This can be found under Microsoft Article
I 885755

Collapse -

by rindi1 In reply to JavaScript cannot open a ...

IE in SP2 has a new built in Pop-up blocker. You can turn it off via Tools, Popup Blocker, or you can adjust the settings to allow certain popups. You can try if that will help out with your problem. If you are having the problem mainly in Outlook Express and the above explanation doesn't help, look inside Outlook express for a similar option (I'm not using outlook express, so i'm not sure if there is such a setting in there).

Collapse -

by BobHo In reply to JavaScript cannot open a ...

I think that all of them support opening new windows. It just depends on the security settings.

I'm not sure about the orig winxp or sp1 but sp2 enabled alot of security features that the other versions had left disabled. You can adjust these features to suit your needs but you also leave yourself open to security issues. In the end, it's still your choice.

Go to the Internet Options and then the Security tab. Select the Internet Zone. You can either slide the security slider down to a lower setting (ie Medium-Low or Low) or click Custom Level and make the ActiveScript options enabled (I would just stick to the signed objects). If you haven't done so already, also disable your pop-up blocker (this also will prevent new windows from opening).

That's it. Have fun.

Cheers.

RW

Back to Windows Forum
3 total posts (Page 1 of 1)  

Related Forums