General discussion

Locked

jsp question

By cmptrwhz ·
Hi All--

I have a jsp application with STRUTS running. It works fine in my W2K3/Tomcat environment, but we are not getting the performance we wanted. I have been asked to move it to IIS/Tomcat to see if there is an improvement. The problem I am having is that when I bring up the app, none of the buttons work (structs stuff).. does anyone know how I can get this working again?

Thanks in advance.
Mike

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by mukul_gandhi In reply to jsp question

Hi Mike,
I am not very sure, why your application is not working properly with IIS/Tomcat. But in my opinion, IIS is not a good choice for running JSP/Struts based application. The reason being, IIS uses a plug-in (its a DLL file) to run JSP pages. This slows down the performance. IIS is better suited to run ASP pages. Using Apache and Tomcat would be a better choice I think, to run JSP/Struts based application(if you are going for freeware).

If you can afford, you can use WebSphere or Weblogic for deploying the Struts application, which would be a better choice than Apache/Tomcat(from performance, scalability and fault-tolerance point of view).

Regards,
Mukul

Collapse -

by cmptrwhz In reply to

Poster rated this answer.

Collapse -

by cmptrwhz In reply to jsp question

This question was closed by the author

Back to Web Development Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums