Question

Locked

Keyboard not working AFTER BIOS...read on:

By kipjaw ·
Basically I went to a LAN party and brought my rig with me, it decided to not work after I had unplugged it all and set it back up at my friends. Everything was working find, dual head monitors, wireless mouse, LED lights inside my tower, everything but my keyboard. It?s a USB Saitek Eclipse II with drivers installed in its hardware which windows recognizes. After I boot up my comp, it will bring up the picture of my core cell extreme chip logo, then go to the little DOS text saying stuff about my hardware/Ethernet etc., where you would press <f1> or <f2> or <del> to go into your BIOS. A moment after this my monitor flashes and goes to the Windows loading screen. This is where I have the problem. The num lock key on my keyboard will stay on and will not turn off if I push it, Same with all the other keys including scroll lock and caps lock. This only happens on PS/2 keyboards by the way; the USB keyboard will only light up its background LED's and wont even turn on its num lock LED. Yes I have tried these keyboards on other computers, they work fine, I also have tried other USB keyboards too but they don't work, just like mine. The PS/2 keyboards works on other computers also.

I have tried remote access connection from my other computer hooked up through the same router but that didn't work most likely because I don't have it enabled on my computer. I have also tried many settings in my BIOS and fooled around with that for long enough, like turning off the USB ports and then enabling them, etc.

If you have any tips or ideas of anything for me to try I would appreciate it, I'm stumped =P.

Thanks.


-Kip

This conversation is currently closed to new comments.

13 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Re: Keyboard not working AFTER BIOS

Boot into "safe mode" and see if the problem clears, if it does have a look in your "system" icon and then "device driver" section, you might have more than one keyboard listed, or your keyboard might have a yellow or red tag. Right click on this tag and select "update drivers", you might be asked for your driver disk so have this ready, or select browse to where your drivers are for your keyboard. Hope this helps you.

Collapse -

Possible fix?

by tcole1999 In reply to Re: Keyboard not working ...

I was having the same issue. I saw an icon in the taskbar called "FilterKeys." It opens with different options. I unchecked "Use FilterKeys" and now my keyboard works. You can get to it also by going to the control panel and selecting "Accessibility Options."

Collapse -

Sorry but you lost me here what's your problem?

by HAL 9000 Moderator In reply to Keyboard not working AFTE ...

You can access BIOS and can allow the system to load and run Windows right?

Once the PS2 Keyboard has Windows running can you then turn off the Num Lock or any of the other Lock keys?

With the USB Keyboard as the USB Drivers are not loaded till Windows is almost loaded is this working correctly when you have Windows Loaded?

What you are describing above is perfectly normal for some M'Board Keyboard combinations of having lights on while booting they should even have all 3 LED's flash when the System first starts. You would only have a problem if you where unable to turn off the different Lock Keys when Windows is running as then you would find that these functions are turned on which may not be useful to a game player.

Col

Collapse -

no no no....

by kipjaw In reply to Sorry but you lost me her ...

i cant type my password in the login screen to log onto windows, and ive tried safe mode.

Collapse -

Re Check your bios.

by 1bn0 In reply to Keyboard not working AFTE ...

Keyboard support may be off in BIOS.
Legacy USB support may need to be on.
If both are on change to off and exit then renter bios and change back to on.

Collapse -

::sigh::

by kipjaw In reply to Re Check your bios.

trust me ive tried everything like that, what im trying now is to reinstall the driver files from a boot floppy, which doesnt seem to be working either, (i probably typed it wrong lol, getting bad file name error)

Collapse -

not working either

by kipjaw In reply to ::sigh::

i tried the floppy disc thing and it would have worked if...it would have recognized my C drive lol so now i think im gonna have to find a windows recovery cd and use that, any other ideas in the meantime?

Collapse -

Try clearing your BIOS and then resetting the Date & Time

by HAL 9000 Moderator In reply to not working either

While you're at it also check the voltage from the BIOS Battery and if it's under 2.5 V DC replace the battery.

When you clear the BIOS you should get an error message and you have to go into BIOS and set the Date & Time before it will continue mainly because the Windows files are date stamped after the Date supplied by the Real Time Clock.

About the only thing that I can think of is that you have altered something in the BIOS that you need working so try clearing it there should be a 3 pin header with Pins 1 & 2 shorted by a jumper and you need to disconnect the mains supply and move the jumper to pins 2 & 3.

At least that way you are starting with the Factory Defaults and have a starting point. If you can not get access to the Keyboard to type in your password if you try a In Place Install you'll be unlikely to be able to enter the Product Key for Windows. You really need to get this one sorted before you do anything else.

You could also try the Ultimate Boot CD to test the hardware for faults it's available for download here if you don't already have a copy

http://preview.tinyurl.com/3jnpy

Col

Collapse -

have you managed to boot into windows

by Dumphrey In reply to Try clearing your BIOS an ...

with any cd? Its possible his windows install is shot..

Collapse -

keyboard works in BIOS but isn't working after startup

by usbsapan In reply to Keyboard not working AFTE ...

It happened so that my employee was accessing the
internet and all of a sudden the keyboard(PS/2) kinda
hanged(though mouse cursor was moving) ,she could not
type in anything.So without shutting down the computer
she pulled out the keyboard from the port and inserted
back.But still she cudn't access the keyboard.So I restarted
the computer and came across this weird problem
wherein my PS/2 keyboard was working fine in the BIOS
and during startup it did allow me to type in the
password,but as soon as I could see the desktop,the
keyboard would just not work.When I tried to press any
key,it made a very low beep sound.The mouse was
working fine.
SO I thought the problem could be with the PS/2 port.It
could have got damaged.So brought a new USB
keyboard.But to my surprise even that didn't work.I tried
to connect both these keyboard to another computer and
to my surprise both keyboards were working fine.
So I though maybe it was a driver problem,so I reinstalled
the driver from the dell website.It still didn't work
out.Then I found somewhere that I need to flash the
BIOS,so did that,still problem could not be rectified.Tried
sfc/scannow(to check system files) but still there wasn't
any problem with the system files.
So tried repair installation.That too didn't work out.
So finally reinstalled the XP.And finally the same PS/2
keyboard was detected and is working fine now that too
in the same port.
So all I can think is that the keyboard related system file
got corrupted and to get it fixed you need to reinstall the
operating system.

Back to Peripheral Forum
13 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums