Question

Locked

Keybord / Touchpad / USB ports - Nothing working

By erico.simas ·
Hi,
I have a acer notebook aspire. I have a big problem also, because the keyboard, touchpad e all USB ports don?t working. I try to use any suggestion disclaimed here. If anyone have a same problem contact me.

Sorry my english.

Tank?s

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

I've got an Aspire - which model do you have ?

by OldER Mycroft In reply to Keybord / Touchpad / USB ...

Perhaps you could go into a little more detail....

Are you running XP ?
When did the problem start ?
What was the last thing you were doing ?
Has the system suffered any crash ?
Has the system been dropped or suffered trauma ?

Post back with more details...

Collapse -

Nothing at all

by erico.simas In reply to I've got an Aspire - whic ...

perfectly running XP, without error message.
The problem start a one week ago.
I just turn on the machine and the keyboard/touchpad and all USB ports not working anymore. Nothing.

Thank you for repalying.

Collapse -

Does the keyboard work BEFORE Windows?

by The Scummy One In reply to Nothing at all

in the BIOS?

If so it is a driver issue most likely. If still not, there may be a HW issue.
Please check that and let us know.

Collapse -

HW issue!

by erico.simas In reply to Does the keyboard work BE ...

I think so about this. The F2 button not working too. If it?s not working, I can?t to open a BIOS manager.

Thank?s all, to try helpme, but this notebook may be burned.

Collapse -

Mine too

by my_jet In reply to HW issue!

I have the same problem.
No trackpad/keyboard/usb,
however if you hit Fn-left and right
you can change the brightness and if you go into sleep mode ytou can wake winxp up by hitting any key... so something is bizarre. You can't hit F2 or anykeys during boot or
anything to enter bios, etc...
What is up with that?
Why will keyboard work sometimes and not others? It should work at boot time if it works at all, but this is NOT the case.

Collapse -

Semi-solution using pcmcia/usb

by indiebear In reply to Keybord / Touchpad / USB ...

Hi, I had the same problem with my Acer Aspire 5100. I've tried to read a lot around internet for a solution and finaly I think it's a problem with Acer mainboards. There are people with a similar problem but your can fix it removing the battery but unfortunately this is not our problem.

Solution :Today I bought a pcmcia/usb and usb mouse+keyboard pack and this is the way that now I'm writing to you. That's the only way to go into windows. The usb ports in the laptop don't work, you need to use a pcmcia. They give power because I can use usb speakers, but a mouse or an external usb hard disc don't work .

As far as the best solution would be to phone to Acer support service but I bought this laptop more than two years ago. I know that It's not my fault, It's a manufacture problem but... What can I do? I'll try to get in contact with Acer. I think I'm not the first one in this situation.

Extra info: I updated BIOS with two different versions today but It doesn't work.

If an expert knows something that I can do and I haven't done before please, post here. Thanks to all and sorry for my english, I'm from Spain.

Collapse -

Solution

by handsome_94 In reply to Semi-solution using pcmci ...

I've same problem with acer 5101.

Solution is : Disconnect AC power, remove the battery. Keep the laptop without battery and power source for 1-2 days.

After that it'll start working.

Problem is with acer bios. Some settings in it gets screwed up, so if you keep it without any kind of power source for some days, all BIOS settings are lost and it starts working again.

One more thing, after doing this your lappy's DATE in BIOS will reset to like 2006 or something...so you'll have to set it again.

Back to Smartphones Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums