KEYS "e,d,c and 3" of LAptop (Hp nx7300) not working?

By vivek244442 ·
i have HP nx7300 laptop, and from few days my keys, ie.,'3', 'e' d', 'c' are not working. Kindly help me, it may be passible tht my laptop id virus infected as i was not using any antivirus for some time. i just started using avast which had detected Win:32 sality virus in my laptop, Kindly guide me whether it is a problem related to virus, BIOS or hardware.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Before you jump off to any conclusions.

by RayFoxxe In reply to KEYS "e,d,c and 3" of LAp ...

First, check your laptop's keypad if it's dirty or full of dirt and grime in between the key spaces. Clean it out first with a soft brush or **** off the things in there with a gentle blower. Wipe the keys clean with a cotton cloth. If that still doesn't work, answer me these.

Have you recently spilled any liquid on your laptop?
Are you letting a child use your laptop?
Ever dropped anything that's quite heavy over the keypad?

Let's asses your keypad's condition first before jumping onto the next options.

Collapse -

Or you could try running a Live Linux

by OH Smeg Moderator In reply to KEYS "e,d,c and 3" of LAp ...

From a CD and see if the Keyboard works now. Also try plugging in an external USB Keyboard and see if that works correctly. You can get a Live Linux as a cover Disc on a Linux Magazine at your local newsagent or download one of the ones here

If it works correctly the Keyboard in the NoteBook has suffered physical damage and nothing you do at a software level will cure the nonworking keys.

Of course if the USB Keyboard doesn't work it could be an infection that has caused this and you may need to reinstall your OS and associated software after first backing up all your Data.

If Avast isn't picking up anything in Safe Mode it's quite possible that because you didn't have anything installed to prevent infections that avast isn't working properly and has been corrupted as you installed it. If that's the case you need to use a Rescue Disc and you can read up on these here in a TR Blog.

But it's also possible if you have been using a external Keyboard previously that you have left something like the Number Lock on when you unplugged the external keyboard and this is the cause of the current problem.


Collapse -

interesting - my response is missing

by markp24 In reply to KEYS "e,d,c and 3" of LAp ...

Hi, i responsed to this with a list of potions to try, and it got 1 vote, but its no longer here.....


Collapse -

Reponse To Answer

by seanferd In reply to interesting - my response ...
Collapse -

ahh thank you i didnt catch that.

by markp24 In reply to KEYS "e,d,c and 3" of LAp ...

Thank you seranferd

Related Discussions

Related Forums