Question

Laptop RAM slot faulty

By alinionescu1301 ·
Tags: Hardware
Hello tech republic!

I own a ASUS ROG G551JM laptop, it’s old but it gets the job done.
I have bought today a 8GB RAM stick to give it a boost.
I have made sure it is the same make, model, voltage, frequency as the one I already have.They even have the same serial number on them.

So here is the problem...the laptop won’t boot with the 2nd RAM slot occupied.With either stick.It turns on, fan starts, but screen stays black.

I tried the new stick in the 1st slot and it works perfectly.

I saw a YouTube tutorial about how I should wiggle it in the slot, In order to make it sit right, because if the slot was never used it may need this - this video:
View: https://youtu.be/Q1OZQL2l-lM

It did nothing.

I then made a bootable usb with windows and tried to boot from that...no luck.

I then updated BIOS to the latest version...still nothing.

Now I do not know what to do.

I need advice, I was thinking about this:
Take the CMOS battery out and put it back in:
I am willing to try to do this if you think it will do anything... I am not keen on fiddling inside the laptop, but oh well.

Thank you!

The ram are both samsung ddr3l, 1600mhz.this was the one that came with the laptop and I bought another one just the same.

These are the RAM details : https://imgur.com/a/DbOHADX
The first stick (came with laptop) : https://imgur.com/a/UFCvYjP
The stick i bought : https://imgur.com/a/OEeZN13

Thank you very much!
1 total post (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Collapse -

Much more likely to be a Timming Issue

by OH Smeg In reply to Laptop RAM slot faulty

Were the RAM is coming up with a Conflict.

A suggestion what happens if you remove all RAM and plug one into the Notebook in the slot that was empty before you started.

If it works you know the Socket is fine.

Back to Hardware Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums