Question

Locked

Laptop Won't Start

By dirv9 ·
Hi! I was here yesterday with a laptop problem in which the battery was dead. I followed Mycroft's instructions to charge the battery, and now I have the green lights, so it's charged. But the computer still won't power on. I've unplugged it, and the lights go off and stay off. I plug it in, and the green lights come back on, but it doesn't do anything. I've tried holding the button down for up to 20 seconds, but still nothing. What else could it be? Any and all responses will be greatly appreciated. Thanks.

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Inspect the DC input jack on the laptop.

by 1bn0 In reply to Laptop Won't Start

The DC input jack on notebooks frequently get damaged. I have seen them charge the battery but not provide power to the motherboard.

Often the jacks solder connections to the motherboard have broken. These can sometimes be repaired if you are experienced with this sort of soldering job.

You can sometimes determine this just by wiggling the power cord at the connection point. Not too hard, you don't want to add to the problem. Sometimes the problem is only apparent by dis-assembling the notebook and visually inspecting the connections.

Collapse -

Battery

by shhite In reply to Laptop Won't Start

When you charged the battery did you completely remove it from the computer? Take the battery out and let the computer sit for about 45 seconds. Reseat the battery and try again.

Post back with results or questions.

Thanis

Collapse -

When you hold down the button for 20 secs, do the lights go off?.

First make sure you hold the start button down until all of the lights go off. Wait 15 secs and then just press the button only once and quick. This will make your laptop come alive, and on-line.

Please post back if you have any more problems or questions.
If this info is useful, please mark it helpful. Thanks

Collapse -

No Go

by dirv9 In reply to When you hold down the bu ...

Thanks for the responses. I tried jiggling the input jack---nothing. I tool the battery out of the computer---nothing. The lights don't go off if I hold down the button. I held it down for as long as a minute. Is there a power supply in the laptop? There is power going in, as evidenced by the light on the adaptor and the light for the battery. So I should be able to turn it on and at least see the bios. The battery light is bright---the other light beside it is dim. I don't know what to try next. Thanks.

Collapse -

Ok, try this out for your laptop issue..

Switch off your laptop and take out the batt.
Now connect your mains adaptor to your laptop and press the start button. Your laptop should be able to boot up. If it boots up then it would be the batt. If not then it would be a connection issue inside your laptop of which you should take to a shop for repair.

Please post back if you have any more problems or questions.
If this info is useful, please mark it helpful. Thanks

Collapse -

Another possibility here depending on the NB

by OH Smeg In reply to No Go

Could be a flat BIOS Battery. If this NB has a Battery for the BIOS when they go flat sometimes the NB will not turn on. Look in the Service Manual for this NB and see if there is a replaceable BIOS Battery, this is sometimes called a CMOS Battery.

These batteries are not rechargeable and generally consist of a coin type Lithium Battery encased in some shrink wrap with 2 wires and a connector coming out of the Shrink Wrap. You can cut the shrink wrap away replace the battery which should cost about $3.00 and then cover it in some Shrink Wrap and heat it enough to shrink the Shrink Wrap tightly around the battery and Holder.

Alternatively you could just buy a replacement Battery for the NB Maker if it has one.

Col

Collapse -

Try this first

by Kenone In reply to Laptop Won't Start

Remove the battery(s), unplug the power, press the start button 10 times, wait 1 minute, re-install battery, plug in power, start laptop.

Collapse -

Nope

by dirv9 In reply to Try this first

Thanks for the responses. I tried turning on the computer with battery removed very first thing. No go on the pushing the button 10 times. There is an internal power supply, right? And if so, and it's bad, that would explain why it won't start? As far as my thinking gets me, it's either that or the power button is bad. Any way to figure that out? With no power at all, I can't even open the cd-rom to run diagnostics. Thanks.

Collapse -

Take it to a repair shop.. Sorry we can not do much else.

Please post back if you have any more problems or questions.
If this info is useful, please mark it helpful. Thanks

Back to Windows Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums