Links in Messages in Outlook 2003

By hckbuss ·
Just right out of the blue after the recent update on IE to Version 8
All my links in my messages open up as if it were an executable file ( save in file opens )
instead of openning in a browser and going to the url.

I reverted back to a previous restore point a few days ago but its the saem

Anyone help ?


Hamant Keval

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

UM IE8 is still a Beta Product expected to break things

by OH Smeg Moderator In reply to Links in Messages in Outl ...

I've just looked at both the Windows Update Server and Microsoft Downloads and ie8 isn't listed as a download for Windows and the only download available is IE8 RC1

I think you have just experienced using something that is even more of a Alpha product than the Beta Products sold and passed off as Released to Manufacturing. The reality here is that when M$ release a Product to the Public it is really a Beta Product that then starts to undergo fixing and when it gets removed it is either fixed and a Retail Release or it never worked properly in the first place and M$ has done the correct thing and dropped it to try to develop something that might work this time.

OH to fix this issue Backup all your Data & Settings then wipe the HDD with a Military Spec Wiping utility and reload the system. You can use Boot & Nuke to wipe the HDD it's available here


Collapse -

Links in Outlook after IE8 install

by khariskh In reply to Links in Messages in Outl ...

It looks like your Outlook is not aware of where your browser sits. This could very well be a result of IE8 being in beta. I'd suggest you look for fixes on their website OR you can re-install Outlook.

Collapse -

Ho hkarishh1- Many thanks

by hckbuss In reply to Links in Outlook after IE ...

Many thanks for your time in replying

I will try to install Outlook from fresh and see what happens.

Have a great day


Collapse -

It's a Junk Mail setting!

by ejtaylor In reply to Links in Messages in Outl ...

Hi Guys --

I went nuts with this link problem for a week. I did all the regsrv stuff and other suggestions around the net and nothing worked. Then I stumbled onto this Outlook menu option checkbox:

"Don't turn on links in messages that might connect to unsafe or fraudulent sites. To help protect your security, we recommend that you leave this check box checked."

Outlook 2003 comes from the factory with this option checked, of course. They recommend it, right? As soon as I UN-checked it, my Outlook links started working. I didn't even have to restart Outlook.

In Outlook 2003 it's here: Actions|Junk E-Mail|Junk E-Mail Options|Options Tab. Uncheck the last item on that page.

You can also find it if you right click on an email in your inbox. Then it's Junk E-Mail|Junk E-Mail Options|Options Tab.

There are no warning messages about it when you click on links; and I also haven't found anything about it after many, many internet searches.

So for anyone having problems with links in Outlook not opening in browser windows, try this first -- especially if it's a new installation of Outlook 2003.

I just about tore my computer apart and it turns out it was only this one stupid checkbox. Thanks again, Bill, Microsoft, etc.

I'm not going to have time to publicize this fix, but I'll post it here and hope other members will help spread the word.

I know this comes a little late, but I hope it helps, hckbuss --


Related Discussions

Related Forums