General discussion

Locked

Linux NIC problems

By cybersekkin ·
I am installing a Linux Mandrake 6.5 server and cannot get the machine to use the NIC card. I have tried an NE2000 compatiable and 3Com 509 and a Intel NetExpress 10/100 but once the system is up I can't get out the NIC card. I even set it up as DHCP (which I have up and running on the network) but the Linux box fails to pull in a DHCP address off the network. I have tried differing PCI and ISA slot and various versions of these cards without luck. As a recent Linux convert (less than six months, although I still manage several NT networks--well this is frustrating.) Any ideas would be greatly appreciated!!!!

Thanks

David

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Re: Linux NIC problems

by Ronaldo In reply to Linux NIC problems

I had this problem also. I'm using Suse 6.4. I bought Elecom's Laneed LD-10/100 cards (japanese brand) and the box had a TurboLinux emblem on it so I'm assuming it is compatible with Linux.

Anyways, the NICs didn't come with linux drivers and Icouldn't seem to get one activated with Suse 6.4, Slackware 7.0, or Mandrake. I used the NE2000 and tulip drivers because these seem to be the standard but I still couldn't get them to work, so I installed TurboLinux 6.0 since their trademark was on the cards' box.

TurboLinux detected them, but I had to use the via-rhine drivers. I tried this driver in the other flavors of linux and they wouldn't work. I then saw "generic 82596" or 82596.o. I tried this driver (under Suse 6.4) and my NICwas detected and I can ping and telnet to it....haven't linked it to my Windows machine, yet, so I don't know if it's functioning using the 82596 driver.

Hope some of this helps. Please let me know, because I'm curious.

Collapse -

finally got the answer

by cybersekkin In reply to Re: Linux NIC problems

The problem turned out to be an incompatability with the mainboard..I thought that it being a new Asus I was safe(silly me) We went out and purchased a new Abit mainborad and everything is working fine. Only problem I've had with Asus boards so far.

Back to IT Employment Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums