Question

Locked

Linux Squid Proxy

By bubloob_13 ·
Hi

I have installed redhat linux 9.0 in our office and configured squid transperant proxy + iptables firewall. I have segregated my users into two groups like support staff and general users. There is no restriction for support staff and general users can browse only their allowed site and i denied access to all pronography stuffs for all. Now i want to add few more urls to be allowed to browse, entered the same in my ACL. But squid is not allowing, but already allowed sites i able to browse but newly added urls i am not able to browse.

Here is my ACL control list

http_access allow localhost
acl mylan src 192.168.1.0/255.255.255.0
acl allowed_pc src "/etc/squid/allowed_pc"
acl support_staff src "/etc/squid/support_staff"
acl general src "/etc/squid/general"
acl rejects url_regex "/etc/squid/rejects"
acl allowed dstdomain "/etc/squid/allowed"

http_access deny rejects
http_access deny !allowed_pc
http_access deny !mylan
http_access allow general allowed allowed_pc
http_access allow support_staff !general
http_access deny all

"allowed_pc" contains all the ip address to be able to access internet
"support_staff" contains the ip address of theirs
"general" contains all the general users ip address

"rejects" has all the keywords and domain name of pronography stuffs. For eg.

# vi rejects
.sex.com
.playboy.com
xxx.com
teengirls
.
.
etc

"allowed" has all the urls which can be accessed by general group. For eg.

# vi allowed
www.firstflight.com
www.ffclchennai.net
http://mq.hathway.com/mqsweb
www.royalsundaram.com
https://onlineservices.tin.nsdl.com/TIN/populateUsingPanno.do
incometaxindiaefiling.gov.in
mail1.hathway.com
.
.
.
etc

In the above list , www.firstflight.com
www.ffclchennai.net i am able browse which i made the entry at the time of installation. I recently added the remaining site, but i am unable browse the following sites

http://mq.hathway.com/mqsweb
www.royalsundaram.com
https://onlineservices.tin.nsdl.com/TIN/populateUsingPanno.do

surpringly i am able to browse incomtaxindiaefiling.gov.in , that also i added recently.

I have no clue what went wrong. Desperately need solution. Can you help me out

Thanks in advance

Sakthi

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

first off

by Jaqui In reply to Linux Squid Proxy

lose the ancient, non supported red hat linux version 9, and go with a newer version.
Fedora Core 6 is the latest free Red Hat Linux, and would be number 15 if they had not changed the naming of the distro.

when you have CURRENT versions, then try it, with software almost as old as windows 3.1.1 no sane company would use it.

Collapse -

Re: Linux Squid Proxy

by bubloob_13 In reply to first off

Hi

You mean to say it's an version issue.....! Even i tried the same configuration in Redhat Linux Enterprise Edition. But it's not working....

Can you help me out....

Regards
Sakthi

Collapse -

Re.

by bubloob_13 In reply to first off

You mean to say it's only a version issues... Even i tried the same configuration in Linux Enterprise Edition also... But same vain.

Can you pls. help me out.

Back to Networks Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums