General discussion

Locked

linux,multiboot and partition tables

By javier030664 ·
Hello everybody! I got a problem when installing Linux, i always heard in a multiboot enviroment the first thing to install are the windows system then the linux, well i got install a few windows in my computer, and when i want to install Fedora or red hat 9 it appears: "unreadable partition table..." etc warning me if i want to make a new partition table losing all the data...so how could i fix that? i tried installing Red Hat 6.2 and it reads the partition table so is the problem the anaconda? Indeed i installed Red Hat 6.2 but i cann't make it work the StartX cause the drivers are not installed for my computer which is a HP Pavilion 6609. I tried with Knoppix and it loads perfect although the Qparted again doesn't recognize the partition of my harddisk...so nothing to work out from there...Does someone know a work around to install Linux when it happens? maybe should i writte a classic MBR then install Linux? Any suggestion is welcome..thanks
Javier

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

update

by Jaqui In reply to linux,multiboot and parti ...

the version of linux.
rad hat 6.2 is around 6 years old, it won't drive all the hardware on your system.

also, how many versions of windows are running?
what partition types are they installed on?

if you only have xp, and ntfs, you are going to have to fight to get the disk space for linux.
this would also create the bad partition table message in the antiquated red hat version.

Collapse -

Has to be the ntfs format

by jdclyde In reply to update

Need to redo your windows.

If you want to be able to access all partitions later, don't use ntfs. If you want ntfs then make two partitions. One ntfs and the other fat32. Install your windows on the ntfs and then the linux will install on the fat32.

Collapse -

Hey Jaqui

by javier030664 In reply to update

hello Jaqui!surprisingly i could install Red Hat 6.2 but in text mode it doesn't work the graphic part...then you are right about the hardware and the old linux version like 6.2, the thing Red Hat 6.2 recognize my partition table using disk druid which doesn't happen with Red Hat 9 or fedoras...why is that? is Anaconda the problem? and how to work around to install Fedora? Also Knoppix recognize the partitions cause i an get in the partitions and mount them just the Qparted doesn't read the Partition Table. About my installations of Windows: I've got installed, windows 98SE primary partition, and as logicals Windows NT4 workstation, NT4 server, 2000 server and XP Pro. It took me some walk around to do that but i did it. About the space in the hard disk I've got a 40 GB harddisk so it is enough space to install Linux in fact i made partitions for Linux using Partition Magic. But still i cann't figure out how to make Red Hat 9 or Fedora to read the partition table...I might try making a back of my MBR and try to writte a classic one do you think then it can be readable for Linux? so any advice is welcome:)

Collapse -

hmmm

by Jaqui In reply to Hey Jaqui

not sure why fedora won't read partition table.
you could try using a completely different distro and see if they do.

with mandriva they have network install image, so you can burn image to floppy and boot from floppy to install from over the internet.
1.44 megs download to see if thier installer reads partition table is better than 3 700mb downloads.

you did check hardware compatability list?
some hardware doesn't have decent linux drivers, give it a year after it comes out before you can expect to find a driver included for a piece of hardware.

Collapse -

NTFS --> FAT(32)

by djameson In reply to Hey Jaqui

the only tool that I am aware of that can change a NTFS partition to fat32 is partition magic. I recommend with a multi boot arrangement install windows first and partition the drive into multiple Primary Partitions (windows will allow up to 4 per disk) then in the boot.ini file add those partitions into it. there is a good article about multiboot with NTFS here
http://www.highlandsun.com/hyc/linuxboot.html

Collapse -

Make sure

by jmgarvin In reply to linux,multiboot and parti ...

1) You are using FC3 or FC4. FC1 is no longer supported and FC2 is dying.
2) RH6.2 is OLD. It probably won't find all the devices on your system
3) You probably have no room to install Linux. I would bet your NTFS partions are taking up your entire drive. You will need to use partion magic or some such to free up drive space
4) Please post your whole error so we can get an idea of exactly what is going on.

Thanks!

Collapse -

Trying the same thing

by JRod86 In reply to Make sure

I am about to attempt about the same thing. I have Windows XP on the first partition. I have 20GB of unpartitioned space on my hard drive. From what I have read that should be sufficient to install Fedora Core 3.

Any other pitfalls I should watch out for? I am imaging the drive to be safe prior to the FC3 install.

Collapse -

20 gigs?

by Jaqui In reply to Trying the same thing

huge space.
linux, full install of everything on all 3 cdroms will fit on 6 gigs.

the watchout for is the partitioning done by the installer ( for majority of distros* )
best to manually create instead of defaults.

anaconda's fdisk often throws a hissy fit at the windows partion, it doesn't like the way ms's fdisk sets it up. if that happens, you'll have to either quit the install and save all data, then use red hat's install to reset the partiton table to it's own liking.
( minimal install of linux in that case, then re-install windows and restore data, then do an install of linux [ this isn't the simplest way, mandrake allows re-installing boot loader from recue mode on first install cd, not sure about red hat ] )

Collapse -

Similar Issues

by Frenchwood In reply to 20 gigs?

I'm having similar issues with Debian, after installation on the empty partition of my XP pro, (i also installed Grub loader to MBR) I get the error:

Error loading Operating System

Really annoying as i now cannot access windows either - Ah well back to the drawing board!

Collapse -

You shouldn't have any problems

by jmgarvin In reply to Trying the same thing

IIRC the "everything" install of FC3 is about 7gig.

The only pitfall, make sure you don't format your NTFS partition! ;-)

So manually partition out:
/boot at 150mb (just in case you ever want to add anything)
/swap at 250mb (you aren't creating a server right?)
/ at the rest

If you want to create a /home you can, but it sounds like this is more to play around...so go easy the first time and then customize to your liking when you get FC4...

Back to Linux Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums