Question

Locked

Local Administrator account privileges problem

By . Avi ·
Hello,
I have a problem on my home PC, i'm runing XP pro SP2,

the problem is that i use an account which is member of the administrators group,
(i know that it's wrong for the most part to use this account)
and i can use most of my admin rights o say change system time and install applications,

but in some things i try to do like in starting a performance trace, installing some apps and such, i get an error message that i need to be an administrator in order to do it,

i tried runing as an administrator but that won't work either i also tried creating a new account and gave him membership of the admins group and runing as and it still gives that error, i also tried logging in to that account and trying to do the i get the error for but that won't work either, i tried removing my original account from the admins group and adding it back but that won't do either,
i think it might be a bug, all i remember is that long time ago i set a password for that account in-order to remote control it, and afterwards set a blank password for it,

i would appreciate any insighs as to wether anyone encountered this and solutions would be great,
if you need more info than i'm a technical person, work as 1st level tech-support for a huge (4,500+) and highly IT based stock traded company, i can give you more details about this problems if you ask me to,

thanks in advance,

avi

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Collapse -

A few questions...

by Boli In reply to Local Administrator accou ...

Is it just your admin account on this computer or all admin accounts?

Also, can u run task manager, Msconfig, or CMD?

Im thinking a possible virus or spyware can cause this.

Collapse -

A few answers...

by . Avi In reply to A few questions...

Thank you boli for the fast reply,
well it happens an all admin accounts (but it's just me using the PC),
i can run task manager, cmd and msconfig just fine, and i use them quite regularly to make changes in my computers enviroment,
i scan my pc often for viruses and spyware,

Collapse -

I think you are posting the wrong question here, Avi

by nepenthe0 In reply to Local Administrator accou ...

It's somewhat confusing reading your description of your problem. However, the essence seems to be:

...all I remember is that long time ago I set a password for that account in order to remote control it, and afterwards set a blank password for it.

In a nutshell, you are locked out of an account, and you are asking the TR folks to help you break the lock.

TR will not help you break the lock, regardless of your explanations.

Rick/Portland, OR

Collapse -

Well actually

by Boli In reply to I think you are posting t ...

I would be careful doing this because it has been known to mess up user accounts completly (altho 90% of the time on Vista)

We use a program called Hiren. It boots itself and can access your user accounts from Dos.

When it works (again mostly breaks Vista) it removes passwords and resets them perfectly.

Collapse -

thanks for the replies, problem not solved yet..

by . Avi In reply to I think you are posting t ...

@ nepenthe0:
i have been trying to describe a problem i'm facing with my home computer that even i as a technical person who loves challenges like this can't solve, especially with me being a helpdesk technician who is actually interested in getting more knowledge in what i do, and that's the only line you filtered of everything i wrote...
i want to EMPHASIZE that this is NOT a "i lost my password, help me login to an admin account" kind of post..
i'm asking a serious question, and i'm researching everywhere online that i know (and i consider myself quite a good googler thank you)
after not being able to find a solution elsewhere, i post here, and there is a good idea posted by Boli@...
@ Boli:
did you ever encountered a case where an account who had a password and was then set to have a blank password, was able to only partially use his privileges of the admins group?

@true blue:
this is not a "i can't through RDP" post..
read again please..

@ other people, again i'll be happy to assist with any information you think might solve this, take in consideration that i tried with numerous account, who have admin privileges, and still i get an error saying: you need to be administrator to do this
while trying to add a set of trace log to performance console on my xp pro machine,
thanks in advance,
Avi

Collapse -

You had better

by Jacky Howe In reply to Local Administrator accou ...

phone home and get someone to add a password to the the User Account or you will never have access.

NT Security wont allow Remote Acces to a non password protected PC.

<i>and afterwards set a blank password for it</i>

< was goin so good >

Collapse -

See if this helps

by Jacky Howe In reply to Local Administrator accou ...

Restart the PC.
Check out whether your task manager (Ctrl+At+Del) has been disabled, if it has try the Antivirus instructions below.
XP Pro

Click Start, Run and type in gpedit.msc and press OK.

Expand the + with the left mouse button on Administrative Templates under the User Configuration.

Expand the + with the left mouse button on System. Left click on Ctrl+Alt+Del options.

In the right hand pane select Remove Task Manager. Right click on it and select Properties. If this setting is enabled and users try to start Task Manager, a message appears explaining that a policy prevents the action. So by disabling the policy, you are enabling the Task Manager. Click on Setting, Select the Disabled radio button, Apply and press OK.


If that does'nt work try this.

From another PC download and install these programs and copy the the installed folder along with VundoFix.exe to a USB Stick.

Restart the PC in Safe Mode and turn off System Restore insert the USB Stick and run Sophos.bat when it is completed run VundoFix.exe. When the PC reboots start in Safe Mode again and run Spybot.

Download Spybot - Search & Destroy 1.5.2 and install it. Update it. http://www.safer-networking.org/en/download/index.html


Download Sophos and the latest IDE Files. Install it and extract the IDE files to the C:\SAV32CLI folder.
http://www.sophos.com/support/knowledgebase/article/13251.html

Copy and paste the below two lines into Notepad and save the file to the USB Stick as sophos.bat, it will scan and remove.

===============================
CD SAV32CLI
SAV32CLI -REMOVE -P=C:\REMOVLOG.TXT
===============================

VundoFix is a freeware removal tool for many of the known variants of Trojan.Vundo, Trojan.Conhook and other similar infections.

http://vundofix.atribune.org/

Double-click VundoFix.exe to run it.
Click the Scan for Vundo button.
Once it's finished scanning, click the Remove Vundo button.
You will receive a prompt asking if you want to remove the files, click YES
Once you click yes, your desktop will go blank as it starts removing Vundo.
When completed, it will prompt that it will reboot your computer, click OK.

Just to be on the safe side when you finish do an online scan with Bitdefender.

http://www.bitdefender.com/scan8/ie.html

Also download and install CCleaner to tidy up your Registry. Let it run through until there are no errors left.

http://www.ccleaner.com/download

When you think that you are clean re-enable Systen Restore.
The Sophos SAV32CLI folder can be safely deleted after it is copied to USB.

Collapse -

then, you're believe this is caused by malware?

by . Avi In reply to See if this helps

okay ill scan my pc using the tools you suggested, and check in the policy,
tho i must note that i allready checked policy settings, and user rights assigment,
i scanned using hijcak this, and my AV software, but you suggestion sounds much more thorough,
ill let you know if that fixed the problem,
and if anyone has any more ideas like i said, i'm open to suggestions,
thanks again,
Avi

Collapse -

If

by Jacky Howe In reply to then, you're believe this ...

the policy settings are OK it could be Virus activity. Let us know how you get on.

Back to Desktop Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums