General discussion

Locked

Local Security Database and Remapped C

By natecasp ·
We have a Citrix server that was just reloaded and before loading Citrix the C drive was remapped to T. This was accomplished using the Citrix Remap Drives utility. Everything seems to be working fine except when I attempt to open the Local Security Policy it claims that the database does not exist and the event viewer reports:

services (416) Unable to write a shadowed header for file C:\WINNT\security\templates\spsecupd.sdb.

This is obviously because the C:\WINNT directory is now located at T:\WINNT.

However I searched the registry for any C:\WINNT occurances and nothing was found. I also tried moving the secedit.sdb to another folder outside of T:\WINNT\Security\Database and I can open the database with the Security Configuration snap-in but in the default location it gives me an access denied error. I have checked permissions and they are exactly the same in both scenarios.

Does anyone know where this security template path is set? I think that if I can change it the whole problem will be resolved.

Thanks

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Comments

Collapse -

by naterice In reply to Local Security Database a ...

The article I found did not reference your EventID but might work for your situation:

1. Open the %SystemRoot%\Security folder, create a new folder, and then name it "OldSecurity".
2. Move all of the files ending in .log from the %SystemRoot%\Security folder to the OldSecurity folder.
3. Find the Secedit.sdb file in the %SystemRoot%\Security\Database folder, and then rename this file to "Secedit.old".
4. Click Start, click Run, type mmc, and then click OK.
5. Click Console, click Add/Remove Snap-in, and then add the Security and Configuration snap-in.
6. Right-click Security and Configuration and Analysis, and then click Open Database.
7. Browse to the %SystemRoot%\Security\Database folder, type Secedit.sdb in the File name box, and then click Open.
8. When you are prompted to import a template, click Setup Security.inf, and then click Open.

NOTE: If you receive an "Access denied" message, you can safely ignore it.

KB article http://support.microsoft.com/kb/Q278316

Collapse -

by natecasp In reply to

Poster rated this answer.

Yes, I have already read the MS KB article and tried those steps however they do not work. Right after you click the Open at the end of step 8 a message comes up stating it could not find the template file. Then when you check the event viewer the same "services (416) Unable to write a shadowed header for file C:\WINNT\security\templates\spsecupd.sdb" is listed 3 or 4 times. Along with "services (416) Database recovery/restore failed with unexpected error -1811". The errors alternate and nothing is created in the Database folder. Then the Security and Configuration Snap-in reports that the database does not exist.

Collapse -

by naterice In reply to Local Security Database a ...

I found the following reference in the registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SeCEdit\

I've exported part of the key to a .reg file from a Windows 2000 Pro machine Here is what you might be interested in:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SeCEdit]
"LastUsedDatabase"="C:\\WINNT\\Security\\Database\\secedit.sdb"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SeCEdit\Template Locations\C:/WINNT/Security/Templates]

Collapse -

by natecasp In reply to

Poster rated this answer.

No unfortunately these registry setting are pointing to the correct paths. They are already set to the T:\WINNT\Security folder and therefore the problem must exist somewhere else. I really can't find anything on this issue anywhere. It looks like I might have to call Microsoft for this one.

Thanks anyways

Back to Windows Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums