General discussion

Locked

Local Security Settings

By hillwr ·
When I go into Security Options on a W2K Pro
machine, it comes back and tells me Windows cannot
open the local policy database and An unknown
error occured when attempting to open the
database. I don't remember changing anything
in here and I haven't installed anything on this machine in a long time. Unfortunately, my backup
has the same thing so this issue has been here for
awhile and I just have not noticed. Any ideas?

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Local Security Settings

by /dev/null In reply to Local Security Settings

Check the NTFS permissions on %systemroot%\system32\GroupPolicy (is a hidden folder). Mine shows Admins and System with FullControl and 'Authenticated Users' with the standard Read permissions.

Also from: http://www.jsiinc.com/SUBF/TIP2600/rh2668.htm
"Your Local Group Policy log files may be corrupt.

To fix the problem, delete or rename the following:

%SystemRoot%\Security\Edb.*
%SystemRoot%\Security\Res*.*
"

Also from: http://support.microsoft.com/?kbid=300267
CAUSE
This behavior occurs if you have modified the default setting of the Everyone group having full control on the %SystemRoot% drive. For example, if you installed Windows 2000 on the D drive, and you then removed the full control permissions for the Everyone group to the D drive.
RESOLUTION
To resolve this behavior, give full control to the Everyone group for the %SystemRoot% drive.


Hope one of the above works for you.

Good luck.

Collapse -

Local Security Settings

by /dev/null In reply to Local Security Settings

That's all the information I could dig up on this error message. You might be better off wiping and reinstalling, if that's acceptable.

Collapse -

Local Security Settings

by hillwr In reply to Local Security Settings

Not sure how to do this. While this particular tip didn't work, it did point me to the site that did work! jsiinc tip3200 \rh3252.htm did the trick. I had to delete the log files AND recreate the security database.

Collapse -

Local Security Settings

by hillwr In reply to Local Security Settings

/dev/null ,
I tried all 3 suggestions with no success.
My system root drive "C" is Fat32, not NTFS.
So there is no security settings, but I did try
putting everyone back in the share, no go. I took
them out again. Somehow, having everyone in the root share doesn't sit right! Any other suggestions?

Collapse -

Local Security Settings

by hillwr In reply to Local Security Settings

This question was closed by the author

Back to Windows Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums