Question

Locked

Login Script Error - 80070035 - Network Path Not Found

By jgreer ·
I am trying to setup a logon script on SBS 2003 that maps users Home drives on their workstations. I verified the path is correct and yet still get the error. Any ideas?

Option Explicit
Dim objNetwork
Dim strDriveLetter, strRemotePath, strUserName
strDriveLetter = "H:"
strRemotePath = "\\Amicuscuriae\users\%username%"
' Purpose of script to create a network object. (objNetwork)
' Then to apply the MapNetworkDrive method. Result H: drive
Set objNetwork = WScript.CreateObject("WScript.Network")
' Here is where we extract the UserName
strUserName = objNetwork.UserName
objNetwork.MapNetworkDrive strDriveLetter, strRemotePath _
& "\" & strUserName
' Extra code just to add a message box
WScript.Echo " Launch Explorer, check: "& strDriveLetter
WScript.Quit
' End of MapNetworkDrive Example logon script.

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

More info needed

Does the error indicate what line of code produced the error, and can you show which line that is?
Also, how have you deployed this script? Is it in a Group Policy Object (GPO)? If so, is the logon script in the Computer Settings or User Settings section?

Collapse -

Error is Line 16, Char. 1

by jgreer In reply to More info needed

Its not deployed yet, just using on test machine. I need to get it deployed ASAP. I looked at the code on line 16 and it looks correct to me

Collapse -

Aha

I think the problem is that you defined the network path with the %USERNAME% DOS environment variable. The MapNetworkDrive API does not recognize this environment variable, so it is not substituting the actual user name. You will have to define your network path variable after you have the user name.

Collapse -

You don't need to map Home Directories in SBS

by Jacky Howe In reply to Login Script Error - 8007 ...

Open Server Management and navigate to Users. In the right hand pane you will see Configure My Documents Redirection. You will have 3 choices. I normally leave it set at the first choice.

In the Users account click on Profile and and make sure that the Connect radio button is selected. Allocate a Drive letter. EG: S and make sure that the Path is \\Amicuscuriae\users\username

The Users My Documents will now be redirected automatically at logon.

Collapse -

Restricted My Documents on End Users

by jgreer In reply to You don't need to map Hom ...

TrueBlue -- SBS has actually restricted access to our local MyDocument folders. I review the permissions and it sends them to their Home drives on the server, just doesn't map them.

Collapse -

If you have them

by Jacky Howe In reply to Restricted My Documents o ...

setup properly the mapped drive should show up as S:
There is no need to change any local settings on My Documents. Check the User Accounts and make sure that they reflect the settings in my last post.

Collapse -

Setup Same Manner

by jgreer In reply to You don't need to map Hom ...

True -- Its setup as you described, only change is letter is set to H. No go though. Still not mapping the drive to H. I wish I could provide some screenshots to show you -- see if there is something else I am missing.

Collapse -

When the Server

by Jacky Howe In reply to Setup Same Manner

is first setup in the second stage with the Wizard you get an option to setup Client Apps and Users where you can change the location of these files. Default User Permissions are applied to these Folders.

On the Users Folder.
Domain Admins = Full control
Domain Users = Special Permissions
Folder Operators = Full control
System = Full control

Check the permissions on the Users folder.

Back to Software Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums