General discussion

Locked

Loosing connections during large Copy

By Erle Williams ·
On a Netware 4.11 server (Netserver LH4) if the administrator uses Ncopy to copy a large amount of data (200MB or more) from one netware drive to another, users (including the administrator) loose their connection to the server. This problem is easily reproduced. Server is running 100MBps Full Duplex. Clients are mostly 95/98 with the netware client. Has anyone run into this?

This conversation is currently closed to new comments.

15 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Loosing connections during large Copy

by Magetower In reply to Loosing connections durin ...

You didn't mention whether you were transferring on the same server or between systems. If between systems then I would doublecheck the settings of the NIC and the hub/switch servicing the server to make sure they agree on the 100MB F-duplex settings. Also make sure the settings match between the client NICs and the hub/switch servicing them.

Collapse -

Loosing connections during large Copy

by Erle Williams In reply to Loosing connections durin ...

Poster rated this answer

Collapse -

Loosing connections during large Copy

by Stillatit In reply to Loosing connections durin ...

Is the server a bit underpowered? It may be that the server is so busy doing the Ncopy that it is not getting around to responding to the heartbeat signals from workstations. If a workstation and server do not get each other's heartbeats, the connection goes down.

If this is what is happening, a solution is to do the copies in some other way, so that the cpu is not maxed out.

Good luck.

Collapse -

Loosing connections during large Copy

by Erle Williams In reply to Loosing connections durin ...

Poster rated this answer

Collapse -

Loosing connections during large Copy

by Curacao_Dejavu In reply to Loosing connections durin ...

Happened to me too.

I had to reorganize the whole folder (adding subfolders, put the appropiate files in them , etc) and then copy it like that), there were thousand of files in that folder.
In my case I was able to zipped the files also afterwards, since they were only periodically used.
Don't know the cause of this yet, but right now it's only maintenance keeping.

Collapse -

Loosing connections during large Copy

by Erle Williams In reply to Loosing connections durin ...

Poster rated this answer

Collapse -

Loosing connections during large Copy

by kelly_aitch In reply to Loosing connections durin ...

Check this out: http://support.novell.com/cgi-bin/search/searchtid.cgi?/10022150.htm

The cause is: "Net Status Busy Timeout" mechanism gives up on server connection because of a non-completed NCP operation. (so there!)

The TID gives a couple of work-arounds that I wish I'd have know about a couple of years ago when struggling to copy data to a new larger drive. I got all the data over except for a half dozen humongous files (200 MB +) that would crap out in this way.

Cheers

Collapse -

Loosing connections during large Copy

by Erle Williams In reply to Loosing connections durin ...

Poster rated this answer

Collapse -

Loosing connections during large Copy

by Duster52 In reply to Loosing connections durin ...

Just curious....have you tried using a straight DOS copy or xcopy? Have you tried to copy through Explorer?

How many total files are you copying? There is an upper limit (I think around 10,000) of files in a directory that can cause problems like this.

Also check your Directory Cache Buffers on the server. If you reach your max setting then clients will be affected and loss their connections (I've experienced this).....it also happens when you make large changes to file rights and you are at your max setting.

Collapse -

Loosing connections during large Copy

by Erle Williams In reply to Loosing connections durin ...

Poster rated this answer

Back to Networks Forum
15 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums