General discussion

Locked

Loss or use of LPT1 port

By rick ·
Every other time I rebbot a win98 pc HP it flashes up that the printer port at LPT1 is use by another program when it is actually not. The only way I can get the printer to work is to go to Control panel,system, devices,ports and remove the LPT! port and then reboot and let Windows recognize it. Does anyone have this similar problem or know how to fix it?

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Loss or use of LPT1 port

by jctech In reply to Loss or use of LPT1 port

First thing I would do, if you are using a printer that requires 2way communications with the computer, is check in BIOS and be sure the printer port is configured as ECP. Then reboot into safe mode, and check in device manager to see if the printer port appears more than once. If so, remove every instance of it, then reboot into normal mode and let the system redetect the port. If you still have the problem after all this, I would remove the printer, then reinstall it along with the latest drivers.

Collapse -

Loss or use of LPT1 port

by rick In reply to Loss or use of LPT1 port

Poster rated this answer

Collapse -

Loss or use of LPT1 port

by syspop In reply to Loss or use of LPT1 port

I've seen this in two forms.

1. Multiple Parallel Port Devices / Drivers:
2. Sharing / Network Capture

Note: It happens every other time, because the 1st time, PnP creates LPT1. Next time, your port hog finds and grabs it!

1. Many devices can share an LPT port. Some misbehave when you also use a printer:

ZIP
Tape
Scanner
PaperPort
Camera
Laplink-type "Direct Cable Connection"
Software protection dongle (notorious)

Some drivers start up as services, so you can't see them with CTRL-ALT-DEL, or in START -> PROGRAMS -> STARTUP. These drivers may wake up before your printer, so when it looks for the port, LPT1 is taken.

To see what's running, hit START -> PROGRAMS -> ACCESSORIES -> SYSTEM TOOLS -> SYSTEM INFORMATION. Click TOOLS and select SYSTEM CONFIGURATION UTILITY. In the STARTUP tab, you see all boot-time services.

Uncheck anything that looks LPT-oriented. In the GENERAL tab, notice that SELECTIVE STARTUP is now active.

Reboot & repeat, till you find theport hog.

2. In a shared / networking environment, you may have relinquished your rights to LPT1, by capturing it yourself (see above), or by sharing it. If another user (or server) has control of the port, you will need network rights to access it (even though it's on your machine).

Some HP printer drivers come in two flavors: Home and Corporate. Though you lose features with the corp driver, it collaborates better.

Collapse -

Loss or use of LPT1 port

by rick In reply to Loss or use of LPT1 port

Poster rated this answer

Collapse -

Loss or use of LPT1 port

by dosman4 In reply to Loss or use of LPT1 port

FIRST GO INTO BIOS ON THE PRINTER PICK BI-DIRECTIPNAL AND THAT YOU HAVE PARALLEL PORT 378/IRQ 7 ALSO IF YOU HAVE WIN NT OR 2000 GO TO THE VENDERS SITE FOR THE DRIVES THAT SUPPORT THOSE OS.

Collapse -

Loss or use of LPT1 port

by rick In reply to Loss or use of LPT1 port

Poster rated this answer

Collapse -

Loss or use of LPT1 port

by ShanePri In reply to Loss or use of LPT1 port

Check in your bios for a setting regarding lpt irq sharing. If you do have that & it's enabled, disable it. Also, are there any legacy devices in the system that are near the memory range assigned to lpt1? If so, reserve that range in bios so it will be free & accessable in win9X. You could also try letting the bios handle irq steering not windows, (or vice versa)! Hope this helps.

Collapse -

Loss or use of LPT1 port

by rick In reply to Loss or use of LPT1 port

Poster rated this answer

Collapse -

Loss or use of LPT1 port

by rick In reply to Loss or use of LPT1 port

This question was closed by the author

Back to Hardware Forum
9 total posts (Page 1 of 1)  

Related Forums