General discussion

Locked

Low Desktop Depth?

By nollage7 ·
Yes, I just built a PC in class(A+ student) and I installed an AGP video card. After I installed the card, I installed Quake III, to check out the 3D. When I click on the Icon to play Quake, I get a "low desktop depth" error, saying that I should have a some kind of voodoo card in, and If I do have a voodoo card, click cancel, and If I don't click OK anyway, to see if it works. Nothing happens when I click OK. The card is a AGP Pine. I thought Quake III would defenitly play on a AGP? Anybody know what's up?

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Low Desktop Depth?

by TheChas In reply to Low Desktop Depth?

3 things to check:
1. Is the AGP miniport driver for the motherboard installed?
2. Is DirectX installed? Run the DirectX diagnostics to check for system issues.
3. Is the AGP apperature size in BIOS settings large enough. I use a minimum of 2X card memory.
Maximum depends on installed memory. I like to leave 128MB free.

Beyond those, check for updated drivers, or game patches.

Collapse -

Low Desktop Depth?

by mdelyea In reply to Low Desktop Depth?

If the AGP card is an older Pine card there is a good chance that there is an SiS 6326 AGP chipset on it. You can see this when you first turn on the computer. If this is the case then you are out of luck. There are no opengl drivers for this chipset so you can't run quake III.

Collapse -

Low Desktop Depth?

by brian_seader In reply to Low Desktop Depth?

Concur with Answer number 2. Quake requires OpenGL drivers, it doesn't support DirectX. If your AGP card isn't OpenGL compliant, you aren't playing Quake with in in any mode other than Quake's compatibility mode (No hardware acceleration).

A note for you class.. All AGP cards are NOT built the same, you get what you pay for .. blah blah blah..

Regards.

Collapse -

Low Desktop Depth?

by pgcarter In reply to Low Desktop Depth?

Yup, gotta have opengl drivers(QuakeIII uses directx for input and sound, and such). I think the bit depth warning is unrelated, it just means that the colour depth of the monitor and game differ(i had that message and it still ran). If you get the opengl drivers) just delete the current config file(q3config.cfg) Quake will rebuild this file, and try again. good luck!

Collapse -

Low Desktop Depth?

by nollage7 In reply to Low Desktop Depth?

Thanks for the info, everybody.
Exactly right. Today, I got rid of the error. I just took my colors down to 16-bit, instead of 24-bit. But, when I tried to play Quake it said "cannot open load OpenGl subsystem". How would I know if the AGP is uses OpenGL? Yup does say SiS at start up, not sure what version though. Can I get OpenGL drivers, or that's it, just the card won't take it?

Back to Desktop Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums