General discussion

Locked

lpt1 with NT ws and Novell

By George ·
Hi,
I seem to have a weird problem on my NT4 SP6a workstation.
LPT1 is gone!
I installed the PC in a Novell network. The Novell-login script would redirect (capture) LPT1 to a network printer. Since the user often wants to use his color inkjet, attached to the only printerport on his machine, I made a small batchfile in which the capture is cancelled. And another to capture it again.
Mind you: this capture to lpt1 is necessary for some DOS-programs that will only print to lpt1. I can't alter that.
This situation was acceptable for the user.
After about two months it wouldn't work anymore.
After deleting the capture we weren't able to print to lpt1 anymore.
Not even from the command prompt with: dir > lpt1
So I installed another PCon this workplace.
Worked again fine for a couple of weeks.
Then the misery began again.
I started with a DOS-bootdisk: no problem with dir > lpt1.
So it can't be a hardware error.
It looks like some program is altering the registry or something.
I'm not able to find it.
Anybody any suggestion?
TIA
George

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

lpt1 with NT ws and Novell

by tommymcbrayer In reply to lpt1 with NT ws and Novel ...

I take it you are using que based printing? If you go and look at a printer properties and look at the ports is there an lpt1? If not you can add one there. First I would remove the local and the network printers. I would also take the redirect out of the login script. I would then add the local printer and verify printing (may have to reinstall the printer port for this to take effect) then add the network printer. Your batch file to capture a network printer should be something like: NET USE LPT1 \\server name\printer que name
example: NET USE LPT1 \\OZ\MEDCL_Q
Set the local printer to default. When the user needs the DOS program have them run the batch file. When they exit the DOS program have them run another batch file: NETUSE LPT1 /DELETE. This will terminate the network printer capture and they can then print to the local which is set as default. I am using this with success for our legacy DOS app.

Collapse -

lpt1 with NT ws and Novell

by George In reply to lpt1 with NT ws and Novel ...

that's what I did before. It worked.
But, and that's the problem, after some weeks it didn't work anymore.
How come? How to restore the former settings?
Thanx for thinking with me.

Collapse -

lpt1 with NT ws and Novell

by flan In reply to lpt1 with NT ws and Novel ...

do you know how to use the net use command? that will solve all your problems type net use /?

Collapse -

lpt1 with NT ws and Novell

by George In reply to lpt1 with NT ws and Novel ...

Yes, it worked, but not anymore.
That's the problem.

Collapse -

lpt1 with NT ws and Novell

by flan In reply to lpt1 with NT ws and Novel ...

do you know how to use the net use command? that will solve all your problems type net use /?

Collapse -

lpt1 with NT ws and Novell

by George In reply to lpt1 with NT ws and Novel ...
Collapse -

lpt1 with NT ws and Novell

by George In reply to lpt1 with NT ws and Novel ...

This question was closed by the author

Back to Windows Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums