Mac OS

Question

Macbook pro 2010 not booting CMD R not working either

By DougieBt ·
Tags: Apple, Mac
Hi, hoping someone can help.

I've got a 15" 2010 Macbook pro. I was having a few glitch issues with applications not loading which later became to an erratic booting and random shutting off and restarting of the mac. I thought this was an issue with the OS becoming corrupted so I was looking to reinstall this off a USB installer I had previously created.

The issue I have is that CMD R is not working (or any other key chain commands on the boot cycle) and skipped straight to booting. That was until a week after the initial issue when the system got stuck at 90% of loading. Most recently it has started flashing the question mark folder icon indicating the HD is not recognised.

I have purchased a replacement Hard Drive to see if this would enable a CMD R, this didn't recognise or allow the Macbook to boot into recovery. I have also purchased and replaced the hard drive cable as a fault find in case I damaged this swapping hard drives (due to the question mark folder icon).

Whilst CMD R isn't working, the caps lock light does turn on and off and the key chain was working when it previously loaded straight to the OS. This leads me to think the keyboard is absolutely fine.

Can anyone suggest any other fault fixes or is this likely to be linked to a logic board failure?

Many thanks,

Doug
Thread display: Collapse - | Expand +

All Answers

Collapse -

Odd

by appltech In reply to Macbook pro 2010 not boot ...

That is very odd indeed. I'd go for resetting NVRAM first. Look up Apple's article online, since the process is different for different models.

Also, while I haven't tried it myself, but it might work: boot into single user mode (hold Command+S keys at startup) and from there follow this: https://apple.stackexchange.com/questions/367336/can-i-initiate-a-macos-restart-to-recovery-mode-solely-from-the-command-line/367367
to try to force booting into recovery.

Also, also, try Internet Recovery mode (Cmd+Opt+R) and see what happens.

Also, also, also, while in most cases it's useless, try Apple Diagnostics (hod the D key on startup).

Collapse -

Thanks

by DougieBt In reply to Odd

Thanks for your response and suggestions. It's really appreciated.

The reset NVRAM did work, it chimed twice and restarted. I guess this proves the keyboard works which ticks one variable off the list.

Unfortunately, CMD R didn't then work, internet recovery didn't work and neither did the diagnostics suggestion. I tried all of these ideas on both the old and new hard drive to see if that makes a difference, sadly not.

I guess disk utility is built into the hardware, could it be this has been corrupted somehow and that's why it's not allowing CMD R to run?

Collapse -

Have you tried the CMD+Option key route?

by mrmacfixit Moderator In reply to Thanks

Keep them held down until, hopefully, the screen shows a choice of drives to boot from.
It does not mean that there is a valid system on whatever drive appears at the bottom of the screen.
With the USB drive attached, you may be able to choose and boot from it.
The flashing question mark does not mean that the drive is not recognized, it means that the firmware cannot find a valid MacOS system on the drive. That said, it appears that you also get the same question mark with a new drive which gives hope for the state of the original.
Clutching at straws here; you obviously are not afraid to open the Mac, so do so and disconnect the battery. Once done, press and hold the power button for around 30 seconds. Reconnect and try the boot again.
P

Related Discussions

Related Forums