General discussion

Locked

Mandatory Profile Desktop Icons

By dpcupples ·
I'm running windows 2000 server with windows professional workstations. Since this is a computer lab lots classes need to log in. Each class has their on mandatory profile, part of that are shortcuts to applications that are on the desktop. Frequently the icons for the shortcuts go blank and don't refresh any more.
This happens with applications that are on a mapped network drive. How do I prevent that?

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by ManISKid In reply to Mandatory Profile Desktop ...

We had a similar problem with this becuase the 'my documents' was placed on the network drive, and accessing this took some time to carry out.

An idea is to redirect the 'my documents' to the local computer to prevent excess network traffic and delays such as those described.

NB I am actually thinking of the user profiles.

A downside to this is that saving files will be to the local computer, but this can be remedied in many ways such as diverting save locations or overwritting computer files.

Collapse -

by sgt_shultz In reply to Mandatory Profile Desktop ...

u are losing the icons cuz u are losing the mapped drive connection imho. i suggest go to support.microsoft.com and search kb under windows 2000 server for "mapped drive" see what looks good. i picked this one for u HIH
<snip>
Mapped Drive Connection to Network Share May Be Lost
Article ID : 297684
Last Review : October 11, 2003
Revision : 5.0
SYMPTOMS
On a computer that runs one of the versions of Windows that is listed at the beginning of this article, if you map a drive to a network share, the mapped drive may be disconnected after a regular interval of inactivity, and Windows Explorer may display a red "X" on the icon of the mapped drive. However, if you try to access or browse the mapped drive, it reconnects quickly. This behavior occurs if the network share computer runs Microsoft Windows NT 4.0, Windows 2000, or Windows Server 2003.
CAUSE
This behavior occurs because Windows NT Server 4.0, Windows 2000 Server, and Windows Server 2003 can drop idle connections after a specified time-out period (by default, 15 minutes) to prevent wasting server resources on unused sessions. The connection can be re-established very quickly, if required.
<snip>

Collapse -

by sgt_shultz In reply to

<snip>
RESOLUTION
To resolve this behavior, change the default time-out period on the shared network computer. To do this, use one of the following methods.

NOTE: You cannot change the default time-out period for Microsoft Windows 95-based computers and Microsoft Windows 98-based computers that have shared resources.
Registry Editor
NOTE: You cannot use this method to turn off the autodisconnect feature of the Server service. You can only use this method to change the default time-out period for the autodisconnect feature. <Registry Editor Warning Here>
Use Registry Editor to increase the default time-out period. To do this, follow these steps, and then quit Registry Editor: 1. Click Start, click Run, type regedit (Windows 2000 or Windows Server 2003) or type regedt32 (Windows NT 4.0), and then click OK.
2. Locate and then click the following key in the registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
3. In the right pane, click the autodisconnect value, and then on the Edit menu, click Modify. If the autodisconnect value does not exist, follow these steps: a. On the Edit menu, point to New, and then click REG_DWORD.
b. Type autodisconnect, and then press ENTER.
4. Click Hexadecimal.
5. In the Value data box, type ffffffff, and then click OK.

Collapse -

by sgt_shultz In reply to

<snip>
Command Line
NOTE: If you use this method, you may turn off the autotuning feature for the Server service.

To change the default time-out period for the autodisconnect feature of the Server service, open a command prompt, type the following line, and then press ENTER
net config server /autodisconnect:number
where number is the number of minutes that you want the server to wait before it disconnects a mapped network drive. The maximum value for this command is 65,535.

NOTE: If you set the autodisconnect value to 0 (zero), the autodisconnect feature is not turned off, and the Server service disconnects mapped network drives after only a few seconds of idle time.

To turn off the autodisconnect feature, open a command prompt, type the following line, and then press ENTER:
net config server /autodisconnect:-1
.
MORE INFORMATION
Some earlier programs may not save files or access data when the drive is disconnected. However, these programs function normally before the drive is disconnected.

For additional information <snip> view the articles in the Microsoft Knowledge Base:
138365 How Autodisconnect Works in Windows NT and Windows 2000
128167 Server Service Configuration and Tuning
</snip>
pant pant

Back to Windows Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums