Question

  • Creator
    Topic
  • #2252816

    Mapping a linux drive on Windows and getting it to “Stick”

    Locked

    by hansoffate ·

    I am trying to map a drive on Windows and get it to stick. Right now it is mapping, but as soon as the user logs off and logs back on, it is there but it says disconnected. We have to go there, and set it up again. Any ideas?

    Thanks,
    -Hans

All Answers

  • Author
    Replies
    • #2507996

      Clarifications

      by hansoffate ·

      In reply to Mapping a linux drive on Windows and getting it to “Stick”

      Clarifications

    • #2914379

      Auto mounting a partition as a MS/Linux swap area

      by mickey6 ·

      In reply to Mapping a linux drive on Windows and getting it to “Stick”

      You can have more control on mounting a file system like /home and /tmp partitions with some nifty options like noexec, nodev, and nosuid.

      This can be setup in the /etc/fstab text file. The fstab file contains descriptive information about the various file systems mount options; each line addresses one file system. Details regarding to security options in the fstab text file are:

      defaults: Allow everything quota, read-write, and suid on this partition.

      noquota: Do not set users quotas on this partition.

      nosuid: Do not set SUID/SGID access on this partition.

      nodev: Do not set character or special devices access on this partition.

      noexec: Do not set execution of any binaries on this partition.

      quota: Allow users quotas on this partition.

      ro: Allow read-only on this partition.

      rw: Allow read-write on this partition.

      suid: Allow SUID/SGID access on this partition.

      For more information on options that you can set in this file fstab, see the man pages about mount(8).

      Edit the fstab file vi /etc/fstab and change it depending on your needs.
      For example:

      /dev/sda11 /tmp ntfs defaults 1 2
      /dev/sda6 /home vfat defaults 1 2

      For our example above, the /dev/sda11 represent our /tmp directory partition on the system, and /dev/sda6 the /home directory partition. Of course this will be not the same for you, depending on how you have partitioned your hard disk and what kind of disks are installed on your system, IDE -hda, hdb, etc or SCSI -sda, sdb, etc.

      Once you have made the necessary adjustments to the /etc/fstab file, it is time to make the Linux system aware about the modification.
      This can be accomplished with the following commands:

      [root@deep] /#mount -oremount /home/
      [root@deep] /#mount -oremount /tmp/

      Each file system that has been modified must be remounted with the command show above. In our example we have modified the /home/, and /tmp/ file system and it is for this reason that we remount these file system with the above commands.

      On future booting the mounting will be automatic.

      Hope this is what you were looking for.
      Have phun….

    • #2914357

      authentication

      by loonit ·

      In reply to Mapping a linux drive on Windows and getting it to “Stick”

      This actually sounds like an authentication issue. Are you mapping the drive as Administrator then logging off and logging back in as the user? Try the “connect using a different user name” option and put the user creds in. If your not on a domain, try placing the machine name in front of the user name in the user name field so like machinename\username. If its on a domain then domainname\username
      and whatever password you set up in linux for the users to access the file share.

    • #2914068

      Mapping a drive on windows and getting it to “Stick”

      by tsadowski ·

      In reply to Mapping a linux drive on Windows and getting it to “Stick”

      I am going to assume you mean that you are mapping the Linux drive over the network via Samba or some such.

      If you are using the command line to map it (net use) you just add the “/persistent:yes” switch to the map command and it will retain it. If you are using the windows map, check “reconnect at logon”. If neither of these hold for some reason, perhaps creating a batch script that does the net use command and putting it in the Startup group, would help.

      If none of this applies, please clarify what you are doing and what steps you are taking to do it.

Viewing 3 reply threads