Question

Locked

Member of domain admin group but don't have local admin rights on Windows 7

By Chris.Rothwell ·
I am a member of the domain admins group on my W2k3 server (DC), when I login to my new Windows 7 Enterprise machine with my domain admin account I have no local admin rights. I can't register Active X files or perform installs! I've added the domain admins group into the local groups on my machine and I've also added my domain account into the administrators group on this machine but still no joy.

Does anyone know why this is?

Thanks,

Chris

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

You

by Wizard-09 In reply to Member of domain admin gr ...

Need to add the domain admin account to the local machines users group hope this helps you out.

Collapse -

Domain Admin Problem

by Chris.Rothwell In reply to You

Thanks for that, I've tried this out and still no joy. Do I need to update the AD or the domain to force the change to take affect? I've tried restarting the machine and I've also logged off several times but still no change. If I do need to refresh the domain, how do I do that?

Thanks for your help so far, much appreciated!

Collapse -

No you don't

by Wizard-09 In reply to Domain Admin Problem

Need to restart the domain, have you tried a restart of the machine, so what you have done is log on to the local machine with local admin rights, added your domain admin account to the admin users group on the local machine that should work?


log in to each "test" PC as the local admin
Go to "Control Panel", "User Accounts"
Go to "Manage User Accounts", then the "Advanced" Tab
Click on the "Advanced" button in the middle of the form
Open the "Groups" folder, then double-click on the "Administrators" group.
Click "Add", then add the relevant user (Username@Domain)
OK (etc) to close all the windows.
Log off the local admin account, then log in to the domain user and test.

Hope it helps

Collapse -

Yes that's what I've done

by Chris.Rothwell In reply to No you don't

Having logged onto my machine with the local admin account that existed in Windows (which I had to enable from local users and groups) I have added my domain user account into the administrators group and then restarted the machine and still no joy.

I can see the domain user account in the list of local admins and I'm really confused now!

I'm having a few other issues with this installation of Windows 7 so I'm wondering if there's a bigger problem here. I'm going to back up the recent files that I've used and then reinstall the OS to see if that fixes the issue. I'll get back to you once I've tried this to let you know if it has resolved the problems.

Thanks again for the advice so far!

Collapse -

Strange

by Wizard-09 In reply to Yes that's what I've done

That should have worked, adding the domain account to the local admin group.

Collapse -

Same problem

by gwhenning In reply to Member of domain admin gr ...

Both "domain admins", and my username are listed in the local administrators group.

Back to Networks Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums