General discussion

Locked

Messages held in queue in E2K

By chipw ·
I just set up E2K and tried some test messages, they are being held up in the queue. I cannot get them to send to the recipient. DNS is not a problem. Relaying is not a problem.
Any suggestions on what to check?

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Messages held in queue in E2K

by chipw In reply to Messages held in queue in ...

I have done the following to configure smtp ( as per 319426 - HOW TO: Configure the SMTP Connector to Link to Internet Domains in Exchange 2000 from microsoft/technet) -
# Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
# Double-click on the Servers icon in the left pane.
# Click the server that you want to configure, and then expand Protocols.
# Right-click either the default SMTP virtual server or the virtual server that you just created, and then click Properties.
# Click the Access tab, and then click Relay.
# Confirm that Only the list below is selected and that the list is empty.
# Click the Delivery tab, and then click Advanced.
# Click Configure to configure external DNS servers for this virtual server.
<cont on next comment>

Collapse -

Messages held in queue in E2K

by chipw In reply to Messages held in queue in ...

Then I did this for the connector:
# Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
# Right-click the Connectors container, point to New, and then click SMTP Connector.
# Type a name for the connector in the Name box.
Under Local Bridgeheads, click Add, click the virtual server that you configured in the "How to Configure the SMTP Virtual Server" section, and then click OK.
# Click the Address Space tab, click Add, click SMTP, and then click OK.
# In the Internet Address Space Properties dialog box, confirm that you entered a wildcard character (*) so that messages to all domains are routed through this connector.
Then I added mx and a records to this machines dns. I have tested dns like this, at the command prompt:
ls -t mx <machine domain>
and other addresses and it works fine. The company firewall allows everything outbound.
I find this an interesting statement (found in
266686 - XCON: How to Configure a SMTP Virtual Server Part 1 on microsoft/technet) -
After you install Exchange 2000, the SMTP service is ready to process e-mail. No further configuration is required to send and receive e-mail.
Hmm, then why doesn't my install, default W2K Enter. Srvr/E2Ksp3 send email?

Collapse -

Messages held in queue in E2K

by curlergirl In reply to Messages held in queue in ...

OK - you've finally given a key bit of information that may be significant. You say that the company firewall allows everything outbound, but how about INBOUND? In order for SMTP to send email, it has to receive acknowledging messages back from theSMTP server at the other end. It will not be able to send unless it gets an acknowledgement back. What exactly happens is that to initiate the message transfer, the Exchange server sends a query - EHLO or HELO - to the receiving SMTP server. If itdoesn't get an OK (250) back, it will not proceed and will assume that the receiving server is down or does not exist. All of this communication happens over port 25. If port 25 is not open inbound as well as outbound, it will not be able to send email. Check this out on your firewall and if SMTP (port 25) is not open inbound, then you must open it and have the packets forwarded to the IP address of your Exchange server. Hope this helps!

Collapse -

Messages held in queue in E2K

by curlergirl In reply to Messages held in queue in ...

Additionally - on your MX record, is the DNS server you are querying the authoritative server for your domain, that is, is it the name server that is listed with the company that has your domain registration? The MX record must exist on the authoritative server for your domain. If your internal server is not authoritative for the domain, then you have to contact whatever company hosts this name server and have them add the MX record to their DNS server(s). Hope this helps!

Collapse -

Messages held in queue in E2K

by curlergirl In reply to Messages held in queue in ...

Regarding your comment on setting up the SMTP virtual connector - when you install Exchange2K, a default SMTP virtual server is usually set up and configured with the most common settings automatically during the install. The only things you usually have to configure after that are things that are specific to your install, such as DNS server addresses, etc., and any customized permissions, relaying or connections settings you want to use. If this didn't happen, then perhaps your install is corrupted in some way and you should remove everything and start over.

Collapse -

Messages held in queue in E2K

by chipw In reply to Messages held in queue in ...

Got it working. Had to switch to a gateway/firewall that had port 25 open.

Collapse -

Messages held in queue in E2K

by chipw In reply to Messages held in queue in ...

Thanks for the tips. I have sent a message to the firewall admin, he's in Norway. Hopefully he'll answer in the next few days.

Collapse -

Messages held in queue in E2K

by chipw In reply to Messages held in queue in ...

This question was closed by the author

Back to Software Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums