General discussion

Locked

Microsft Access

By fred ·
Error message "The decimal fields precision is too small to accept the numeric you attempted to add". Can this be changed? We have tried Tools/Options.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Microsft Access

by Stillatit In reply to Microsft Access

When you created the field and called it a number, you implicitly selected a type. In design view you can see this type in the Field Size property for the field. The default is long integer, which stores integer values from -2,147,483,648 to +2,147,483,648. If the number you put in is bigger or smaller than this, you will get an error. If you selected type Integer, the range is -32,768 to +32,767. Look at Access help on the "FieldSize" property.

You can change the field type in the design view, but I do not know what this will do to the data already in the database.

Good luck.

Collapse -

Microsft Access

by fred In reply to Microsft Access

I apologize, the error occurs when importing an ODBC table and fields are not defined yet in database.

Collapse -

Microsft Access

by Bob Sellman In reply to Microsft Access

If you are using the import function, you may be running into problems because Access may be automatically defining that field as a single precision field, rather than double precision,in the new table it automatically creates. There are a few methods I would suggest trying to solve your problem.

If possible, try linking to the ODBC table, rather than importing. You should then be able to see the data and copy it to a table you set up in Access. You have to define the table yourself, thenopen the source table, mark all rows (<Ctrl><A&gt and copy them into the destination table that you have defined in Access.

As an alternate possibility, I would suggest defining a destination table with the correct fields, making sure that the problem field is defined as a double precision. Then import the data from the ODBC table into the table you have defined.

A third option to try if one of the first two don't work, is to attempt to set up a table in Access with the offending field temporarily set up as a text field of a maximum length of at least 50 characters. If that's the only way you can convince it to import the data, then after doing that then add a numeric field to the table and try converting the data in the text field into numbers to go into the numeric field.

Back to Web Development Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums