General discussion

Locked

Microsoft Access 2000 security problem

By *PeterG* ·
I set up a small test database and, using the security wizard, set up database security on the test file (2 tables, 1 query, 1 form, 1 report). When I now try to open the Test.mdb file, the system tells me I do not have the necessary privileges to open the file ("Contact your system administrator" PS: I AM the system administrator!) I am also the Creator & the Administrator of the file. My Windows 2000 Profile that I have used is normally set to Power User, but even when I change that to Administrator, nothing seems to work.

How do I open this "permanently secure" (ha-ha) database? And, if I want to just get rid of the test.mdb file, I now also have a Secured.mdw file to deal with. Can I simply delete these two files and start all over again or is there some other potential problem lurking in the wings if I should do this (like Registry problems)?

By the way, the security setup has 4 Groups: Admins, New Data Users, Read-Only Users, and Users. For Admins & Users, the Group ID was "previously created" (according to the "One-Step Security Wizard Report"); the other two Group IDs were assigned mixed alphanumeric IDs at the time of setup.

I would appreciate your help with this problem. Many thanks.

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Where are the files

by tp1955 In reply to Microsoft Access 2000 sec ...

Where are you storing the mdb and mdw files, on a server or on your workstation. I seem to recall something similar and permissions on the root of c: on the workstations were restricted. Just a thought.

Collapse -

user level security

by paul.gretes In reply to Microsoft Access 2000 sec ...

You have probably solved your problem by now, or have given up. After you run the User level security wizard you can't access you database directly. The wizard will ask you how you want to access it. Generally there are 2 options. Make the workgroup you are creating your default workgroup file. Or create a shortcut on your desktop, and you can only access the database from the shortcut.

-hope this helps
paul

Back to Security Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums