Microsoft Desktop wireless Problem

By davide ·
Hello to all,
i write from italy so sorry for my english.
I have a problem from few days that I cannot find answer.
I have a PC, mobo asrock with nforce mcp61, gforce 6100, sataII etc, with amd64 5000+. All system have last drivers n firmware.
I bought a "micorosoft wireless optical desktop 1000", it include receiver 2.1, mouse wireless 2000, and keyboard wireless multimedia.
I install before the cd with drivers, after when i plug the receiver, my OS (ms win xp pro sp2) say "uknown usb hardware", i try the wireless set in my notebook toshiba satellite an work great, with the same OS.

So what is the problem? I plug the receiver trought USB n not with ps2 adapter. I try last drivers, i try to remove the "classic" mouse n keyboard, buy usb not understand my receiver (for what i know it not need drivers, drivers i loaded is for keyboard n mouse)

A yes, all others USB things, like wi-fi pen, memory pen, card readers works in the usb ports, so i cannot think is a usb problem.

Please help me, i dunno what doing more (((


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

re: install

by ThumbsUp2 In reply to Microsoft Desktop wireles ...

Did you follow the instructions for installing the keyboard/mouse? Sometimes, the instructions say that you need to run the CD installation package before you plug in the device and then what to do when Windows sees the new hardware.

Collapse -

yes i follow

by davide In reply to re: install

yes i follow the instruction, before install cd, after reboot n plug the usb, nothing. i think is a bug of the mobo also if have last drivers n firmware of bios

Collapse -

Extactly the same problem here...

by tepes4 In reply to yes i follow


First of all i tried to install the software after it was completely installed it asked me to restart the pc and after doing that i plugged the receiver in. The lights were blinking in sequence but when i tried to connect the keyboard and mouse, nothing happened. After a complete uninstalation and reinstallment of the drivers (including a restart) still no joy.
I tried looking for another set of drivers from the ones that were on the cd but there are none ( i have version 6.2). I used the desktop set in another computer and it all works well. However the main difference is that the computer that i want this set to be installed had previously another desktop (keyboard & mouse set, made by microsoft).
The only reason that i can think of, that my device does not work is that there has been some mix-up with the drivers from the previous set of keyboard and mouse. However, there are no drivers installed for them since i uninstalled them all.

Could somebody please give me a hint as to why this happens?

Thank you very much!

Collapse -

Have a look in ...

"Device manager" you might see a red or yellow tag next to it, if it has then right click on it and select "update drivers > browse computer for drivers" then select one of the drivers from the list, if you do not see any drivers listed then re-install them. Make sure that in your "bios", (bootup your computer and press either "F1 or F2" key on your keyboard or whatever key that relates to your "bios") under the usb section that the boxes are marked either "enable or Legacy", then re-boot your system and then see if your keyboard and mouse work. You might have to attach a "PS2" keyboard to your computer if the usb one does not work in the bios.
Hope this helps you.

Please post back if you have more problems or questions.

Collapse -

Tried it, no joy

by tepes4 In reply to Have a look in ...


Thank you for your help but unfortunately it did not work. I gave up and I have ordered a new desktop set to try my luck with another brand.

Thank you very much for your help anyway!

Related Discussions

Related Forums