Question

Locked

Microsoft Visual C runtime error Vista Internet Explorer 8

By ralphbar ·
Hi,

I have a particularly sticky problem I'm trying to solve.

I'm running 32 bit Vista Home Premium with IE8. I've installed all updates including Vista SP2.

When logging onto AOL e-mail, and also some other web pages (example: http://www.indianrail.gov.in/inet_metro_trns.html ), I get the following error message:

-----------------------------------
Microsoft Visual C++ Runtime Library

X Runtime Error!

Program:C:\Program Files\Internet Explorer\iexplore.exe

This application has requested the Runtime to terminate it in an unusual way.

Please contact the applications support team for more information.
-----------------------------------

The problem does not show when running in Safe Mode and also does not show up in Firefox.

Online research has suggested numerous causes for this and I have done the following:

Add-ons
Have used the add-on manager to disable all of them - have also run IE (no add-ons).

Anti-virus/Firewall/Spyware etc. - McAfee Security.
Have removed it and run McAfee's clean-up

Adobe reader
Have installed latest version.

Temporary files
Have cleaned out Windows/Temp and emptied the recyle bin

IE8
Have run Tools/Internet Options/Advanced/Reset

Anyone got any ideas for what to try next?

Thanks!

Ralph.

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Switch to Compatibility Mode.......

by ThumbsUp2 In reply to Microsoft Visual C runt ...

The pages you're trying to view haven't been coded for IE8, so make the browser pretend that it's viewing the page as if it were IE7.

The Compatibility Mode button is just to the right of the address bar at the top.

As for AOL email, have you installed the latest AOL browser (what version?), or are you simply visiting AOL with the default IE browser? If I'm not mistaken, AOL still requires use of THEIR browser to access their system.

Collapse -

Compatibility Mode - No Change

by ralphbar In reply to Switch to Compatibility M ...

Hi ThumbsUp2 - thanks for your reply.

Unfortunately Compatibility Mode makes no difference. Also, I am able to view these pages correctly in IE8 on a different PC running Vista and on the suspect PC using Firefox - so AOL doesn't require the use of their own browser.

Ralph.

Collapse -

Check Alan Edwards post

by Jacky Howe In reply to Microsoft Visual C runt ...

http://www.microsoft.com/communities/newsgroups/en-us/default.aspx?dg=microsoft.public.internetexplorer.general&tid=df5edd55-ef14-4362-b4c4-e62355d60f88&cat=&lang=&cr=&sloc=&p=1

Collapse -

Have reset IE8 - No Change

by ralphbar In reply to Check Alan Edwards post

Hi Jacky - thanks for your reply.

I had already followed all the varous steps that Microsoft suggest in these articles. Sadly, none make any difference!

Collapse -

OK

by Jacky Howe In reply to Have reset IE8 - No Chang ...

no Toolbars installed.

Use the Internet Explorer (No Add-ons) mode
To do this, click Start, point to All Programs, point to Accessories, point to System Tools, and then click Internet Explorer (No Add-ons).

If this resolves the issue, follow these steps to isolate the browser add-on that is causing the issue:
1. Click Tools, and then click Internet Options.
2. Click the Programs tab, and then click Manage add-ons.
3. Click an add-on in the Name list, and then click Disable.
4. Repeat step 3 until you identify the add-on that is causing the issue.


Try disabling IE8 memory protection
Start, Control Panel, Internet Options, Advanced, Security, uncheck Enable memory protection to help mitigate online attacks.

Try creating another User account to check for a corrupt profile.

Collapse -

You say that it works in safe mode

by Jacky Howe In reply to Have reset IE8 - No Chang ...

Click Start, type msconfig in the Start Search box, and then press ENTER
The System Configuration Utility dialog box is displayed.
Configure selective startup options
In the System Configuration Utility dialog box, click the General tab, and then click Selective Startup.
Click to clear the Process SYSTEM.INI File check box.
Click to clear the Process WIN.INI File check box.
Click to clear the Load Startup Items check box. Verify that Load System Services and Use Original BOOT.INI are checked.
Click the Services tab.
Click to select the Hide All Microsoft Services check box.
Click Disable All, and then click OK.
When you are prompted, save the settings and restart the PC.

you will need to re-enable the items in the Startup and Services list one or two at a time in order to identify which one is causing the problem reboot each time you change something. Try enabling one or two startup entries at a time to isolate the problem.

After you complete your troubleshooting and fix your configuration, return to a normal startup. To do this, follow these steps:
Click Start, type msconfig in the Start Search box, and then press ENTER.

If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
On the General tab, click Normal startup, and then click OK.
Click Restart.

Collapse -

Fixed... sort of

by ralphbar In reply to You say that it works in ...

Hi Jacky,

Thanks for these ideas. Before I tried that I discovered that the option to disable memory protection was grayed out and the only way to change it was to run ie8 as administrator. As soon as I right click IE and run as administrator the C++ runtime error goes away!

Now all I need to figure out is how to make IE8 run as admin by default grrrrrr

Collapse -

There are articles

by Jacky Howe In reply to Fixed... sort of

on TR that tell you how to do this but I can't find them. See if you can get it to work through a shortcut.

http://www.howtogeek.com/howto/windows-vista/always-start-an-application-in-administrator-mode-on-windows-vista/

Collapse -

Try This ...

by Amnezia In reply to Fixed... sort of

There's a hotfix for the Viscual C++ library used on some Dell PCs. There's a file called vcredist_x86.exe (or vcredist_x64.exe for 64bit systems)which fixed an similar issue for me on a new Dell laptop. May work for you.

Collapse -

Here's a link...

by Amnezia In reply to Try This ...

http://tinyurl.com/lpobwc

Hope this helps.

Back to Browser Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums