General discussion

Locked

Migrating Group Permissions

By dgagne ·
Last Saturday I scheduled a data migration and was going to do it using Backup Exec 8.6 by backing it up from the old machine and restoring it with NT security to the new machine. Well all of the data came over fine but none of the local group permissions did. I tried running XCOPY /E/H/K/O/X from the W2K machine and all of the data came over with the permissions but when I copied an existing user account and ran a test I was denied access to certain folders. I ran SHOWACLS /S /U on the testuser account against both systems, compared the permissions and they were exactly the same. I then tried using ROBOCOPY /MIR /SEC and got the same results, data with permissions migrated fine but was denied access to certain folders on the new machine even though I can access everything on the old machine with no problems.
Here is the environment:

Old server ? HP LH4r running NT 4 sp 6a, BDC & File server

New server ? Compaq Proliant ML 570 Running W2K SP3, File Server

Both are running in an NT4 domain. We have a W2K domain running and have been in the process of migrating user accounts over using Fastlane. The test user accounts that I tried are running in the NT4 domain.

Anyone out there understamd what I'm missing?

This conversation is currently closed to new comments.

1 total post (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Migrating Group Permissions

by rapidad In reply to Migrating Group Permissio ...

when you go from one machine to another you change the sid (system identifier) associated with the nic card. This causes the policy editor to refuse logon for that user. This also manifests itself when using ghost images. Usually going into network properties and re-adding the box to the domain restores the proper trusts for the nic card. I think your use of drive coping is the same as restoring an image and hence the server thinks you are out of sequence and denies the old trust relationship. On windows 2k server this actually causes an error box to pop up on the server explaning this. Look in your server event viewer for anolomies listing this problem.

Back to Windows Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums