General discussion

Locked

missing icons of external (usb) drives

By charlesporcaro ·
The drive letter icons do not show up in 'my computer' for external USB drives either flash or hard drive. Works ok in other Windows XP home machines. How do I make them visible?

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by kennethsf In reply to missing icons of externa ...

By any chance are you running a network-connected computer?

Maybe the network-connected drive letters are "shadowing" the ones the USB drives are assigned to.

You can right-click on My computer, then choose Manage and from the window that opens, choose "disk management" (you have to be VERY careful here, since playing with the wrong drives could render data in your computer drives unusable) Now search for drives mentioned as "removable". Chances are you'll find your USB drive there, just sharing the same drive letter as one of your network drives. Right-click on that USB drive and choose "change drive letter and paths", then choose a letter (preferably from Z: upwards) that is not assigned to the network drives (you can check network drive letters by opening "my computer")
Accept the changes (again on the USB drive, don't touch anything else) and your drive will appear on "my computer" as soon as you press F5

You'll have to repeat the same routine for each USB drive you happen to have, even if it's the same model: it's better to choose a different drive letter for each, just in case. (USB devices are serialized, thus individually treated by windows)

Well, it's funny that in a full-blown network operating system like this, the automatic drive letter assignment system does not recognize the network-assigned letters as "already in use", isnt' it?

HTH

Ken

Collapse -

by kennethsf In reply to

BTW: if this doesn't do the trick, then go again to "my computer", right-click, then choose properties > hardware > Device Manager And open the "Universal Serial Bus controllers" branch, Are your devices being correctly recognized? If not, then check the BIOS settings to verify they are, in fact, enabled (reboot the computer then enter BIOS setup). If they are, then select "USB root hub" > right click > properties > driver > update driver, and let your computer download them from the Internet. Maybe this should work.

Ken

Back to Hardware Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums