Question

Locked

Mounted directory Permissions

By unclebyron ·
I mounted a Windows 2000 server shared directory called Public onto a Linux computer running Red Hat Enterprise Linux ES kernal 2.6.9-42. I can copy/move files into the directory from the Linux box only when I am running as root. When I am an ordinary user on the Linux box, I'm denied permission. The Windows Public directory is shared out with full privleges to the Everyone group both locally and on the domain. I've tried creating an account on the Windows box with the same login/password as the ordinary user on the Linux box with full rights to the Public directory but it still fails. From the Linux box, I tried as root to chown and chmod on the mounted Public directory to the ordinary user but it wouldn't change anything. I suppose because it was a mounted directory. I still shows:

drwxr-xr-x 1 root root 4096 Jan 6 16:19 Public

If I create a directory on the Linux box and make the owner the ordinary user, as soon as it is made the mount directory, the rights become what you see above again.

I've heard of linking an Unix/Linux account with a Windows account using the command smbadduser but it wasn't on my Linux distribution.

What can I do to give the ordinary user on the Linux box permission to copy/move files to the mounted Public directory?

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

your best bet

by Jaqui In reply to Mounted directory Permiss ...

is to change the mount command to be nosuid for the mounted volume.

the MS NTFS used by windows [ all nt family products at least ] has poor permissions, since all windows stuff is always "administrator" root is the only user that gets write access on linux unless the mount doesn't set the user bit.

Collapse -

Thank you

by unclebyron In reply to your best bet

Thanks...I will keep that in mind......
I did find another way....I mounted the directory as CIFS and specified the linux account I wanted to use as the owner of the mounted directory using the username= option. This account can write to it now...

Back to Networks Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums