General discussion

  • Creator
    Topic
  • #2092389

    MS-DOS Compatability Mode

    Locked

    by mikehoke ·

    My wife tried to install Leisure Suit Larry, an MS-DOS based video game, and could not get it to work. Sometime after that she noticed that the CD-ROM would not work. Upon further investigation I found that Windows was running in MS-DOS Compatability mode. She is running Windows 98 and I cannot get it to recognize the CD-ROM even with a boot disk. I tried to REM out the lines in the config.sys and the autoexec.bat files and it still didn’t recognize it. I have a 20GB drive with 2 partitions 10GB each and both partitions are running in Compatability Mode (apparently she tried to install it twice, once on each partition). There are no errors in the device manager that I can see. Help!

All Comments

  • Author
    Replies
    • #3878889

      MS-DOS Compatability Mode

      by kman52000 ·

      In reply to MS-DOS Compatability Mode

      First, have you uninstalled the game? Second, you may want to try to physcially remove the CD-ROM drive and boot the machine without it, making sure it is no longer listed under Device Manager. Then try to reinstall the CD-ROM drive. To do this, you need to make sure that either Windows already has the drivers or, if there are updated drivers that you have these on a disk.

      I hope this solves your problem.

      • #3879478

        MS-DOS Compatability Mode

        by mikehoke ·

        In reply to MS-DOS Compatability Mode

        I tried everything you said and it still didn’t work. I even tried to boot from a Win98 boot disk and access the cd-rom that way but it didn’t work either. I finally decided to take out the cd-rom and switch it with another one that I had. Once the new cd-rom drive was in I was able to access it. Then I just re-installed Win98 and it worked. I didn’t lose anything that was on the HDD. It just must have been a coincidence that the game was installed and made it go into MS-DOS Compatability mode at the same time the cd-rom quit working.

    • #3878860

      MS-DOS Compatability Mode

      by shmaltz ·

      In reply to MS-DOS Compatability Mode

      if the cdrom is the problem then you will need dos drivers for the cd rom.
      if the installation is the problem then it might be that it tries to take over the systme as a lot of dos prorams do and it does not recognize the hdd since they are fomatedwith the FAT32 file fomat and thats why the dos program can not be installed.

      • #3879479

        MS-DOS Compatability Mode

        by mikehoke ·

        In reply to MS-DOS Compatability Mode

        I tried everything you said and it still didn’t work. I even tried to boot from a Win98 boot disk and access the cd-rom that way but it didn’t work either. I finally decided to take out the cd-rom and switch it with another one that I had. Once the new cd-rom drive was in I was able to access it. Then I just re-installed Win98 and it worked. I didn’t lose anything that was on the HDD. It just must have been a coincidence that the game was installed and made it go into MS-DOS Compatability mode at the same time the cd-rom quit working.

    • #3878508

      MS-DOS Compatability Mode

      by shanghai sam ·

      In reply to MS-DOS Compatability Mode

      First, check to see if “Force compatibility mode disk access” is unchecked in the advanced properties in msconfig (goto start, run and put in msconfig to get this).
      If thats unchecked, disconnect the cdrom ide cable, and reboot into safe.. To do that if you dont know, hit f8 on boot up continously until you get a start-up menu.. Inf there, goto device manager and uncheck EVERYTHING under cdrom. Shutdown and reconnect cdrom. Let windows install it when you boot up this time (normal mode). If that doesn work, check to see if it works in dos.. Get a cdenabler boot disk, boot to dos and see if you can access the drive. If you can, its windows and youll probly need to reload. If you cannot access it, reset config. data (try this before reloading windows also) in the bios.

      • #3879480

        MS-DOS Compatability Mode

        by mikehoke ·

        In reply to MS-DOS Compatability Mode

        I tried everything you said and it still didn’t work. I even tried to boot from a Win98 boot disk and access the cd-rom that way but it didn’t work either. I finally decided to take out the cd-rom and switch it with another one that I had. Once the new cd-rom drive was in I was able to access it. Then I just re-installed Win98 and it worked. I didn’t lose anything that was on the HDD. It just must have been a coincidence that the game was installed and made it go into MS-DOS Compatability mode at the same time the cd-rom quit working.

    • #3878507

      MS-DOS Compatability Mode

      by s6xtyn9ne ·

      In reply to MS-DOS Compatability Mode

      First, check to see if “Force compatibility mode disk access” is unchecked in the advanced properties in msconfig (goto start, run and put in msconfig to get this).
      If thats unchecked, disconnect the cdrom ide cable, and reboot into safe.. To do that if you dont know, hit f8 on boot up continously until you get a start-up menu.. Inf there, goto device manager and uncheck EVERYTHING under cdrom. Shutdown and reconnect cdrom. Let windows install it when you boot up this time (normal mode). If that doesn work, check to see if it works in dos.. Get a cdenabler boot disk, boot to dos and see if you can access the drive. If you can, its windows and youll probly need to reload. If you cannot access it, reset config. data (try this before reloading windows also) in the bios.

      • #3878505

        MS-DOS Compatability Mode

        by s6xtyn9ne ·

        In reply to MS-DOS Compatability Mode

        If you need help with anything else or thta doesnt work, email me at tobygri@clientlogic.com

      • #3879481

        MS-DOS Compatability Mode

        by mikehoke ·

        In reply to MS-DOS Compatability Mode

        I tried everything you said and it still didn’t work. I even tried to boot from a Win98 boot disk and access the cd-rom that way but it didn’t work either. I finally decided to take out the cd-rom and switch it with another one that I had. Once the new cd-rom drive was in I was able to access it. Then I just re-installed Win98 and it worked. I didn’t lose anything that was on the HDD. It just must have been a coincidence that the game was installed and made it go into MS-DOS Compatability mode at the same time the cd-rom quit working.

    • #3879520

      MS-DOS Compatability Mode

      by berserker ·

      In reply to MS-DOS Compatability Mode

      Download the latest driver for your motherboard chipset.
      This case happens if you have the Via or intel chipset. By installing the updated hardware *.inf will resolve the problem. If else fails , maybe you have a virus infection. Scan uaing a DOS scanner to be sure.

      • #3879482

        MS-DOS Compatability Mode

        by mikehoke ·

        In reply to MS-DOS Compatability Mode

        I tried everything you said and it still didn’t work. I even tried to boot from a Win98 boot disk and access the cd-rom that way but it didn’t work either. I finally decided to take out the cd-rom and switch it with another one that I had. Once the new cd-rom drive was in I was able to access it. Then I just re-installed Win98 and it worked. I didn’t lose anything that was on the HDD. It just must have been a coincidence that the game was installed and made it go into MS-DOS Compatability mode at the same time the cd-rom quit working.

    • #3879477

      MS-DOS Compatability Mode

      by mikehoke ·

      In reply to MS-DOS Compatability Mode

      This question was closed by the author

Viewing 5 reply threads