General discussion

Locked

MS Exch 5.5 w/SP4; Directory Problem

By gardinerdm ·
Problem: Can't modify any objects in the directory store (unless you restart server and make edits immediately). The error returned to Exch Admin is: "There is not enough space on the device, MS Exchange DS error ID no: c105001c"

In addition, theDS for this problem server will not successfully complete an online backup nor will it complete its nightly online defrag run... it errs out with 0xC800001FE Unable to write the log file.

There is plenty of free space on the disk where the DS logs and dir.edb are located. The Directory Service starts successfully and does not crash. But sometime shortly after a reboot, and a few directory edits, the directory "locks up" again with the c105001c err.

I've searched the KB to no avail. I've searched a some Exchange user group bulletin boards and have found mention of the same problem, but none of the 5 mentions appear to have been resolved.

I've run the ESEUTIL /D /DS utility a few times in an effort to defrag the DS, and it gives mefeedback that it completes successfully. But c105001c returns again every time.

I've reapplied SP4 and checked all files with MS's SPCHECK file version checker and everything appears to be SP4.

My Theories:
1. Exchange is having trouble cleaning up or overwriting edbtemp.log on the DS working path. It's not having trouble creating the first one. but it's having some kind a clean up or commit problem after this logs first use and thereafter its inablity to cleanly access this log is percieved as a disk space problem.

2. Something related to registry entrys for the Exchange PerfWiz, which I ran to move all the logs to a larger disk on the machine to eliminate any "actual" disk space constraints. There are a few interesting registry entries under HKLM\Software\Microsoft\PerfWiz that relate to disk space and log file states.

Has anyone seen this behaviour before in a Exch 5.5 Directory Store?

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

MS Exch 5.5 w/SP4; Directory Problem

by [_Rick_> In reply to MS Exch 5.5 w/SP4; Direct ...

Question:
Is there an antivirus program installed on the system which is set to scan the files and folders of the directory tree - which includes the Exchange files?

Collapse -

MS Exch 5.5 w/SP4; Directory Problem

by Shanghai Sam In reply to MS Exch 5.5 w/SP4; Direct ...

Good one!
We use InoculateIT with the exchange option... the exchsrvr directories on both hard drives for logs and dir.edb have been exempted from scans by the app itself along with its 'realtime' agent since the A/V suite was installed. I disabled the 'realtime' agent for testing and the directory will still not allow an online backup or edits to any objects... errs out with "Unable to write the log file" (edbtemp.log)

Thanks for taking the time to respond.

Thanks!

Back to Software Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums