Question

Locked

mup.sys hang

By kfrost ·
I have a dell that has XP media edition on it. About 2 weeks ago it wasn't booting up anymore. I tried booting in Safe mode and it hangs on mup.sys. I've searched online and found that the power supply is usually the culprit. I replaced the power supply and the same thing is happening. I removed the hard drive from the machine and placed it in another machine and the OS boots up with no problem. I've disconnected everything inside the machine except for the hard drive to see if it boots and I have no luck. The only other device I keep in is the USB mouse since I do not have a PS2 connection. Does anyone have any ideas or suggestions on this.

Thanks

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Other peoples solutions you can try out....

The main reasons for this Windows XP or Win 2000 boot hang or alleged mup.sys issue are:

* Hard disk failure or corruption
* A corrupted registry or registry hive
* New hardware has been installed but not did not completely "Register or re-Register" correctly
* New hardware has been installed but it is faulty or failing
* The new hardware's driver or windows itself has been compromised (Disk data corruption or by a virus) or (rare) needs to be updated
* The power supply is marginal in output or failing (Common per user feedback)
* BIOS\ESCD\Motherboard chipset driver conflict with a component, its driver, or its registry data
* Existing hardware including the motherboard may have failed in a specific way but not catastrophically.
............................................

MUP.SYS - Software Resolutions

CHKDSK /P /R
The synopsis was that the machine would get to the Windows opening screen and before loading it would lock up,
the monitor would go to sleep and the hard drive would go idle.
By trying to load Windows XP in safe mode I saw that the system locked with the last line displayed as Mup.sys.
This file is not the issue.

By configuring my Bios so I could boot via a Windows XP Install disc, I was able to load the Windows Repair Console.
Once I received the C: (DOS prompt) I entered CHKDSK /P /R and waited for the process to be completed.
This took quite a while so be patient! The issue was that there was a bad sector on the hard disc that had corrupted
data. This bad spot was now marked and repaired by CHKDSK.

Still in the recovery console I entered the command FIXBOOT at the C prompt and waited for that process to be
completed. Once that process finished, I entered the EXIT command to leave the Repair Console and rebooted the PC.
The first boot took a little while longer than normal, but when the machine came to life nothing was lost!
This procedure recovered the machine and everything is working normally.
More here:
http://www.aitechsolutions.net/mup-sys-resolved.html

Please post back if you have any more problems or questions.
If this information is useful, please mark as helpful. Thanks

Collapse -

I will try this...

by kfrost In reply to Other peoples solutions y ...

I will give this a try and see what happens. If the hard drive had a bad sector on it the OS wouldn't of loaded on another machine correct? I put the current HDD in another machine and XP media edition booted up with no problems.

Collapse -

It could be due to the motherboard chipset.

If the motherboard chipset is wrong this will keep the drive from loading also.
If possible you could try updating the BIOS and see if that helps.

Please post back if you have any more problems or questions.
If this information is useful, please mark as helpful. Thanks.

Collapse -

It also could be a faulty Memory Chip causing this to happen

by OH Smeg In reply to I will try this...

Test the installed RAM with a Memory Tester. If it fails and you have more than 1 Stick fitted try removing all but 1 Stick and test again. If it still fails replace the RAM Stick and retest.

If all the RAM Passes it is most likely to be the fact that you have different RAM Types Fitted and there is a Timing Issue arising causing the unit to hang.

You Can use Memtest
or the Mem Tester Utilities on the Ultimate Boot CD available here

http://www.ultimatebootcd.com/download.html

Mem test is available here

http://www.memtest86.com/download.html

Col

Collapse -

Tested RAM

by kfrost In reply to It also could be a faulty ...

I have 2 sticks of RAM. I tested each by removing one and than testing the other in each of the four slots.Repeated with the 2nd stick of RAM and still had the same issues. I tried removing the CMOS battery for about 1/2 hour with no luck. I've been reading that with this Model (Dell Dimension E150) that the board is usually faulty. I just ordered a new board, it should be here in a few days. I'll keep everyone posted. Thank you for your input.

Collapse -

Well you could test the Hardware while you are waiting

by HAL 9000 Moderator In reply to Tested RAM

Use The Ultimate Boot CD to look for any Faults with the existing Hardware.

http://www.ultimatebootcd.com/download.html

Remember that if the RAM is different it may still test OK but have timing issues between the 2 Sticks. These are the worst things to catch out as technically everything is working properly but when you have this happen it's very hard to find the problem.

Col

Back to Hardware Forum
6 total posts (Page 1 of 1)  

Related Forums