Question

Locked

My mouse locks up when using soundcard software

By jajogluck ·
I have verified that it happens with both a PS/2 and a USB mouse. When I run Audacity (sound recording software) and click the "record" button, the mouse immediately and mysteriously locks up. No other keyboard input is accepted either and I am forced to do a cold reboot.

At one point the mouse even locked up when I pulled the audio cord from the sound card and reinserted it. What's going on? This may not even be a mouse issue. Maybe the entire system becomes unstable as a result of using soundcard software? What's the solution?

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

OK so we know what the Sound Card is

by OH Smeg In reply to My mouse locks up when us ...

But what is the rest of the Hardware Involved here? Assuming that there are no Hardware Conflicts causing this to occur the next logical thing would be to consider Software Conflicts arising.

So we need a complete list of your Hardware and Software to rule out problems with incompatible Hardware & or Software.

Col

Collapse -

It's a ceative sound card

by jajogluck In reply to OK so we know what the So ...

The sounc card is a creative labs x-gamer 5.1 which is installed in a PCI slot. The motherboard sound card is a VIA AC97 but I am not using that one. I cannot currently furnish any software or hardware list but the only conflict I can think of is the two sound cards. But then again, this configuration has been around for years without such conflict.

Collapse -

Try disabling the onboard in the BIOS...

by ThumbsUp2 In reply to It's a ceative sound card

This will free up an IRQ and help prevent shared IRQ's between the card and the mouse.

What I would do would be to shut down, pull the Creative card out, reboot and go to BIOS first to disable the onboard. Allow the computer to then completely boot up to Windows, then shut down again and put the Creative card back in. Boot up and let Windows discover the Creative card again. Of course, during all of this, you're unplugging the power and grounding yourself properly.

Collapse -

Also remove the Realtech AC97 Drivers from the system

by OH Smeg In reply to It's a ceative sound card

It's just possible that the Windows Update Server is allocating those for this computer and a Update is causing a Software Conflict.

Col

Collapse -

temporary solution

by jajogluck In reply to Also remove the Realtech ...

I have verified that the problem is peculiar to the creative labs sound card. When I use my VIA AC97 sound card I have no problem. I also know that it's not the "mouse" that's the issue; it's the entire system that locks up in response to running software that attempts to control the creative labs sound card. I think physically removing and then reinserting the card may help as one reader suggested.

Does everyone agree that this is a "resource conflict" and not a corrupt driver issue or something else (when I tried updating the driver the installer software refused to run claiming that no "hardware compatible with the driver" had been detected).

It is noteworthy that the physical card works fine as evidenced by the output sound to the speaker when I draw a line from a casette player to the "line in" jack.

Collapse -

My tuppence worth ...

by OldER Mycroft In reply to temporary solution

It's been a couple of years since I last looked at Audacity (round about the time I'd run out of cassette tapes to copy to HD), and it's probably gone through quite a few rebuilds since then - but I seem to recall that Audacity could be 'tuned' to different sound-sources?

So maybe BEFORE you press the record button, there might be a screen header control where you could educate Audacity which sound source to record from. (What file path are you using for your Output ?)

Other than that, it has to be an interrupt problem.

Back to Hardware Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums