My partition is not set as active after sysprep, why?

By wicked_0 ·
I work in an organization that is using sysprep and ghost to currently create and deploy images. I'm currently working on an image that operates correctly until I try and unpack the image. The image is XP SP3.

The steps of importance are as follows:
1. Create image
2. Use sysprep to set options including enumerating drivers, etc.
3. Run sysprep.exe and use Reseal with mini-setup
4. Take offline image with ghost
5. Deploy to new workstation

Here is where the problem occurs. The hardware this image was built for has only 1 hard drive with only 1 partition, respectively C:. After the machine has the image deployed it gives a non system disk error. I verified that the hard drive modes are correct (IDE, sadly) and that the reference machine is operational still, which it is.

After viewing the partition table during my troubleshooting I noticed that the partition on the imaged machine isn't set as the active partition anymore, although it is the only partition listed. Once I changed the partition to active on the imaged machine, the sysprep file runs and everything works without issue. This can be repeated.

I have made numerous images and never run into an issue where the active partition is no longer set. Does anyone have a suggestion as to what might be the cause of this?

Here is the sysprep.inf that is being used for this image:

OemPnPDriversPath=\drivers\8540p\aud;\drivers\8540 p\blue;\drivers\8540p\cardr\83x32;\drivers\8540p\d rgrd;\drivers\8540p\mod;\drivers\8540p\turbo;\driv ers\8540p\turbo\x32;\drivers\8540p\usb;\drivers\85 40p\vid;\drivers\8540p\wlan;\drivers\8540p\chip











This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

2 wild guesses.

by seanferd In reply to My partition is not set a ...

Is the partition from which you are taking the image larger than the target partition?

Did you allow Ghost to extend or contract the partition?

Neither of these is good, but I can't say that they would necessarily cause the behavior you are seeing.

There could conceivable be something odd about the imaged drive - was it fully wiped before installing the OS? Maybe it used to have a recovery partition?

What about the target drives? Are they blank?

Collapse -


by wicked_0 In reply to 2 wild guesses.

The partitions are the exact same size/brand as one another.

Sysprep is set to extend the partition, but this isn't an issue since they are the same size.

The machines didn't come with the recovery partition due to the fact it is a business class machine and we get them shipped without that useless partition.

I have tried imaging to a machine without formatting the drive and with a formatted drive, same result.

I'm looking into a possible conflict with some mass storage drivers that are pulled from sysprep and will post if I find the solution.

Collapse -

Bios Change

by rjluvkc In reply to Answers

I have seen where we have needed to go into the bios and change the drive from AHCI to Compatibility mode before imaging it. After imaging change it back.
We also find just changing the MBR fixes boot issues after an image. We use this tool:
Works great! It creates a bootable usb flash drive and a utility that allows you to set the MBR on partitions...even ones that are hidden. Hopefully this helps.

Collapse -

Still not working

by wicked_0 In reply to Bios Change

I wasnt sure changing the disk from AHCI to IDE and then back just gave the same errors. I have been able to get this machine to boot by using a Windows 98 boot disk (gotta love that these are still around) and using fdisk to set the partition to active. This just isn't going to work in an environment our size and with the deployment I'm currently working on.

Thanks for the suggestions, got any other ideas?

Collapse -

OK, just to be sure,

by seanferd In reply to Still not working

you are choosing to have the partition set as active in the Ghost config when you are taking the image? IIRC, I thought this was a necessary step.

What version of Ghost are you using?

Collapse -

Correct (edit reply to next question)

by wicked_0 In reply to OK, just to be sure,

This is being set in Ghost. This has been tested with both ghost 8 and 11.

EDIT: Sorry the site won't let me add another thread. I am taking the whole disk as an image and in a nutshell the partition is not marked active after the image is taken and deployed. I can manually mark this as active with a Windows 98 disk, but I would like to find a way to automate this or correct the issue(obvious).

Collapse -

Pretty much out of ideas here. (But see edit)

by seanferd In reply to Correct (edit reply to ne ...

Hopefully, someone with more experience in using Ghost to deploy images will chime in.

The last check I would suggest, although you rather seem to know better what you are doing than I, is to make sure you are setting the imaged partition as bootable, as opposed to the ISO image. These are two rather different things, so I assume you already have this covered.

If I understand that you are imaging the <i>partition</i> as opposed to the full disk, this may be expected behavior. See the bottom post here:

Back to Networks Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums